Announcement

Collapse
No announcement yet.

2008 Road Star Running Rough

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2008 Road Star Running Rough

    I have had my 2008 R* for 8 months now. It took me a while to get used to all the noises lol. Just to give a little background on what I have done with the bike before I describe the problem. Bike had 12k miles when I got it, and has 16k now. I put in all new plugs and had the valves/rockers checked 8 months ago. Stock exhaust with holes drilled(stage 2 mod basically). Added extra holes to the airbox and put in a K&N filter. Been running 20w50 Mobil 1 since I got it. No aftermarket fuel manager.

    Now, on to the problem. Up till this last week, the bike ran great, and smooth. I could hold the throttle at any level and it was smooth with no misses. I could get it up to 100mph+ and it was pretty smooth(normally only run 80). I don't do burnouts. I'm not super aggressive or anything either. Anyway, this last weekend I went to ride the bike and I noticed there seems to be a bit of stutter/ a miss now when I hold the throttle, and anything above 80 I get a decent amount of vibration. Definitely no loss of power that I can tell though. If there is, it's so small it's unnoticeable. Tried Seafoam in a tank. Ran 2 tanks of gas through it. Probably going to check the plugs this week. Looking for suggestions. Thanks!

    Rick
    Garland, TX

  • #2
    Run 87 fuel only. Disconnect the battery for a few minutes and then reinstall it to see if things get reset. Loosen the exhaust bolts slightly from front to rear and then tighten them back down. Sometimes this relieves some of the tension in the exhaust which could give you more vibration. How many miles on the plugs? Is the air filter clean?

    Comment


    • #3
      are you sure it is an engine vibration and not something with a tire. Maybe lost a wheel weight? If Metzler tires you may have a belt shift?

      Comment


      • #4
        Originally posted by davej View Post
        are you sure it is an engine vibration and not something with a tire. Maybe lost a wheel weight? If Metzler tires you may have a belt shift?
        Yes, and get rid of the lead weights and use either Ride On liquid or DynaBeads per instructions.

        Comment


        • #5
          Originally posted by Shores View Post
          Run 87 fuel only. Disconnect the battery for a few minutes and then reinstall it to see if things get reset. Loosen the exhaust bolts slightly from front to rear and then tighten them back down. Sometimes this relieves some of the tension in the exhaust which could give you more vibration. How many miles on the plugs? Is the air filter clean?
          I always run 87. I could try the battery disconnect. I did that after I drilled the exhaust and airbox a month or so ago also. Air filter is K&N and barely has 500 miles on it with no rain riding yet. I'll check it though.

          Comment


          • #6
            Originally posted by Shores View Post

            Yes, and get rid of the lead weights and use either Ride On liquid or DynaBeads per instructions.
            I'm pretty sure it's an engine vibration, but it's hard to be sure. Holding a high idle didnt have a miss before like it does now. Tires did cross my mind early on as I do need to get a new front soon.

            Comment


            • #7
              So I got new plugs, unhooked the battery for a day to reset computer(I know it only needs like 10 mins), and got a new front tire and had the rear one rebalanced. Definitely still a noticeable engine vibration that wasn't there before. Will probably try doing a throttle body sync this week and see what that does.

              Comment


              • #8
                Originally posted by RickC View Post
                So I got new plugs, unhooked the battery for a day to reset computer(I know it only needs like 10 mins), and got a new front tire and had the rear one rebalanced. Definitely still a noticeable engine vibration that wasn't there before. Will probably try doing a throttle body sync this week and see what that does.
                I wouldn't mess with the throttle body. There's a slim chance that it got out of adjustment since it ran good last time. I would loosen the exhaust system and retighten it, working your way back and forth from front to rear. Are all four plugs burning about the same color?

                Comment


                • #9
                  Any chance the front pulley nut got loose?

                  Comment


                  • #10
                    Originally posted by Shores View Post

                    I wouldn't mess with the throttle body. There's a slim chance that it got out of adjustment since it ran good last time. I would loosen the exhaust system and retighten it, working your way back and forth from front to rear. Are all four plugs burning about the same color?
                    All 4 plugs looked almost identical. Normal coloring. I'll check the exhaust, but I haven't heard any leaks. One thing I did notice was a lot of vibration in the handle bars. If I give them a good firm grip, I can make some of the vibration go away. I did change out the risers a while back, so I'm going to take that loose and check it. I wouldn't think it would need the neck nut adjusted yet though. Bike only has 15k miles on it.

                    Comment


                    • #11
                      Originally posted by Herrindude View Post
                      Any chance the front pulley nut got loose?
                      I don't think so, as I have checked it twice in the 6 months I have had it, but I will check it again.

                      Comment


                      • #12
                        Originally posted by RickC View Post

                        All 4 plugs looked almost identical. Normal coloring. I'll check the exhaust, but I haven't heard any leaks. One thing I did notice was a lot of vibration in the handle bars. If I give them a good firm grip, I can make some of the vibration go away. I did change out the risers a while back, so I'm going to take that loose and check it. I wouldn't think it would need the neck nut adjusted yet though. Bike only has 15k miles on it.
                        The neck bearings are notoriously dry and loose from the factory so I wouldn't hesitate repacking them and adjusting them. Some vibrations can be caused just from over tightening exhaust, handlebars, etc in a cockeyed position.

                        Comment


                        • #13
                          What plugs did you use?

                          Comment


                          • #14
                            Did it run smoother before you had the valves adjusted?

                            Comment


                            • #15
                              Originally posted by Shores View Post
                              Did it run smoother before you had the valves adjusted?
                              All the posts inhave read and yamahas inhave owned......I don't think I ever heard a Roadstar running better/"needing" a valve adjustment...but LOTS of people encountering problems after adjusting valves themselves or having them adjusted.

                              Comment


                              • #16
                                So I finally found what caused a decent amount of the vibration. There were no spacers at either end of the long rod that holds the gas tank on. Not sure how I never noticed that before. I have had the tank off 3 times and never noticed any spacers. Wondering if they fell off with the previous owner. I ordered the correct part online, but for now I stacked some washers in there, and when I took it for a test ride there was a noticeable improvement. Still requires further testing which I will do this weekend with a long ride, but I was pretty happy with the improvement. Thinking back now, It did seem to be more exaggerated of a vibration right after I filled up and the tank was full and heavy. Also found some corrosion between the battery tender connector and the negative terminal. To be continued...

                                Comment


                                • #17
                                  Originally posted by Shores View Post
                                  Did it run smoother before you had the valves adjusted?
                                  Didn't notice a change at all when I did the rocker adjustments tbh. That was back in March also. These are newer vibrations. Some of the vibration is gone after fixing the tank, but I still have a some floorboard vibrations I didn't have before. Going to experiment with taking the engine guard off tonight probably and see what that does.

                                  Comment


                                  • #18
                                    A little less vibration without the engine guard. Did notice whoever put them on used the wrong length bolts also and I could barely spin the washer with the bolt tight. Funny enough, that took away a little knock/tick noise. Probably because under heavy engine vibration the guard was moving a little.

                                    Comment


                                    • #19
                                      After doing a lot more reading and research, I think my problem is my exhaust pipes are binding. I took them off a while back and put them back on, but by the sounds of it, I didn't do it properly. I had a hard time getting them back on. Going to try that and I'll report back.

                                      Comment

                                      Latest Posts

                                      Collapse

                                      Topics Statistics Last Post
                                      Started by JD64k, 4 hours ago
                                      1 response
                                      28 views
                                      0 likes
                                      Last Post Bikerron  
                                      Started by Father Pobasturd, 2 days ago
                                      5 responses
                                      123 views
                                      0 likes
                                      Last Post Lug Nut
                                      by Lug Nut
                                       
                                      Started by K. Clayton, 6 hours ago
                                      2 responses
                                      38 views
                                      0 likes
                                      Last Post Lug Nut
                                      by Lug Nut
                                       
                                      Started by bencadenbach, 1 week ago
                                      15 responses
                                      181 views
                                      0 likes
                                      Last Post Lifeguard  
                                      Started by Pauli466, 8 hours ago
                                      4 responses
                                      33 views
                                      0 likes
                                      Last Post Lug Nut
                                      by Lug Nut
                                       
                                      Started by Lucky, 4 weeks ago
                                      15 responses
                                      306 views
                                      3 likes
                                      Last Post Lug Nut
                                      by Lug Nut
                                       
                                      Started by Father Pobasturd, 05-24-2019, 03:51 PM
                                      829 responses
                                      9,725 views
                                      1 like
                                      Last Post MikeyC
                                      by MikeyC
                                       
                                      Started by rox, 1 day ago
                                      5 responses
                                      98 views
                                      0 likes
                                      Last Post davej
                                      by davej
                                       
                                      Started by Ironman, 3 days ago
                                      4 responses
                                      134 views
                                      0 likes
                                      Last Post grubsie
                                      by grubsie
                                       
                                      Started by gunner308, 02-14-2018, 03:53 PM
                                      36 responses
                                      4,215 views
                                      0 likes
                                      Last Post davej
                                      by davej
                                       
                                      Started by JoeBloShmo, 1 week ago
                                      9 responses
                                      138 views
                                      0 likes
                                      Last Post cike
                                      by cike
                                       
                                      Started by Vicious, 2 days ago
                                      1 response
                                      67 views
                                      0 likes
                                      Last Post davej
                                      by davej
                                       
                                      Started by Cubo55, 3 days ago
                                      3 responses
                                      92 views
                                      0 likes
                                      Last Post Shores
                                      by Shores
                                       
                                      Started by cike, 2 weeks ago
                                      15 responses
                                      250 views
                                      0 likes
                                      Last Post davej
                                      by davej
                                       
                                      Started by Pauli466, 3 days ago
                                      5 responses
                                      86 views
                                      0 likes
                                      Last Post Bikerron  
                                      Started by Ironman, 6 days ago
                                      8 responses
                                      129 views
                                      0 likes
                                      Last Post davej
                                      by davej
                                       
                                      Started by cike, 6 days ago
                                      10 responses
                                      183 views
                                      0 likes
                                      Last Post Jaybo
                                      by Jaybo
                                       
                                      Started by Kenkaman, 1 week ago
                                      22 responses
                                      218 views
                                      0 likes
                                      Last Post roadiemort  
                                      Started by bencadenbach, 1 week ago
                                      14 responses
                                      181 views
                                      0 likes
                                      Last Post bencadenbach  
                                      Started by brianmac, 1 week ago
                                      18 responses
                                      234 views
                                      0 likes
                                      Last Post Spydr
                                      by Spydr
                                       
                                      Working...
                                      X