Announcement

Collapse
No announcement yet.

2003 Road Star Silverado Help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spydr
    commented on 's reply
    If you are not getting Spark, no amount of gas nor starter fluid is going to make it start.

    If you're Sure you're not getting Spark, you should be focused on finding out Why.

  • thunderace4
    replied
    I pulled the air filter off and while cranking it I twisted the throttle open. I saw the accelerator pump squirt gas and I saw it pulling gas up around the needle. Do you think it still could be getting a reduced flow? I’m going to try starting fluid tomorrow and post up here with the result.
    **** I also forgot the kickstand switch was disconnected by the previous owner. I gotta look into that too now.

    Leave a comment:


  • Lug Nut
    replied
    Fuel issue.. ..check carb inlet that has a little filter/screen may be dirty. Pull fuel line from carb (that goes to metal elbow) and hold a rag over and turn key on...see if you have fuel flow...if you do then prob something in carb itself

    Leave a comment:


  • thunderace4
    replied
    Still cant get her to run. I replaced the seat and needle with a mikuni set. I replaced the en richer cover and the boot (diaphragm as it was cracked). I removed the manifold and reinstalled it with a little hylomar to be sure it was sealed up. It seems as it is getting no spark. I removed the plugs and cleaned them and re installed. Fresh gas, battery is at 12.7 and when cranking about 11.5 volts. I do not know if it is a valid test but I cranked it with a plug out and grounded it to the head to see if it sparked (from my old two stroke days) and I didn't see any spark. What else am I missing? If the manifold still had a leak, it should still at least seem like it was catching i think. I don't know where to go form here. Any suggestions are welcome and appreciated.
    2003 Road star silverado
    AIS Delete
    Vance and Hines long shots
    everything else seems stock.

    Leave a comment:


  • thunderace4
    replied
    Ha ha, believe me, I thought I may have but I tried it on reg and reserve. I faced the new manifold, gently greased the O-rings, torqued properly in a crisscross order. I took my time and tried to get it right on the first time. I am by no means a motorcycle mechanic but I know my way around a toolbox. I am gonna do a full carb rebuild, check the manifold again and go from there. I checked the fuel pump and I can feet it turn on when I turn the key.

    Leave a comment:


  • Father Pobasturd
    replied
    Did you turn off the fuel petcock and forget to turn it on?

    Leave a comment:


  • thunderace4
    replied
    I installed it finger tight then did the criss-cross pattern up to the 120 inch pounds. Its all apart again already. I was going to order the full rebuild kit tomorrow.

    Leave a comment:


  • Lug Nut
    replied
    Did you tighten manifold carefully? Final torque is 105 in/lb....best to do in 20lb increments in a cris-cross pattern. If you over Tightened or did full 105 in/lb on one side at a time maybe cracked or have a leak. Prob best to pull tank carb and manifold and reinstall manifold carefully and inspect carb again while it's out.

    Leave a comment:


  • thunderace4
    started a topic 2003 Road Star Silverado Help

    2003 Road Star Silverado Help

    Hi, I have a 2003 Road Star Silverado, It is all stock except for vance and hines long shot pipes. I recently bought it with 9,600 miles on it, third owner I believe. It ran and rode well but was a little lean. I found the manifold was leaking so I bought a new yamaha manifold and the orings to go along with it. I faced the manifold as recommended on the forum and then installed it just using a light grease on the rings. While the carb was off I took it apart and cleaned it. It wasn't too bad. I replaced the float bowl gasket and put it all together. ( I did notice while cleaning that the seat gasket was hard and had a couple cracks/nicks in it. I didn't have a new one so I used it as is) . The bike fired right up and was on choke for a minute or two and then idled fine without the choke. I let it warm up for about 10 minutes then I shut it off. I went to restart it about ten minutes later and it wouldn't start. They key was on. I held it wide open and cranked it and then it fired for a second then died. I am assuming the seat gasket it bad or maybe the float needle. I pulled the plugs and they were wet. Besides the needle/seat issue is there anything I may be missing? Also during this whole thing I deleted the AIS and made sure the manifold hose connection was plugged. Thanks for the help, Anthony.

Latest Posts

Collapse

Topics Statistics Last Post
Started by Lucky, 4 weeks ago
11 responses
240 views
3 likes
Last Post Cubo55
by Cubo55
 
Started by Ironman, 8 hours ago
3 responses
53 views
0 likes
Last Post Lug Nut
by Lug Nut
 
Started by cike, 3 days ago
10 responses
156 views
0 likes
Last Post Jaybo
by Jaybo
 
Started by Kenkaman, 5 days ago
22 responses
203 views
0 likes
Last Post roadiemort  
Started by bencadenbach, 4 days ago
14 responses
167 views
0 likes
Last Post bencadenbach  
Started by Ironman, 3 days ago
7 responses
79 views
0 likes
Last Post Pauli466  
Started by brianmac, 4 days ago
18 responses
204 views
0 likes
Last Post Spydr
by Spydr
 
Started by JoeBloShmo, 3 days ago
5 responses
103 views
0 likes
Last Post JoeBloShmo  
Started by Parhamj, 4 days ago
5 responses
97 views
0 likes
Last Post 07 silverado  
Started by Pauli466, 1 week ago
30 responses
420 views
0 likes
Last Post D-Fresh
by D-Fresh
 
Started by GNR10, 6 days ago
5 responses
77 views
0 likes
Last Post D-Fresh
by D-Fresh
 
Started by thunderace4, 10-19-2019, 12:34 PM
23 responses
251 views
0 likes
Last Post Lucky
by Lucky
 
Started by GNR10, 2 weeks ago
24 responses
98 views
0 likes
Last Post roadiemort  
Started by Motorcycler, 2 days ago
4 responses
95 views
0 likes
Last Post Lug Nut
by Lug Nut
 
Started by bencadenbach, 4 days ago
13 responses
149 views
0 likes
Last Post Shores
by Shores
 
Started by gunner308, 02-14-2018, 03:53 PM
34 responses
4,125 views
0 likes
Last Post Scottyxbones  
Started by roadiemort, 2 days ago
6 responses
61 views
1 like
Last Post GNR10
by GNR10
 
Started by Father Pobasturd, 05-24-2019, 03:51 PM
826 responses
9,698 views
1 like
Last Post JoeBloShmo  
Started by Pauli466, 4 days ago
8 responses
136 views
0 likes
Last Post Pauli466  
Started by Vicious, 3 days ago
6 responses
91 views
0 likes
Last Post LeLimoMan  
Working...
X