Announcement

Collapse
No announcement yet.

Backfire after shutoff

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Backfire after shutoff

    Got all the fluids changed out on the new bike and took it out today for its first really good ride.

    Once I got back, parked the bike and killed the engine, there was a slight backfire from one pipe, then a slightly delayed one from the other pipe. I figured it's just due to the pipes getting so hot and a little unburnt fuel getting passed into the exhaust after the kill switch is off.

    Is this a common thing on these bikes? Something I should be worried about at all?

    Thanks in advance!

  • #2
    Carbed engines continue to draw in raw fuel when the spark plugs are shut down until the engine stops spinning. A good, hard ride will heat up carbon deposits and metal parts in the exhaust ports to the point it’ll ignite the hot mixture when exposed to any ignition source.

    Run some Marvel Mystery Oil in the tank. Does wonders and run regular gas.

    Comment


    • Padre
      Padre commented
      Editing a comment
      Thanks, that was pretty much my assumption but I wanted to get a second opinion.

      Will pick up some Marvel Mystery Oil after work tomorrow and add some when I fill up.

  • #3
    Sounds to me like it's about to blow up. I'll get it out of your way for you, all you have to do is pay to ship it to Arizona. Of all the rotten luck, huh? No, seriously, mine does it now and the too.

    Comment


    • #4
      LOL!

      Mine does seem to be doing it after every ride when I shut it down tho. I did add some seafoam that I had sitting around when I filled it up today. Hopefully cleaning some of that old carbon out will help. If not, is there anything else I should take a look at that could be the culprit, or is this just the nature of the beast?

      Comment


      • #5
        Mine does it after spirited rides ...which is about all I do . I run premium gas but after doing research I'll be moving back to regular. Do you have the AIS removal do or no ?

        Comment


        • #6
          I’m pretty sure all the emission type systems have been removed by the previous owner.

          Comment


          • #7
            Do you have the idle set too high? should be about 900-950 rpm. If it is set too high it could cause that to happen because of drawing in raw fuel as Ron said above.

            Comment


            • Padre
              Padre commented
              Editing a comment
              The previous owner had it set way too low so I have upped it, but if it's in the ~900RPM range I'm not sure. I've just kinda done it by ear.
              I will try lowering it a bit and see if it helps.

              Thanks

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by thunderace4, 11 hours ago
          5 responses
          53 views
          0 likes
          Last Post Bikerron  
          Started by JonBru, 3 days ago
          10 responses
          155 views
          0 likes
          Last Post RonK
          by RonK
           
          Started by jdhard0341, 5 hours ago
          5 responses
          45 views
          0 likes
          Last Post RonK
          by RonK
           
          Started by rsokie, 5 hours ago
          3 responses
          25 views
          0 likes
          Last Post Spydr
          by Spydr
           
          Started by Alaw, 6 hours ago
          2 responses
          28 views
          0 likes
          Last Post Alaw
          by Alaw
           
          Started by J89k, 4 days ago
          25 responses
          363 views
          0 likes
          Last Post EP Roadie  
          Started by Cherembosky, 1 day ago
          9 responses
          96 views
          0 likes
          Last Post Brad_G
          by Brad_G
           
          Started by Brad_G, 3 days ago
          6 responses
          133 views
          0 likes
          Last Post brianmac  
          Started by brianmac, 1 week ago
          3 responses
          70 views
          0 likes
          Last Post brianmac  
          Started by brianmac, 1 day ago
          2 responses
          73 views
          0 likes
          Last Post Father Pobasturd  
          Started by blackboy304, 08-22-2018, 08:17 PM
          23 responses
          1,261 views
          0 likes
          Last Post boomerA
          by boomerA
           
          Started by YZ18, 2 days ago
          3 responses
          122 views
          0 likes
          Last Post Messer2.0  
          Started by Starboi7, 1 week ago
          37 responses
          442 views
          0 likes
          Last Post Starboi7  
          Started by RickC, 09-09-2019, 10:38 AM
          15 responses
          259 views
          0 likes
          Last Post RickC
          by RickC
           
          Started by jluisochoa, 1 day ago
          6 responses
          87 views
          0 likes
          Last Post jluisochoa  
          Started by Lifeguard, 4 days ago
          15 responses
          279 views
          0 likes
          Last Post Starboi7  
          Started by Tykes_Place, 06-06-2018, 12:40 AM
          28 responses
          489 views
          5 likes
          Last Post Tykes_Place  
          Started by thunderace4, 09-08-2019, 02:43 PM
          8 responses
          194 views
          0 likes
          Last Post thunderace4  
          Started by Ed_XV1600, 1 week ago
          19 responses
          211 views
          0 likes
          Last Post Starboi7  
          Working...
          X