Announcement

Collapse
No announcement yet.

Severe bogging and Backfiring at Full Throttle--2009 Roadstar 1700 fuel injected

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Severe bogging and Backfiring at Full Throttle--2009 Roadstar 1700 fuel injected

    Hey Everyone, Thanks for having me on the forum. I am having severe bogging and backfire problem at Full throttle when cold. Once the bike warms up it anything past 1/4 throttle.
    Took to an independent mechanic. He said he flushed the fuel system, changed the fuel pump actuator, 02 Sensor actuator, spark plugs, replace a coil pack, cleaned the fuel injectors. All of this did nothing.
    Before I took it to him, I pulled a code 24 (bad O2 sensor?) and a code 46 ( ignition control module?)
    I am at a loss. I have an appt to take it to the dealer in a week. Wondering If I am missing something simple. Any thoughts or information would be much appreciated !

  • #2
    Symptoms belie a lack of ignition advance which could derive from a faulty ignition control module. Did the code 24 clear yet?


    Comment


    • #3
      When did it last run well? What was the last work done to it when it ran well? Does the bike have an after market fuel processor or are you running the stock one?

      Comment


      • #4
        Hey Guys. Thanks for the response. I have not checked the codes since I retrieved the bike today but I will. Improper timing makes sense....

        I bought the bike used. It only has 4000 miles on it. Once I got it, I put about 200 miles on it before it started acting up. Got me home from a 80 mile road trip, but was barely running. Anything above 10% throttle and it would bog and backfire.
        I did not do any work to it once I bought it other than new tires. I am running the stock fuel processor. The bike is completely stock.

        Comment


        • #5
          What is a o2 sensor "Actuator" do you mean he just replaced an o2 sensor? It's kinda hard for the timing to be off so I wouldn't even consider that as the issue. Did you do something as simple as check the air filter? Also sometimes when a bike has been put away for long periods of time like it appears that yours has little rodents climb into places and eat things like wires and filters.They also make little nest in some of those same places and can before a problem.

          Comment


          • #6
            Run a bunch of Seafoam through it.

            Comment


            • #7
              I would agree with Shores, when i bought my 09 it had sat for 2 years and the dealer i bought it from had it running but i brought it home and run some seafoam injector cleaner through it like the instruction on the can said and it made the shop look like it was on fire from the smoke, afterwards it run better, and performed better now i just run a seam foam or Marvel Mystery oil every other tank no problems since and the plugs have that nice straw color to them.

              Comment


              • #8
                The fuel system was flushed. It's not an air filter or rodent problem. The bike has been run on a regular basis. Just not ridden much.
                he replaced the 02 sensors and the actuator. I'm not exactly sure what it does.

                Comment


                • #9
                  Originally posted by tsimone98 View Post
                  The fuel system was flushed. It's not an air filter or rodent problem. The bike has been run on a regular basis. Just not ridden much.
                  he replaced the 02 sensors and the actuator. I'm not exactly sure what it does.
                  Run often vs ridden often are two different things. Starting often and not riding it to get to nice hot operating temp sucks moisture into the system as it cools. Easy enough to do....fill the tank with proper amt of Seafoam and ride like you stole it for 100 miles. Don’t assume others cleaned the system well.

                  Comment


                  • #10
                    I was kind of curious about what the actuators were also. Looks like he quit posting though.
                    Scott B.

                    Comment


                    • Brad_G
                      Brad_G commented
                      Editing a comment
                      He's out riding the shit out of it like Shores instructed.

                  • #11
                    Ha...Thanks Shores.

                    Comment


                    • #12
                      Swap ICU and see what happens.
                      Is the word PICTURE a picture?

                      Comment


                      • #13
                        So, I broke down and took it to the dealer. The tech says he is sure it is the fuel pump. At idle it is making 55 psi. Once the throttle starts to open the pump dies.
                        The dealer quoted my almost $700 for the pump. I think that is ridiculous. As a matter of fact, I can probably do the pump myself.
                        Does anyone know if someone makes a cheaper aftermarket pump? or any other cheaper Idea? Again its a 2009 xv1700a

                        Comment


                        • #14
                          Originally posted by tsimone98 View Post
                          So, I broke down and took it to the dealer. The tech says he is sure it is the fuel pump. At idle it is making 55 psi. Once the throttle starts to open the pump dies.
                          The dealer quoted my almost $700 for the pump. I think that is ridiculous. As a matter of fact, I can probably do the pump myself.
                          Does anyone know if someone makes a cheaper aftermarket pump? or any other cheaper Idea? Again its a 2009 xv1700a
                          Don’t put in another pump. Go pumpless. Lots of folks here will tell you how.

                          Comment


                          • Bikerron
                            Bikerron commented
                            Editing a comment
                            “2009 Roadstar 1700 fuel injected”

                            Yea, that’ll work. Lol

                          • Doc_V
                            Doc_V commented
                            Editing a comment
                            Uh... Shores??? Wanna try that one again? Err... Why kind of R* do you have?

                        • #15
                          Originally posted by tsimone98 View Post
                          So, I broke down and took it to the dealer. The tech says he is sure it is the fuel pump. At idle it is making 55 psi. Once the throttle starts to open the pump dies.
                          The dealer quoted my almost $700 for the pump. I think that is ridiculous. As a matter of fact, I can probably do the pump myself.
                          Does anyone know if someone makes a cheaper aftermarket pump? or any other cheaper Idea? Again its a 2009 xv1700a
                          Another member replaced his with this one.

                          https://www.highflowfuel.com/i-23900...2008-2010.html

                          Comment


                          • #16
                            Originally posted by Bikerron View Post
                            “2009 Roadstar 1700 fuel injected”

                            Yea, that’ll work. Lol
                            Oops! My bad!

                            Comment


                            • Doc_V
                              Doc_V commented
                              Editing a comment
                              I think maybe spending all that time in the tropical sun has got to you.

                          • #17
                            I would always use Yamaha factory parts for stuff like that. Why bother trying to save a few bucks on something so critical? I’ve never heard of a fuel pump actually going bad on an FI Roadstar yet but there’s a first time for everything.

                            Still sounds like somethig is clogged up to me. Bike that age with almost no miles on it is a prime candidate for clogged fuel stuff. A pump that can make 55psi seems like it’s ok. When psi drops with a demand for volume could be a pump but sounds more like a restriction to me.

                            Comment


                            • #18
                              Originally posted by Deerkiller View Post
                              I would always use Yamaha factory parts for stuff like that. Why bother trying to save a few bucks on something so critical? I’ve never heard of a fuel pump actually going bad on an FI Roadstar yet but there’s a first time for everything.

                              Still sounds like somethig is clogged up to me. Bike that age with almost no miles on it is a prime candidate for clogged fuel stuff. A pump that can make 55psi seems like it’s ok. When psi drops with a demand for volume could be a pump but sounds more like a restriction to me.
                              I agree! Sounds like an easy plan to separate you from some of your money. Got 52K on my fuelie with no issues with anything, except I keep having to put more gas in the tank!

                              Comment


                              • #19
                                Thanks everyone for the input. I really do appreciate it all. I may try a tank of seafoam like Shores and others have suggested. It's just hard as the thing barely takes any throttle past idle once hot.
                                Can anyone tell me where the fuel filter is on these?

                                Comment


                                • davej
                                  davej commented
                                  Editing a comment
                                  It is inside the tank.

                              • #20
                                Thanks davej

                                Comment

                                Latest Posts

                                Collapse

                                Topics Statistics Last Post
                                Started by Kenkaman, 2 days ago
                                13 responses
                                141 views
                                0 likes
                                Last Post Ahodge75  
                                Started by Wonky1, 16 hours ago
                                2 responses
                                61 views
                                0 likes
                                Last Post mikew
                                by mikew
                                 
                                Started by Father Pobasturd, 05-24-2019, 02:51 PM
                                934 responses
                                10,914 views
                                1 like
                                Last Post JoeBloShmo  
                                Started by twowheeltherapy, 1 week ago
                                42 responses
                                245 views
                                4 likes
                                Last Post Chromepony  
                                Started by roadiemort, 18 hours ago
                                1 response
                                55 views
                                0 likes
                                Last Post J89k
                                by J89k
                                 
                                Started by curtixman, 1 day ago
                                2 responses
                                53 views
                                0 likes
                                Last Post Smokescreens  
                                Started by Wonky1, 1 day ago
                                2 responses
                                37 views
                                0 likes
                                Last Post davej
                                by davej
                                 
                                Started by Deerkiller, 10-02-2019, 12:11 PM
                                17 responses
                                220 views
                                0 likes
                                Last Post davej
                                by davej
                                 
                                Started by curtixman, 4 days ago
                                7 responses
                                117 views
                                0 likes
                                Last Post curtixman  
                                Started by LeLimoMan, 1 day ago
                                1 response
                                36 views
                                2 likes
                                Last Post Bikerron  
                                Started by Smokescreens, 03-05-2018, 10:34 AM
                                267 responses
                                5,594 views
                                14 likes
                                Last Post boomerA
                                by boomerA
                                 
                                Started by Cubo55, 04-20-2020, 09:24 PM
                                73 responses
                                791 views
                                0 likes
                                Last Post brianmac  
                                Started by jdhard0341, 4 days ago
                                11 responses
                                140 views
                                0 likes
                                Last Post Brenden lesage  
                                Started by Jaybo, 04-20-2020, 11:36 PM
                                49 responses
                                631 views
                                1 like
                                Last Post boomerA
                                by boomerA
                                 
                                Started by Ahodge75, 3 days ago
                                7 responses
                                111 views
                                0 likes
                                Last Post Shores
                                by Shores
                                 
                                Started by roadiemort, 5 days ago
                                4 responses
                                111 views
                                0 likes
                                Last Post roadiemort  
                                Started by coolalexrex, 6 days ago
                                4 responses
                                102 views
                                0 likes
                                Last Post brianmac  
                                Started by J89k, 3 weeks ago
                                8 responses
                                191 views
                                0 likes
                                Last Post Horsehammerr  
                                Started by RoadieRob, 5 days ago
                                6 responses
                                67 views
                                0 likes
                                Last Post Duke
                                by Duke
                                 
                                Started by Angel220, 1 week ago
                                5 responses
                                155 views
                                0 likes
                                Last Post ItBeMe
                                by ItBeMe
                                 
                                Working...
                                X