Announcement

Collapse
No announcement yet.

Sputters when I get on throttle at highway speeds

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sputters when I get on throttle at highway speeds

    Just got an ‘08 Road Star that only had 1600 miles on it when I bought it. Just recently got a chance to take it out on the freeway. Runs great through all gears and speeds up to about 70-75mph. When I try to get on the throttle at those speeds it just sputters. Almost dies. So far I’ve only cleaned the air filter as thatvwas recommended by someone else and didn’t help at all. As a matter of fact the filter looked brand new. Gonna try injector cleaner as that was also recommended and don’t think it could hurt anything. Anything else I should look at? Any ideas? Manual don’t even mention a fuel filter so I’m guessing they don’t want me messing with it. But is that something I should try?

  • #2
    A bike that old and with that few miles is likely gonna have gunk in the fuel system from sitting too long with old fuel in it. That would include rust, oxidization and ethanol gel possibly in the tank, pump, fuel filter, injectors, etc. Put a HEAVY dose of Seafoam in several tanks of fuel and run that through before you start tearing things apart. Ride it hard.

    “The West is the Best" - Jim Morrison

    Comment


    • #3
      My bike sat for awhile before I jought it and it would spit and sputter at times but after several heavy doses of Sea Foam it cleared right up. I use it regularly now and haven't had anymore issues

      Comment


      • #4
        I appreciate your all help. Went to Target and put about half a can in a full tank of fuel. Didn’t get to ride it much except for straight home from the store. Maybe tomorrow I’ll get it out on the freeway and see how it does. How about the fuel filter? Is it a PIA to change like everything else seems to be so far? I noticed the manual doesn’t even mention the fuel filter so I’m guessing it’s not easy to deal with. But if the sea foam doesn’t straighten it out how hard is it gonna be to put a new filter in it?

        Comment


        • #5
          Originally posted by Dcspurlock View Post
          I appreciate your all help. Went to Target and put about half a can in a full tank of fuel. Didn’t get to ride it much except for straight home from the store. Maybe tomorrow I’ll get it out on the freeway and see how it does. How about the fuel filter? Is it a PIA to change like everything else seems to be so far? I noticed the manual doesn’t even mention the fuel filter so I’m guessing it’s not easy to deal with. But if the sea foam doesn’t straighten it out how hard is it gonna be to put a new filter in it?
          Filters on the pump which is inside the tank....I think.

          “The West is the Best" - Jim Morrison

          Comment


          • #6
            So far the sea foam hasn’t done a lot of good. Bike is definitely running worse than yesterday. Or any day I’ve had it for that matter. Granted I’ve only ran about a half a tank through it with sea foam but now the bike starves for fuel anytime I ask for more throttle. If I don’t creep through the gears and go easy throttle then it’ll dang near die right in the road. Backfire is getting worse too. It’s most definitely not getting enough fuel.

            Comment


            • #7
              Originally posted by Dcspurlock View Post
              So far the sea foam hasn’t done a lot of good. Bike is definitely running worse than yesterday. Or any day I’ve had it for that matter. Granted I’ve only ran about a half a tank through it with sea foam but now the bike starves for fuel anytime I ask for more throttle. If I don’t creep through the gears and go easy throttle then it’ll dang near die right in the road. Backfire is getting worse too. It’s most definitely not getting enough fuel.
              That may be a sign that the Seafoam is doing its job and loosening things up and they are traveling through the system. Patience Grasshopper! Ten years of crap isn’t gonna clear out over night. You might eventually have to clean rust or other hard debre out of the tank, pump, fuel lines, injectors, etc. But try the simple stuff first. Run several full tanks and ride it like you stole it.

              “The West is the Best" - Jim Morrison

              Comment


              • #8
                Shores is right about the bike sitting too long and unfortunately with an FI, short of removing the injectors and having them professionally cleaned, all you can really do is be patient and keep riding. Depending on how bad it is, it can take a while for the Seafoam to do it's job. Maybe even a couple tanks.

                - Open question to the gang since I don't own an FI bike... What about a possible vacuum leak?

                Comment


                • #9
                  Originally posted by Shores View Post

                  That may be a sign that the Seafoam is doing its job and loosening things up and they are traveling through the system. Patience Grasshopper! Run several full tanks and ride it like you stole it.
                  I appreciate your help on this brother. You’re probably right. I didn’t think about the gunk breaking up and running out. If I could ride it like I stole I dang sure would lol. Poor girl just falls as soon as I give her a twist. This time it’s any gear though. Just don’t wanna take fuel. I’ll stock up on the sea foam though. I’ll try to get 3-4 tanks through her before I start tearing things apart. Again, thanks for the help bro. Glad I found this site.

                  Comment


                  • #10
                    have you checked for water in the fuel?

                    Comment


                    • #11
                      Click image for larger version  Name:	s-l300.jpg Views:	1 Size:	3.8 KB ID:	34882

                      Check the rollover valves.

                      Inline with the tank vent.

                      Parts #37 in picture. Link below.

                      https://www.partzilla.com/catalog/ya...awyr/fuel-tank



                      Comment


                      • #12
                        Accelerator pump diaphragm might be cracked also.

                        Comment


                        • Bikerron
                          Bikerron commented
                          Editing a comment
                          Fuel injected model.

                      • #13
                        Seems to me that pulling and cleaning the injectors is in order from everything I’ve read so far. Seafoam/gas treatments can only do so much...

                        I’d be removing the gas tank and draining it. Clean it all out. Pull the stuff out of the tank and inspect/clean it.

                        Check rollover valve as mentioned above.

                        Check all FI related hoses/components when the tank is off. There’s really not all that much to check under there.

                        Comment


                        • #14
                          If it gets to pulling the tank there is a strainer in there.

                          Ive seen pictures of it totally crapped.



                          Comment


                          • #15
                            Pretty much everything we know about the fuelies as not many threads are brought up about the confounded thing.

                            Link covers about all that has been shared, in a nut shell.
                            https://www.roadstarclinic.com/forum...ion-facts-tips



                            Comment


                            • Brad_G
                              Brad_G commented
                              Editing a comment
                              Most of the time it's just hit the starter button and ride.

                            • SKWEARpeg
                              SKWEARpeg commented
                              Editing a comment
                              Sadly, I suspect as the Fuelies start getting longer in the tooth, the crime of neglect will become more and more apparent.

                          • #16
                            Nothing escapes the Reaper.



                            Comment


                            • #17
                              Originally posted by Bikerron View Post
                              Click image for larger version Name:	s-l300.jpg Views:	1 Size:	3.8 KB ID:	34882

                              Check the rollover valves.

                              Inline with the tank vent.

                              Parts #37 in picture. Link below.

                              https://www.partzilla.com/catalog/ya...awyr/fuel-tank
                              How can I check the rollover valves? What would I be lookin for to tell if they’re bad or not?

                              Comment


                              • #18
                                They are check valves that allows air into the tank as fuel is used. Air flows in only one direction through them. In a tip over of the Road Star they will not allow fuel to exit the vent line from a reverse flow.

                                They have been known to stop up and not vent the tank properly.

                                One thing. I kind of question of the validity in the manual as to the flow direction shown. Seems the arrow should be pointing in the direction of the tank to vent.

                                So, if you can’t blow through them in EITHER direction I’d say they are pooched.



                                Comment


                                • #19
                                  Originally posted by Bikerron View Post
                                  If it gets to pulling the tank there is a strainer in there.

                                  Ive seen pictures of it totally crapped.
                                  Where is the strainer supposed to be? I’ve got the tank apart now and once the pump comes out that’s it. I don’t see a strainer or anything that is supposed to even semi filter the fuel and I’m pretty sure that’s my problem. There is a crusty lookin gunk all over the pump but nothing I can see so far that is supposed to be filtering the fuel?

                                  Comment


                                  • #20
                                    It’s inside the gunked up thing.

                                    You have to manipulate release tabs (maybe 3) on the pump housing to take it apart to get to the pump motor and strainer.

                                    https://www.highflowfuel.com/i-23900...2008-2009.html



                                    Comment

                                    Latest Posts

                                    Collapse

                                    Topics Statistics Last Post
                                    Started by Milkman, 4 minutes ago
                                    0 responses
                                    1 view
                                    0 likes
                                    Last Post Milkman
                                    by Milkman
                                     
                                    Started by roadiemort, 03-05-2018, 08:01 PM
                                    2,499 responses
                                    21,755 views
                                    3 likes
                                    Last Post roadiemort  
                                    Started by Greasybastard02, 1 week ago
                                    35 responses
                                    355 views
                                    0 likes
                                    Last Post Greasybastard02  
                                    Started by zingpow, 4 days ago
                                    22 responses
                                    332 views
                                    0 likes
                                    Last Post zingpow
                                    by zingpow
                                     
                                    Started by LDofDC, 2 days ago
                                    7 responses
                                    72 views
                                    0 likes
                                    Last Post KCpartsguy  
                                    Started by Ftwbear, 1 day ago
                                    6 responses
                                    117 views
                                    0 likes
                                    Last Post Father Pobasturd  
                                    Started by Kruzcontrol, 2 days ago
                                    7 responses
                                    94 views
                                    0 likes
                                    Last Post Penguin
                                    by Penguin
                                     
                                    Started by brianmac, 1 week ago
                                    45 responses
                                    481 views
                                    0 likes
                                    Last Post Shores
                                    by Shores
                                     
                                    Started by Kelly, 07-17-2018, 03:39 PM
                                    41 responses
                                    662 views
                                    0 likes
                                    Last Post Roadstar_Rob  
                                    Started by D-Fresh, 3 days ago
                                    6 responses
                                    128 views
                                    0 likes
                                    Last Post VegasDave  
                                    Started by Aussie John, 6 days ago
                                    8 responses
                                    153 views
                                    0 likes
                                    Last Post Aussie John  
                                    Started by Mitch82, 1 week ago
                                    8 responses
                                    226 views
                                    0 likes
                                    Last Post RonK
                                    by RonK
                                     
                                    Started by Rob in FL, 2 days ago
                                    8 responses
                                    118 views
                                    0 likes
                                    Last Post Duke
                                    by Duke
                                     
                                    Started by NCB, 6 days ago
                                    7 responses
                                    145 views
                                    0 likes
                                    Last Post Jclevesque  
                                    Started by Rob in FL, 6 days ago
                                    23 responses
                                    193 views
                                    1 like
                                    Last Post Rob in FL  
                                    Started by LaBamba, 6 days ago
                                    12 responses
                                    243 views
                                    0 likes
                                    Last Post davej
                                    by davej
                                     
                                    Started by brianmac, 2 days ago
                                    1 response
                                    57 views
                                    0 likes
                                    Last Post davej
                                    by davej
                                     
                                    Started by Texas Jim, 4 days ago
                                    18 responses
                                    209 views
                                    0 likes
                                    Last Post Bikerron  
                                    Started by Txulrich, 04-24-2018, 01:12 PM
                                    641 responses
                                    3,534 views
                                    0 likes
                                    Last Post Ratl
                                    by Ratl
                                     
                                    Started by JayinCA, 6 days ago
                                    15 responses
                                    130 views
                                    0 likes
                                    Last Post HotRod
                                    by HotRod
                                     
                                    Working...
                                    X