Announcement

Collapse
No announcement yet.

I'm puzzled/ power loss when warmed up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Chromepony
    commented on 's reply
    If you're gona' trade, trade up.
    Look around & see if you can find good deal on a 'Liner. At least ride one before you pull the trigger on a trade.
    You won't regret it.

  • Oldsguy1
    commented on 's reply
    I'm just outside of Lincoln Ne. I paid a whopping 3,700 bux for it 10 years ago and at the time it needed a rear tire and battery. 'm sure to be better off selling privately but an easy trade-up situation is faster (like it matters, there'll be snow on the ground by then. It is definitely dated but rides and performs perfect until this little hickup.

  • MikeyC
    replied
    Oh, bummer, good looking bike. What is trade in value? where are you located?

    Leave a comment:


  • Oldsguy1
    replied
    I gave up, valves need adjusted anyway....I took it in to Dillon Brothers in Omaha Ne. 1 month wait. I may turn right around and get a trade in price on it. Thanks for the help guys.

    Leave a comment:


  • Oldsguy1
    replied
    Tearing it apart tomorrow, might have to start throwing parts at it, the fuel filter has been on for the 10 years I've owned it but sees a limited amount of ride time.Fuel is always cold weatherized and always has a cool weather tender on it. Where would there be an ignition be located? I was told the ignition had been upgraded somehow when I bought it but the seller was unaware of what was done.

    Leave a comment:


  • Pauli466
    replied
    When the engine cough's ( intake backfire) the flame hits the plastic slide in the carb throat, see how it feels by lifting it with your finger, if it isn't perfectly smooth polish it with#0000 steel wool

    Leave a comment:


  • Jclevesque
    replied
    Coils act up only when hot. Something to look into. JC

    Leave a comment:


  • Oldsguy1
    replied
    Agreed, that was a characteristic comparison. I've had this about ten years, never been into the carb, I was mostly cyrious if anybody had the opinion that this was ignition related and/or testable while cool.

    Leave a comment:


  • Duke
    commented on 's reply
    Vent runs from the top of the fuel tank by the ignition key switch, to the down tube part of the frame at back of motor. There is a rollover valve that plugs up and I'd just remove it into the trash can.

  • Shores
    replied
    Road Stars don't like to be blipped.

    Leave a comment:


  • Oldsguy1
    replied
    negative, and the fuel filter seems fine. Crack the gas too far too quick and it bogs out, blip the gas and similar results. medium throttle aggression results seem perfect all the way through the rpm range. . was just about to sell the thing too and try to look for an 07 or so 1700

    Leave a comment:


  • Shores
    replied
    Does it idle rough when warm? Maybe sticky valve syndrome?

    Leave a comment:


  • Oldsguy1
    replied
    and yes, it totally acts like starved for fuel but only when hot? Where is the vent line run to?

    Leave a comment:


  • davej
    commented on 's reply
    This is the new RSC the original RSC closed down and was resurrected by Rock River Powersports. We all signed in again.

  • Oldsguy1
    replied
    I also noticed when this is going on the fuel guage isn't registering until I key the bike off and restart it

    Leave a comment:


  • Oldsguy1
    replied
    I'll check it out. Thanks guys, I was a part of this group for quite a while, same name, etc. I had to re-sign for some reason, none of my sign in or email addresses would work anymore.

    Leave a comment:


  • Brad_G
    replied
    from Solon, IA

    Does it run rough when warmed up like it's only firing on one cylinder? Or as Duke suggested, does it feel like it's starving for fuel?

    Leave a comment:


  • Duke
    replied
    From the Four Corners area, northwest New Mexico.
    Check your fuel filter and the the vent on the fuel tank.

    Leave a comment:


  • Oldsguy1
    started a topic I'm puzzled/ power loss when warmed up

    I'm puzzled/ power loss when warmed up

    It's more then the title says but in a nutshell my 01 midnight star backfires and loses almost all power and can barely get out of it's own way when it's warmed up.

    When it's cold, it starts right up, idles nice, revs nice...I can take it out for a couple of blocks but after that it just starts cutting out on what feels like one cylinder. New plugs two seasons ago, 30k miles. Right before all of this started I had washed and dried the bike the way I've done it for years. This was two weekends ago, if something got wet (doubt it) it's dry by now.. could a coil be bad and only testable when warmed up? same with wires and plugs? stator? .. Also, any chance the valves might just need adjusted? opinions on where to start looking?

    Ryan

Latest Posts

Collapse

Topics Statistics Last Post
Started by Father Pobasturd, 4 days ago
14 responses
216 views
0 likes
Last Post roadiemort  
Started by roadiemort, 08-22-2020, 04:09 AM
277 responses
1,610 views
1 like
Last Post roadiemort  
Started by brianmac, 1 week ago
67 responses
672 views
0 likes
Last Post brianmac  
Started by Lug Nut, 23 hours ago
0 responses
35 views
0 likes
Last Post Lug Nut
by Lug Nut
 
Started by Doc_V, 1 day ago
7 responses
100 views
0 likes
Last Post Doc_V
by Doc_V
 
Started by Bip_Bip, 4 days ago
32 responses
254 views
0 likes
Last Post Bip_Bip
by Bip_Bip
 
Started by Father Pobasturd, 4 days ago
6 responses
91 views
0 likes
Last Post MikeyC
by MikeyC
 
Started by Lifeguard, 02-16-2019, 09:07 PM
28 responses
435 views
2 likes
Last Post Duke
by Duke
 
Started by brianmac, 11-06-2018, 08:57 AM
101 responses
2,585 views
0 likes
Last Post brianmac  
Started by roadiemort, 4 days ago
5 responses
110 views
0 likes
Last Post roadiemort  
Started by Darkkill57, 3 days ago
5 responses
139 views
0 likes
Last Post brianmac  
Started by Michael72, 09-02-2020, 11:48 AM
14 responses
301 views
0 likes
Last Post brianmac  
Started by Slammed&Cammed, 1 week ago
12 responses
219 views
1 like
Last Post Doc_V
by Doc_V
 
Started by Lifeguard, 6 days ago
7 responses
135 views
0 likes
Last Post Doc_V
by Doc_V
 
Started by YZ18, 5 days ago
17 responses
156 views
0 likes
Last Post Lug Nut
by Lug Nut
 
Started by mariner3302, 10-22-2020, 03:16 PM
17 responses
377 views
0 likes
Last Post davej
by davej
 
Started by Lug Nut, 6 days ago
0 responses
87 views
0 likes
Last Post Lug Nut
by Lug Nut
 
Started by Lug Nut, 6 days ago
0 responses
105 views
0 likes
Last Post Lug Nut
by Lug Nut
 
Started by Lug Nut, 1 week ago
16 responses
251 views
0 likes
Last Post Lug Nut
by Lug Nut
 
Started by Lug Nut, 6 days ago
3 responses
85 views
0 likes
Last Post Lug Nut
by Lug Nut
 
Working...
X