Announcement

Collapse
No announcement yet.

Clutch or tranny?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Jclevesque
    commented on 's reply
    Well said Brad I feel the same as you. JC

  • Brad_G
    commented on 's reply
    That's my biggest fear. No one has my safety in mind more than myself. I'm pretty particular about the way things are done. So in addition to the enjoyment of wrenching on things, I enjoy the satisfaction of getting it done to my standards.

  • Jclevesque
    replied
    Lesson learned there, do you own work. I will never let someone else touch my bikes. If I dont know a task, gonna learn/read/study until I am ready to tackle it. Never done any mechanic work before owning a bike. 12 years into it have taken engines aparts to rebuild. I say to myself, “if any monkey can take my stuff apart, I can sure learn and do myself!” JC

    Leave a comment:


  • Infantryjared1
    replied
    It was a powersports dealer that carries and services Yamaha and Kawasaki and Honda. Bikes and ATVs

    Leave a comment:


  • Infantryjared1
    replied
    Correct, so that's why I went ahead and did it myself. Have ridden few hundred miles since and hasn't done it since. So, that's a pretty big coincidence if you ask me

    Leave a comment:


  • Father Pobasturd
    commented on 's reply
    No, it went well except I couldn't find my brand new bag of Roblox so we had to scrape the gasket the old fashioned way. I have a good stout clutch now.

  • Brad_G
    commented on 's reply
    Who did you have change it? Could they have put in oil not designated for wet clutch?

  • Brad_G
    commented on 's reply
    Glad to hear yours is done and back on the road. Hopefully you’re feeling up to riding.

  • Infantryjared1
    replied
    So, after a lot of research on this site, I decided to go ahead and change my oil. The last two I took it in and had it done. The issue started after the 15k service. I tracked down some mobil1 vtwin synthetic and a K&N 303 filter and did it myself. I'm not saying the problem is solved, but rode 3 hours today and couldn't get it to slip

    Leave a comment:


  • Duke
    commented on 's reply
    Glad you got your clutch done FP. Any problems getting it done?

  • Father Pobasturd
    replied
    I just solved this same problem with my bike, it's a 2006. Though your bike is low miles, for years it has been sitting with pressure on the clutch diaphragm spring. Chances are pretty good replacing that or going with the Barnett conversion will solve your problem. I used the EBC replacement diaphragm spring, which is 30% stronger than the stock one. I couldn't really tell much difference as far as lever effort, but my clutch no longer slips, and it's not that hard of a job to do. Good luck.

    Leave a comment:


  • gillis.jordan
    replied
    Time for Barnett pressure plate!

    Leave a comment:


  • Jclevesque
    replied
    Like Mort said ensure clutch is set properly and if still slipping under load, time for a new spring or Barnett conversion kit.

    Leave a comment:


  • roadiemort
    replied
    Make sure it is adjusted properly before you jump to conclusions.

    Leave a comment:


  • Duke
    replied
    From what you said, your clutch is slipping. Time for more pressure.

    Leave a comment:


  • J89k
    replied
    Totally sounds like the clutch spring.

    My 04 had similar issues. Installed a barnets. Problem solved.

    there are some fantastic resources on replacing the clutch spring. I just posted them in Father Pobasturd's thread. Let me know if you need them.

    I needed new friction plates too. Ended up replacing the clutch plates as well because buying the whole clutch kit was almost the same price as individual friction disks.

    16k isn't many miles though.

    Leave a comment:


  • Infantryjared1
    started a topic Clutch or tranny?

    Clutch or tranny?

    So, I have a 2008 1700 that is, for the most part, gently rode. I have noticed here recently that under a heavy throttle twist, it feels as if the belt is slipping. Like the motor noise is there but for a second the power isn't being delivered. This happens while already in gear and sometimes right after shifting. I know it isn't the belt, it was inspected right after the 15k mile service. Any thoughts? Oh, the bike has just a little over 16k on it of which 6k we're my own miles. Thanks in advance

Latest Posts

Collapse

Topics Statistics Last Post
Started by Shores, 02-21-2018, 07:37 PM
15 responses
2,547 views
3 likes
Last Post McVinny614  
Started by Lug Nut, 1 hour ago
0 responses
11 views
0 likes
Last Post Lug Nut
by Lug Nut
 
Started by mariner3302, 4 days ago
10 responses
117 views
0 likes
Last Post MikeyC
by MikeyC
 
Started by chromax, 3 days ago
10 responses
206 views
1 like
Last Post Deerkiller  
Started by Ironman, 09-14-2018, 09:50 AM
34 responses
845 views
3 likes
Last Post Deerkiller  
Started by Shores, 1 week ago
30 responses
269 views
0 likes
Last Post Lug Nut
by Lug Nut
 
Started by GreenMachine, 08-13-2020, 12:19 PM
229 responses
2,278 views
3 likes
Last Post roadiemort  
Started by Flyinfish, 1 day ago
5 responses
87 views
0 likes
Last Post Lug Nut
by Lug Nut
 
Started by Shores, 1 day ago
4 responses
121 views
0 likes
Last Post Deerkiller  
Started by viking, 05-24-2019, 11:15 AM
30 responses
400 views
0 likes
Last Post davej
by davej
 
Started by Lug Nut, 1 day ago
0 responses
76 views
1 like
Last Post Lug Nut
by Lug Nut
 
Started by roadiemort, 4 weeks ago
159 responses
852 views
1 like
Last Post LDofDC
by LDofDC
 
Started by AR. Hillbilly, 02-01-2020, 10:31 AM
84 responses
1,113 views
2 likes
Last Post AR. Hillbilly  
Started by Flyinfish, 3 days ago
20 responses
108 views
0 likes
Last Post Jon D
by Jon D
 
Started by Lug Nut, 1 day ago
0 responses
41 views
0 likes
Last Post Lug Nut
by Lug Nut
 
Started by JoeX, 2 days ago
16 responses
124 views
1 like
Last Post EP Roadie  
Started by Jaskin71, 03-21-2019, 04:36 AM
27 responses
742 views
0 likes
Last Post zuluwave  
Started by Lug Nut, 3 days ago
10 responses
243 views
2 likes
Last Post Lug Nut
by Lug Nut
 
Started by Blackcloud12, 07-27-2020, 10:42 PM
56 responses
723 views
2 likes
Last Post Blackcloud12  
Started by MrG, 2 days ago
13 responses
124 views
0 likes
Last Post MrG
by MrG
 
Working...
X