Announcement

Collapse
No announcement yet.

Loss of power after engine is hot at speed

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Loss of power after engine is hot at speed

    While I"m on the highway, and only after the bike is hot, sometimes (not all the time), I get loss of power. It's brief, but it'll be there, then not, then there again. Kind of a bucking, but not dangerous bucking, just annoying. I can stop it with more or less throttle. Any ideas? Bad coil pack or rectifier maybe? It's a 2008 so it's injected.

    Also, any idea why the post whore thread was abandoned and not many of the old regulars have their posts and join dates updated? Anyone with a direct line to the admins maybe have them peek in there?

  • #2
    Is an after market fuel processor installed or are you running the stock ECU? The old site had to be shut down if that’s what you mean. We all had lots of warning. You have access to all moderators. Just PM them.
    signature

    Comment


    • #3
      It seems to me that you might be experiencing a fuel starving problem. Maybe air lock, tank venting??
      Remember, the stock ecm governs the RPMs at 4200 and causes ignition to cut off.

      Comment


      • #4
        I would think more in the fuel delivery than electrical. There is a filter inside the tank that may be giving you an issue along with maybe a little water and crap in the bottom of the tank getting stirred up on occasion.

        Comment


        • #5
          Originally posted by Shores View Post
          Is an after market fuel processor installed or are you running the stock ECU? The old site had to be shut down if that’s what you mean. We all had lots of warning. You have access to all moderators. Just PM them.
          It's the stock ECU.

          I'm talking about the thread where the admins offered to update original members post count and join dates on the new forum and then abandoned it but left it open and it has about 40 unanswered requests in it: https://www.roadstarclinic.com/forum...ll-post-whores

          Originally posted by Duke View Post
          It seems to me that you might be experiencing a fuel starving problem. Maybe air lock, tank venting??
          Remember, the stock ecm governs the RPMs at 4200 and causes ignition to cut off.
          Yeah, it's not a rev limit stop. We're talking about 4th gear, 65ish mph then just a hiccup like what I said in my post that can be alleviated with more or less throttle The cap has airflow, and it's injected, so air lock would be unlikely.

          Originally posted by davej View Post
          I would think more in the fuel delivery than electrical. There is a filter inside the tank that may be giving you an issue along with maybe a little water and crap in the bottom of the tank getting stirred up on occasion.
          I feel like if it was a filter issue maybe it would get progressively worse over time and throttle position wouldn't matter.

          Comment


          • #6
            Jonathan, the Post Whores thread is still there, it's just fallen way down the list since no one has posted to it since Nov. I know Tykes_Place was originally monitoring it, I personally haven't, but if PM me or one of the other Admins with your Info, we can update it for you.

            Comment


            • #7
              Hey Jonathan, Long time no see. How have you been .

              Is this something that happens more in the higher elavations ?










              This space intentionally left blank

              Comment


              • #8
                Originally posted by Doc_V View Post
                Jonathan, the Post Whores thread is still there, it's just fallen way down the list since no one has posted to it since Nov. I know Tykes_Place was originally monitoring it, I personally haven't, but if PM me or one of the other Admins with your Info, we can update it for you.
                Hey Doc, I don't have my info, Tykes_Place said they'd pull it from the old board info and just to post your username from the old forum in that thread. I don't remember when I joined or what my count was. According to the original post, everyone that's in that thread is still waiting to have their post counts and original join date set. After it's set, the member's reply to that thread was going to be deleted as a way of keeping track. It's not big deal, it's just that every time I pop in here, I hope to see that info has been updated.

                Originally posted by Jeaston View Post
                Hey Jonathan, Long time no see. How have you been .

                Is this something that happens more in the higher elavations ?
                Hey Jeaston, I'm doing OK. Didn't ride much last year. My mother passed away and I ended up renovating the house all summer to sell it. Just getting my bike ramped up and running so I can enjoy the summer.

                To answer your question, no, it's any time, but it's injected, so jetting wouldn't be the issue here (if that's what you're thinking).

                Comment


                • #9
                  I wonder if your clutch is momentarily slipping. This reminds me of when I discovered mine slipping . You say this occurs in 4th -5th gear , have you any increase in RPMs when this happens ?

                  Comment


                  • #10
                    I was thinking of slipping too. Mine was doing something similar at high speeds sorta slight hesitation then grab.

                    Comment


                    • #11
                      Originally posted by Jonathan View Post
                      Hey Doc, I don't have my info, Tykes_Place said they'd pull it from the old board info and just to post your username from the old forum in that thread. I don't remember when I joined or what my count was. According to the original post, everyone that's in that thread is still waiting to have their post counts and original join date set. After it's set, the member's reply to that thread was going to be deleted as a way of keeping track. It's not big deal, it's just that every time I pop in here, I hope to see that info has been updated.
                      Was your user name always Jonathan?

                      Comment


                      • #12
                        Doc, He has been with the fourm for a while now.

                        Jonathan are you still in the condo ? Or have you moved.







                        This space intentionally left blank

                        Comment


                        • #13
                          Just wanted to be sure Jonathan, you're looking a little different these days..



                          ...But then aren't we all.


                          Comment


                          • #14
                            Originally posted by Doc_V View Post
                            Just wanted to be sure Jonathan, you're looking a little different these days..



                            ...But then aren't we all.
                            That is def me. That pic is in the late fall with my hat in. This one here is with my hair down. I just grabbed what I had handy to update here.

                            Comment


                            • #15
                              Originally posted by Jeaston View Post
                              Doc, He has been with the fourm for a while now.

                              Jonathan are you still in the condo ? Or have you moved.
                              Still in the condo and just renovated it.

                              Comment


                              • #16
                                Originally posted by Horsehammerr View Post
                                I wonder if your clutch is momentarily slipping. This reminds me of when I discovered mine slipping . You say this occurs in 4th -5th gear , have you any increase in RPMs when this happens ?
                                Originally posted by Jclevesque View Post
                                I was thinking of slipping too. Mine was doing something similar at high speeds sorta slight hesitation then grab.
                                No increase in rpm's, just a tiny hesitation. Like the I'm just for a second getting no sparks or like the ECU is like "durrrrr" just for a moment. ,A certain it's not slipping, it's got brand new clutches I installed myself and a Barnett too, and never even blinks at long uphills under load. I wouldn't rule it out, but on a flat away at speed the clutch is under almost no load at all, and there's other times when it surely would slip if it was.

                                Last year I did put new pipes on the bike, I wonder if I ruined an air sensor doing it or if my sensor extension is bad on the left side.

                                Comment


                                • #17
                                  Just an FYI.

                                  The O2 sensors are only in a closed loop application (the ECU is processing what the O2 sensors are reading) during light throttle cruising. But, during idle and hard throttle applications the fuel system reverts to a preset, open loop default setting (which takes the O2s out of the loop) for a richer setting for better idle and a richer mix for power.

                                  Comment

                                  Latest Posts

                                  Collapse

                                  Topics Statistics Last Post
                                  Started by midnitmike, 5 hours ago
                                  3 responses
                                  33 views
                                  1 like
                                  Last Post Lug Nut
                                  by Lug Nut
                                   
                                  Started by JoeBloShmo, 3 hours ago
                                  3 responses
                                  22 views
                                  0 likes
                                  Last Post Horsehammerr  
                                  Started by AR. Hillbilly, 4 days ago
                                  12 responses
                                  195 views
                                  0 likes
                                  Last Post JoeBloShmo  
                                  Started by Herrindude, 1 day ago
                                  20 responses
                                  183 views
                                  0 likes
                                  Last Post Rodzim
                                  by Rodzim
                                   
                                  Started by Lug Nut, 2 days ago
                                  19 responses
                                  225 views
                                  0 likes
                                  Last Post Lug Nut
                                  by Lug Nut
                                   
                                  Started by Kenkaman, 1 day ago
                                  19 responses
                                  131 views
                                  0 likes
                                  Last Post Shores
                                  by Shores
                                   
                                  Started by gillis.jordan, 2 days ago
                                  13 responses
                                  153 views
                                  0 likes
                                  Last Post Doc_V
                                  by Doc_V
                                   
                                  Started by Lucky, 03-09-2019, 09:30 AM
                                  51 responses
                                  625 views
                                  3 likes
                                  Last Post highvoltage  
                                  Started by Kroyleahcim, 2 days ago
                                  4 responses
                                  92 views
                                  2 likes
                                  Last Post zingpow
                                  by zingpow
                                   
                                  Started by zingpow, 03-20-2019, 11:59 AM
                                  60 responses
                                  1,126 views
                                  0 likes
                                  Last Post zingpow
                                  by zingpow
                                   
                                  Started by coolalexrex, 17 hours ago
                                  3 responses
                                  66 views
                                  0 likes
                                  Last Post Lug Nut
                                  by Lug Nut
                                   
                                  AOC by Shores
                                  Started by Shores, 3 days ago
                                  59 responses
                                  447 views
                                  0 likes
                                  Last Post erizo
                                  by erizo
                                   
                                  Started by 99YamaDavidson, 6 days ago
                                  6 responses
                                  130 views
                                  0 likes
                                  Last Post BigPainRing  
                                  Started by Father Pobasturd, 1 day ago
                                  10 responses
                                  123 views
                                  1 like
                                  Last Post Zman
                                  by Zman
                                   
                                  Started by Jaskin71, 1 day ago
                                  16 responses
                                  287 views
                                  0 likes
                                  Last Post Kevstephenson7  
                                  Started by GreasySam, 08-22-2018, 10:45 PM
                                  37 responses
                                  591 views
                                  1 like
                                  Last Post GreasySam  
                                  Started by midnitmike, 4 weeks ago
                                  22 responses
                                  264 views
                                  2 likes
                                  Last Post midnitmike  
                                  Started by Shores, 2 days ago
                                  9 responses
                                  159 views
                                  0 likes
                                  Last Post Ahodge75  
                                  Started by Smokescreens, 03-05-2018, 10:34 AM
                                  212 responses
                                  4,022 views
                                  9 likes
                                  Last Post Shores
                                  by Shores
                                   
                                  Started by LeLimoMan, 2 days ago
                                  5 responses
                                  121 views
                                  1 like
                                  Last Post Father Pobasturd  
                                  Working...
                                  X