Announcement

Collapse
No announcement yet.

Idle issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Idle issue

    About 3 weeks ago my 1700 started to die at idle after it was hot. It acts like its out of fuel. Float level is good, idle jet is new, 3 turns out on the screw. I feel like its a fuel issue, but nothing I do is changing it. Ive even insulated the fuel line thinking that heat was effecting it. Ive checked my plugs, they look good, and have spark. Fuel pump is working, and petcock is flowing. I'm at a loss, and maybe even going down the wrong ave. It seems to idle great until it warms up, aroumd 30 miles, and the seconds after it hits idle bam dead. Starts right back up, hell it halls ass with no hiccups. Anyone got any idea where to go form here? Thanks

  • #2
    Try bypassing the fuel pump and see if it still does it. The pump may be starting to fail. Run some fuel line directly from the petcock to the carb.

    BTW, from Dallas
    Peace,
    Baron Wilhelm Gustav von Schmidt III
    (But you can call me Joe)

    Comment


    • RoadstarDevil
      RoadstarDevil commented
      Editing a comment
      thanks for the idea, I will give it a try.

      And glad to be here!

  • #3
    Set the idle at 900 when hot.

    “The West is the Best" - Jim Morrison

    Comment


    • RoadstarDevil
      RoadstarDevil commented
      Editing a comment
      It's not a case of turning the idle up or down. I wish It were that easy. The condition still exists no matter where i set the idle screw.

  • #4
    First of all... from California. As for your idle issue, I"m wondering if your float needle valve is sticking. They do wear out over time and can stick. Or possibly a gummed up idle jet. Maybe even a clogged fuel filter... Try bypassing the fuel filter by moving the hoses on the side. It does sound like a fuel issue, but to be sure, check the simple things like the battery and coil connectors. Have you done any messing with the wiring lately? I once had a problem where my bike would cut out on the freeway at speeds above 75 and it turned out to be a loose wire because I didn't plug something back in properly. Anyway, just hang in there; I'm sure with all the collective noggins here you'll figure it out eventually.
    Last edited by Doc_V; 1 week ago.

    Comment


    • RoadstarDevil
      RoadstarDevil commented
      Editing a comment
      Greetings from Illinois
      I am going to replace the needle jet next. I inspected it and no rings or garbage built up. It has a new idle jet. I will bypass the filter and see if that does anything. What is so aggravating as to why I can't figure this out, I work on Harleys for a living! (make jokes here) So I've defiantly been over the simple things. And to add to the aggravation, you can (or should) only change 1 thing at a time. Ride it an hour to get it hot enough, find out that didn't work, let it cool. rinse and repeat ugh.

    • daveto
      daveto commented
      Editing a comment
      I love it! A Harley mechanic riding a roadstar, smartest Harley mechanic I have seen yet! Keep up the great work, I’m sure you can figure it out.

  • #5
    Welp for those following this post, I figured out my issues. Rear intake gasket was shot. Repaired 2 nights ago, made 4 trips cold to hot and no problem. Thanks for all the help!

    Comment


    • #6
      We all Love happy endings.

      Comment

      Latest Posts

      Collapse

      Topics Statistics Last Post
      Started by NCB, 2 days ago
      19 responses
      187 views
      0 likes
      Last Post NCB
      by NCB
       
      Started by FDRUCaptain, 1 day ago
      37 responses
      374 views
      0 likes
      Last Post FDRUCaptain  
      Started by Cowboy, 44 minutes ago
      0 responses
      14 views
      0 likes
      Last Post Cowboy
      by Cowboy
       
      Started by link55x, 2 hours ago
      2 responses
      28 views
      0 likes
      Last Post Duke
      by Duke
       
      Started by roadiemort, 03-05-2018, 07:01 PM
      1,686 responses
      14,696 views
      3 likes
      Last Post Brad_G
      by Brad_G
       
      Started by CBOB, 20 hours ago
      20 responses
      77 views
      0 likes
      Last Post blueverclear  
      Started by Dcspurlock, 1 day ago
      16 responses
      146 views
      0 likes
      Last Post Bikerron  
      Started by Cmw2212, 1 day ago
      9 responses
      106 views
      0 likes
      Last Post Ironman
      by Ironman
       
      Started by Txulrich, 04-24-2018, 12:12 PM
      311 responses
      2,555 views
      0 likes
      Last Post Txulrich  
      Started by AR. Hillbilly, 1 week ago
      32 responses
      313 views
      0 likes
      Last Post tlr200
      by tlr200
       
      Started by roadiemort, 19 hours ago
      4 responses
      73 views
      0 likes
      Last Post YZ18
      by YZ18
       
      Started by Messer2.0, 02-13-2018, 08:58 PM
      76 responses
      911 views
      0 likes
      Last Post SMOKINJOE  
      Started by Tykes_Place, 02-13-2018, 11:49 PM
      64 responses
      2,211 views
      3 likes
      Last Post blueverclear  
      Started by brianmac, 1 week ago
      13 responses
      206 views
      0 likes
      Last Post Jclevesque  
      Started by Tykes_Place, 1 day ago
      5 responses
      102 views
      0 likes
      Last Post tlr200
      by tlr200
       
      Started by Horsehammerr, 1 day ago
      5 responses
      111 views
      0 likes
      Last Post davej
      by davej
       
      Started by Sshows, 1 day ago
      5 responses
      79 views
      0 likes
      Last Post Jike
      by Jike
       
      Started by AR. Hillbilly, 1 day ago
      14 responses
      137 views
      0 likes
      Last Post Bikerron  
      Started by RoadstarDevil, 1 week ago
      9 responses
      127 views
      0 likes
      Last Post Spydr
      by Spydr
       
      Working...
      X