Announcement

Collapse
No announcement yet.

Idle issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Idle issue

    About 3 weeks ago my 1700 started to die at idle after it was hot. It acts like its out of fuel. Float level is good, idle jet is new, 3 turns out on the screw. I feel like its a fuel issue, but nothing I do is changing it. Ive even insulated the fuel line thinking that heat was effecting it. Ive checked my plugs, they look good, and have spark. Fuel pump is working, and petcock is flowing. I'm at a loss, and maybe even going down the wrong ave. It seems to idle great until it warms up, aroumd 30 miles, and the seconds after it hits idle bam dead. Starts right back up, hell it halls ass with no hiccups. Anyone got any idea where to go form here? Thanks

  • #2
    Try bypassing the fuel pump and see if it still does it. The pump may be starting to fail. Run some fuel line directly from the petcock to the carb.

    BTW, from Dallas
    Peace,
    Baron Wilhelm Gustav von Schmidt III
    (But you can call me Joe)

    Comment


    • RoadstarDevil
      RoadstarDevil commented
      Editing a comment
      thanks for the idea, I will give it a try.

      And glad to be here!

  • #3
    Set the idle at 900 when hot.

    Comment


    • RoadstarDevil
      RoadstarDevil commented
      Editing a comment
      It's not a case of turning the idle up or down. I wish It were that easy. The condition still exists no matter where i set the idle screw.

  • #4
    First of all... from California. As for your idle issue, I"m wondering if your float needle valve is sticking. They do wear out over time and can stick. Or possibly a gummed up idle jet. Maybe even a clogged fuel filter... Try bypassing the fuel filter by moving the hoses on the side. It does sound like a fuel issue, but to be sure, check the simple things like the battery and coil connectors. Have you done any messing with the wiring lately? I once had a problem where my bike would cut out on the freeway at speeds above 75 and it turned out to be a loose wire because I didn't plug something back in properly. Anyway, just hang in there; I'm sure with all the collective noggins here you'll figure it out eventually.
    Last edited by Doc_V; 08-10-2018, 05:15 PM.

    Comment


    • RoadstarDevil
      RoadstarDevil commented
      Editing a comment
      Greetings from Illinois
      I am going to replace the needle jet next. I inspected it and no rings or garbage built up. It has a new idle jet. I will bypass the filter and see if that does anything. What is so aggravating as to why I can't figure this out, I work on Harleys for a living! (make jokes here) So I've defiantly been over the simple things. And to add to the aggravation, you can (or should) only change 1 thing at a time. Ride it an hour to get it hot enough, find out that didn't work, let it cool. rinse and repeat ugh.

    • daveto
      daveto commented
      Editing a comment
      I love it! A Harley mechanic riding a roadstar, smartest Harley mechanic I have seen yet! Keep up the great work, I’m sure you can figure it out.

  • #5
    Welp for those following this post, I figured out my issues. Rear intake gasket was shot. Repaired 2 nights ago, made 4 trips cold to hot and no problem. Thanks for all the help!

    Comment


    • #6
      We all Love happy endings.

      Comment

      Latest Posts

      Collapse

      Topics Statistics Last Post
      Started by roadiemort, 5 days ago
      58 responses
      375 views
      0 likes
      Last Post roadiemort  
      Started by Bigpapakeat, 10 hours ago
      3 responses
      25 views
      0 likes
      Last Post RPHazen
      by RPHazen
       
      Started by Doc_V, 2 days ago
      6 responses
      69 views
      0 likes
      Last Post Doc_V
      by Doc_V
       
      Started by zingpow, 2 days ago
      8 responses
      176 views
      0 likes
      Last Post Jaybo
      by Jaybo
       
      Started by cike, 1 day ago
      26 responses
      351 views
      1 like
      Last Post Doc_V
      by Doc_V
       
      Started by Chief_10Beers, 7 hours ago
      0 responses
      15 views
      0 likes
      Last Post Chief_10Beers  
      Started by JoeBloShmo, 07-24-2018, 10:27 PM
      69 responses
      850 views
      1 like
      Last Post JoeBloShmo  
      Started by Questcap, 1 day ago
      9 responses
      144 views
      0 likes
      Last Post Doc_V
      by Doc_V
       
      Started by mbk, 1 day ago
      6 responses
      66 views
      1 like
      Last Post Lucky
      by Lucky
       
      Started by Jaybo, 1 day ago
      12 responses
      114 views
      0 likes
      Last Post Jaybo
      by Jaybo
       
      Started by zingpow, 4 days ago
      11 responses
      153 views
      0 likes
      Last Post zingpow
      by zingpow
       
      Started by midnitmike, 1 day ago
      10 responses
      139 views
      1 like
      Last Post Leadkrm
      by Leadkrm
       
      Started by Lug Nut, 1 day ago
      1 response
      60 views
      0 likes
      Last Post Doc_V
      by Doc_V
       
      Started by cike, 2 days ago
      31 responses
      1,043 views
      0 likes
      Last Post Rob in FL  
      Started by Father Pobasturd, 1 day ago
      6 responses
      146 views
      0 likes
      Last Post Rob in FL  
      Started by Jaskin71, 2 days ago
      16 responses
      143 views
      0 likes
      Last Post Questcap  
      Started by davej, 02-27-2018, 12:05 PM
      36 responses
      673 views
      5 likes
      Last Post JGrsemonkey  
      Started by slyguy, 4 days ago
      8 responses
      188 views
      0 likes
      Last Post Yaman
      by Yaman
       
      Started by Tykes_Place, 01-14-2019, 12:47 AM
      23 responses
      339 views
      1 like
      Last Post Brad_G
      by Brad_G
       
      Started by D-Fresh, 5 days ago
      44 responses
      258 views
      0 likes
      Last Post Nwrodie
      by Nwrodie
       
      Working...
      X