Announcement

Collapse
No announcement yet.

Check engine light randomly lights - TPS going bad?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Check engine light randomly lights - TPS going bad?

    Hey y'all,
    Gonna try and keep this focused as there's a lot going on. Here goes... and thanks in advance for any assistance y'all can provide!!

    Issue:
    • Check engine light comes on under load after carb clean and rebuild.
    History:
    • The bike had sat for a while and needed some TLC in order to run
    • I stripped, cleaned, and rebuilt the carb
    • I also replaced battery cables, starter, solenoid, and battery
    • Finally, I installed LED running lights/turn signals with appropriate relay
    After this work, the Check engine light would randomly (Not so randomly after paying a bit of attention) come on when the bike is under load. It seems to come on at around mid-range throttle and just before idle. Light is off the rest of the time.

    I Checked the TPS and the resistance was low, so I adjusted to:
    • 5.09K ohms resistance measured when checking the Blue and Black wires
    • 0.97K ohms resistance measured between the Yellow and Black terminals at idle
    • 4.03k ohms resistance measured between the Yellow and Black terminals at WOT
    All that said, the bike runs like a scalded dog. No stutters, fluctuations in power, or other anomalies observed.

    Questions:
    • This did not happen prior to the work. How concerned should I be?
    • Does the TPS connection at the carb somehow need to be greased, oiled, or otherwise lubricated?
    • Is this the sign of an aging TPS that needs to be replaced?

    General Info:
    • '99 Yamaha Roadstar.
    • Mileage 54,728
    • Pumpless with 3.0 Needle valve
    • 167.5 main jet, 37.5 pilot jet, and MaxAir filter
    • Barons Nasty Habits

  • #2
    From the ohms reading you mentioned, your TPS is fine, if the connection is good.
    When the light comes on, does it blink, or just stay on?
    Just guessing, but I'm inclined to think it could be the gas gauge sending unit.

    Comment


    • #3
      Hey Duke,
      I appreciate the reply! It does not blink. It'll light, then turn off again. Where is the gas gauge sending unit located?
      ​​​
      Thanks,
      Tony

      Comment


      • #4
        In the tank with the float.

        Comment


        • #5
          Thanks Bikerron!
          You think the Techron Concentrate Plus fix you've mentioned in other threads may help here as well? Also, do you think this will leave me stranded, or is it more cosmetic?

          Thanks,
          Tony

          Comment


          • #6
            My CEL light has been on since I bought it. 2 mechanics could find nothing wrong and it runs fine, so it's just annoying.
            2000 Roadstar 1600 - BAK, Pumpless, Curt's manifold, Mikuni HSR42 Freedom Combat Pipes Jumbo Strong bags, PPG 'HellFire' Paint.

            Comment


            • #7
              Good to know, Jaybo!! I'll be strageically placing a small bit of black tape and going for a ride...

              Comment


              • #8
                Try unplugging the sending unit. It's located under the seat and at the base of the fuel tank. Green connector plug.
                If it changes what the light is doing, light stays on, or off, then it's the float sending unit. I can't remember what the light does, on or off.

                Comment


                • Jaybo
                  Jaybo commented
                  Editing a comment
                  My gas gauge does work though, sometimes the light is off until I start out, sometimes not. Sometimes it goes off and comes back on, etc. It generally stays lit most of the time.

              • #9
                Google " road star fuel sending unit repair"- Flickr. There is an article with pictures that is very good.hope this helps.
                I will not apologize for being white, being straight or for loving this country.

                Comment


                • #10
                  Originally posted by Duke View Post
                  Try unplugging the sending unit. It's located under the seat and at the base of the fuel tank. Green connector plug.
                  If it changes what the light is doing, light stays on, or off, then it's the float sending unit. I can't remember what the light does, on or off.
                  Thanks for the suggestion, Duke! I reseated that connection when I put the tank back on, but probably a good idea to spray a little contact spray on those contacts. I'll add that to the To-Do list.

                  Comment


                  • #11
                    Originally posted by highvoltage View Post
                    Google " road star fuel sending unit repair"- Flickr. There is an article with pictures that is very good.hope this helps.
                    Thanks, Highvoltage!! I'll look it up!

                    Comment


                    • #12
                      I would think if your gas gauge is working then the sending unit and connection are ok...I do believe there is a faulty connection or broken wire somewhere tho.
                      not all those who wander are lost......

                      Comment


                      • #13
                        If it's the fuel sending unit the light will blink, I forget what code it will blink.
                        Life is short, eat dessert first----Unknown

                        Comment

                        Latest Posts

                        Collapse

                        Topics Statistics Last Post
                        Started by Smokescreens, 2 weeks ago
                        50 responses
                        778 views
                        0 likes
                        Last Post Smokescreens  
                        Started by RoadieRob, 22 hours ago
                        2 responses
                        22 views
                        0 likes
                        Last Post RoadieRob  
                        Started by twowheeltherapy, 5 days ago
                        30 responses
                        140 views
                        4 likes
                        Last Post twowheeltherapy  
                        Started by curtixman, 1 day ago
                        4 responses
                        80 views
                        0 likes
                        Last Post MikeyC
                        by MikeyC
                         
                        Started by cap-tech, 6 days ago
                        7 responses
                        125 views
                        0 likes
                        Last Post Lug Nut
                        by Lug Nut
                         
                        Started by Darkkill57, 1 day ago
                        8 responses
                        93 views
                        0 likes
                        Last Post ItBeMe
                        by ItBeMe
                         
                        Started by Bear1433, 1 day ago
                        2 responses
                        39 views
                        0 likes
                        Last Post Bear1433  
                        Started by Cubo55, 2 days ago
                        12 responses
                        88 views
                        0 likes
                        Last Post Shores
                        by Shores
                         
                        Started by roadiemort, 1 day ago
                        3 responses
                        43 views
                        0 likes
                        Last Post Brad_G
                        by Brad_G
                         
                        Started by Jaybo, 04-20-2020, 11:36 PM
                        46 responses
                        573 views
                        1 like
                        Last Post curtixman  
                        Started by Lifeguard, 1 day ago
                        1 response
                        39 views
                        0 likes
                        Last Post Blackcloud12  
                        Started by NCB, 4 days ago
                        10 responses
                        119 views
                        0 likes
                        Last Post Pauli466  
                        Started by YZ18, 1 day ago
                        1 response
                        48 views
                        0 likes
                        Last Post GuernseyLad  
                        Started by coolalexrex, 1 day ago
                        2 responses
                        41 views
                        0 likes
                        Last Post davej
                        by davej
                         
                        Started by J89k, 2 weeks ago
                        7 responses
                        154 views
                        0 likes
                        Last Post J89k
                        by J89k
                         
                        Started by Angel220, 5 days ago
                        4 responses
                        110 views
                        0 likes
                        Last Post brianmac  
                        Started by AR. Hillbilly, 02-01-2020, 10:31 AM
                        18 responses
                        208 views
                        1 like
                        Last Post Horsehammerr  
                        Started by Jaybo, 5 days ago
                        10 responses
                        99 views
                        0 likes
                        Last Post Jaybo
                        by Jaybo
                         
                        Started by Jaybo, 2 days ago
                        1 response
                        31 views
                        0 likes
                        Last Post Jaybo
                        by Jaybo
                         
                        Started by kwarten, 1 week ago
                        4 responses
                        129 views
                        0 likes
                        Last Post Jaybo
                        by Jaybo
                         
                        Working...
                        X