Announcement

Collapse
No announcement yet.

Bike stalls

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bike stalls

    I was riding one afternoon from work and as I was going 70-80 mph and I came to a stop for a signal light, the bike died. I tried to start it back up but the bike just spin over. I had all the power from radio to headlight. I had a local sport bike mechanic work on it and he says he cleaned and jetted the carburetor. The bike ran but it did the exact same thing. The bike has new plugs, new fuel pump, (non Oem) and a new fuel filter. I even had the gas tank coated so rust wont start and I use premium gas only. Any advice would be helpful because I cant afford dealership prices.

  • #2
    Fuel pump may have quit. Non OEM are questionable reliability. No need to rejet if it was running fine before. Beware of mechanics. No need for premium fuel. The engine is a low compression design and engineered for 87. What year? How many miles? What is your current jetting? Stock intake filter and exhaust? We need much more into to help you.

    Comment


    • #3
      I'm with Shores on the non OEM fuel pump. They are junk. You would be better off picking up a used oem one off ebay. Typically it's the points in the pump that fail and can be replaced with minimum work.
      A lot of the people here remove the pump completely to eliminate pump issues. I'm sure the other guys here with carbed bikes can chime in on what needs to done for the pump removal.

      Comment


      • #4
        Like Shores said, no more money to the mechanic; we can help you figure it out. And yes, the more info you can provide, the better we can help you. There are a number of possibilities but fuel pump is as likely a place to start as any. When you turn the bike on, do you hear the pump buzzing? Can you start the bike now? If the answer to both of those is "no", many have had aftermarket pumps fail right away, so it wouldn't be surprising. I just had a member send me a fuel pump a couple days ago and there were others on the following thread who had one available. Be sure to check it out and ask; I'm sure someone will step up: https://www.roadstarclinic.com/forum...hy-go-pumpless

        Comment


        • #5
          Gas tank may not be venting...........especially after having it coated.....
          not all those who wander are lost......

          Comment


          • #6
            Replace fuel pump with a new OEM one... $130....
            I would replace the fuel filter and look at the old one carefully. Pull the tank dran the gas and look at the screen/filter on the petcock to see if it's dirty. If the mechanic said he jetted the car ask SPECIFICALLY what brand and size he used and if he removed the carb from the bike for his "cleaning".

            how many miles in bike, what was used to coat the tank and who did it? Use 87 octane only and run Seafoam Motor Treatment through 3 full tanks in a row per instructions on can.
            LET'S RIDE

            Comment


            • #7
              Originally posted by Flashback View Post
              Gas tank may not be venting...........especially after having it coated.....
              +1

              Comment


              • #8
                I'm with Shores and Flash, check the gas tank vent at the front right of the tank!

                Comment


                • #9
                  Originally posted by Lug Nut View Post
                  Replace fuel pump with a new OEM one... $130....
                  I would replace the fuel filter and look at the old one carefully. Pull the tank dran the gas and look at the screen/filter on the petcock to see if it's dirty. If the mechanic said he jetted the car ask SPECIFICALLY what brand and size he used and if he removed the carb from the bike for his "cleaning".

                  how many miles in bike, what was used to coat the tank and who did it? Use 87 octane only and run Seafoam Motor Treatment through 3 full tanks in a row per instructions on can.
                  The petcock is also after market new. With the key on you can hear the pump clicking. The “mechanic” said he added bigger jets but I never seen the the jets. I’m gonna order a Oem fuel pump. The engine has 29,000 miles but the bike sat in a trailer for 14 months before he worked on it. Guys I’m sorry about the questions this my 1st cruiser and it upsets me when I go to work every day and a so called mechanic works on my bike

                  Comment


                  • #10
                    Originally posted by Shores View Post
                    Fuel pump may have quit. Non OEM are questionable reliability. No need to rejet if it was running fine before. Beware of mechanics. No need for premium fuel. The engine is a low compression design and engineered for 87. What year? How many miles? What is your current jetting? Stock intake filter and exhaust? We need much more into to help you.
                    Crazy thing is mechanic said I need to run 100 octane

                    Comment


                    • jd750ace
                      jd750ace commented
                      Editing a comment
                      Yeah, I'd steer clear of "that guy"

                  • #11
                    Have you tried starting the bike since you got it home? If your tank is not venting properly, even if the pump is working, it can't suck any fuel out of the tank. Open the gas cap for a moment and then try starting it again. If it starts and dies a few mins later, try opening the gas cap again, if you hear air get sucked in, the tank vent is your problem.

                    Check that and let us know what happens.

                    Comment


                    • #12
                      Originally posted by Cutdog1978 View Post

                      Crazy thing is mechanic said I need to run 100 octane
                      Forget mechanics! See the manual....87. High octane is for high compression engines. Contrary to popular belief, high octane doesn’t give every engine better performance. Octane suppresses combustion which is necessary for high compression engines. You are wasting money on the Roadstars low compression engine. My FI Roadstar runs hot on high octane.

                      Comment


                      • #13
                        +1 what Shores said....forget mechanics. Our bikes (stock not HC modified) run better with low octane. Plenty can attest that and I am one of them. Ask here first for opinions from now on. Plenty of knowledge and experience with these bikes. Sounds like a pump or tank vent problem. Checking the roll over valve too would be on my list to check out.

                        Comment


                        • #14
                          Originally posted by Jclevesque View Post
                          +1 what Shores said....forget mechanics. Our bikes (stock not HC modified) run better with low octane. Plenty can attest that and I am one of them. Ask here first for opinions from now on. Plenty of knowledge and experience with these bikes. Sounds like a pump or tank vent problem. Checking the roll over valve too would be on my list to check out.
                          I just got my oem fuel pump and I’m going to clean out the gas tank vent hole. I’ll let you no how it turns out

                          Comment


                          • Flashback
                            Flashback commented
                            Editing a comment
                            You may find it difficult to clear the tank vent. best bet is to vent the gas cap....

                        • #15
                          When you get it all together and take it for a ride, if it does it again, open the gas cap for a moment and try again. If it starts after opening the gas cap, you still have a tank breather issue; in which case I'd try pulling the breather hose off the rollover valve on the left side of the frame. Best of luck; let us know what happens.

                          Comment


                          • #16
                            Originally posted by Doc_V View Post
                            When you get it all together and take it for a ride, if it does it again, open the gas cap for a moment and try again. If it starts after opening the gas cap, you still have a tank breather issue; in which case I'd try pulling the breather hose off the rollover valve on the left side of the frame. Best of luck; let us know what happens.
                            I added 2 oem coils and new spark plugs still does the same thing. Someone I know said something about the ignition module. I’m tired of breaking down. When the bike runs ill go about 70 mph and feels like its stalling. When it dies I still have full power but no startup. After the bike cools down for a few hours it starts back up. How do I check if the gas tank vent is not stopped up. The weather here in Georgia been amazing and my bike been stuck in the garage. This is so depressing

                            Comment


                            • #17
                              Originally posted by Cutdog1978 View Post

                              I added 2 oem coils and new spark plugs still does the same thing. Someone I know said something about the ignition module. I’m tired of breaking down. When the bike runs ill go about 70 mph and feels like its stalling. When it dies I still have full power but no startup. After the bike cools down for a few hours it starts back up. How do I check if the gas tank vent is not stopped up. The weather here in Georgia been amazing and my bike been stuck in the garage. This is so depressing
                              Remove the chrome instrument cover on the tank. Underneath it you'll see a metal tube coming off the tank with a rubber hose connected to it. That's your tank vent. If you had the insides of the tank coated it may have clogged that vent. Get some stiff wire and stick it down into the vent tube, make sure it's not clogged. If it is, that's likely your problem. If not...

                              Another thing that comes to mind is float level. If it's too high, as you come to a stop, fuel runs up the tube from the fuel sloshing forward in the float bowl and floods the motor. [I've had that happen before.] If it set too high, and the bike is really hot, like coming off the freeway, even with the motor off it can continue to percolate out of the tube for a while and continue to flood the motor, preventing you from restarting. As the bike sits and cools, the fuel evaporates and all is well again. This could also be a possible explanation for why it feels like it's stalling at 70 MPH. Excess fuel could be percolating out of the feed tube and causing an overly rich condition. It's easy enough to check that you should rule it out before proceeding with any more electrical items.

                              As for fuel, there's zero reason to run premium on these bikes, unless you have high compression pistons. They call for regular 87 octane, though if it's a really hot day, and you get some low RPM knocking, mid-grade fuel can help.

                              Click image for larger versionName:	R* Measure fuel level in float bowl.jpgViews:	0Size:	262.5 KBID:	108188
                              Last edited by Doc_V; 09-13-2020, 08:27 PM.

                              Comment


                              • #18
                                Didnyou replace fuel pump with orm or still using non stock one? Change fuel filter?

                                Pull tank off and the small nipple at front of tank is the vent... There is a small rubber hose that goes from that nipple down the frame to the rollover valve. Tank vent itself may be plugged or line/ rollover valve may be plugged
                                ​​​​​​... Can try to blow out line with air
                                LET'S RIDE

                                Comment


                                • #19
                                  Originally posted by Lug Nut View Post
                                  Didnyou replace fuel pump with orm or still using non stock one? Change fuel filter?

                                  Pull tank off and the small nipple at front of tank is the vent... There is a small rubber hose that goes from that nipple down the frame to the rollover valve. Tank vent itself may be plugged or line/ rollover valve may be plugged
                                  ​​​​​​... Can try to blow out line with air
                                  Yes I did change the fuel pump from aftermarket to a oem fuel pump. A guy I know was saying the ignition module was the problem because its getting hot causing the bike to cut off. I’m so upset because I’m tired of throwing parts at the bike. You guys been giving me awesome advice.

                                  Comment


                                  • #20
                                    Originally posted by Doc_V View Post

                                    Remove the chrome instrument cover on the tank. Underneath it you'll see a metal tube coming off the tank with a rubber hose connected to it. That's your tank vent. If you had the insides of the tank coated it may have clogged that vent. Get some stiff wire and stick it down into the vent tube, make sure it's not clogged. If it is, that's likely your problem. If not...

                                    Another thing that comes to mind is float level. If it's too high, as you come to a stop, fuel runs up the tube from the fuel sloshing forward in the float bowl and floods the motor. [I've had that happen before.] If it set too high, and the bike is really hot, like coming off the freeway, even with the motor off it can continue to percolate out of the tube for a while and continue to flood the motor, preventing you from restarting. As the bike sits and cools, the fuel evaporates and all is well again. This could also be a possible explanation for why it feels like it's stalling at 70 MPH. Excess fuel could be percolating out of the feed tube and causing an overly rich condition. It's easy enough to check that you should rule it out before proceeding with any more electrical items.

                                    As for fuel, there's zero reason to run premium on these bikes, unless you have high compression pistons. They call for regular 87 octane, though if it's really hot and you get some low RPM knocking, mid-grade fuel can help.

                                    Click image for larger versionName:	R* Measure fuel level in float bowl.jpgViews:	0Size:	262.5 KBID:	108188
                                    Tomorrow ill put a wire down the vent hole to make sure its not clogged. What is a rollover valve. You’ll been SUPER helpful to me for that I’m very grateful and thankful

                                    Comment

                                    Latest Posts

                                    Collapse

                                    Topics Statistics Last Post
                                    Started by 6door7r, 3 days ago
                                    5 responses
                                    88 views
                                    2 likes
                                    Last Post Chromepony  
                                    Started by Lug Nut, 3 hours ago
                                    3 responses
                                    24 views
                                    0 likes
                                    Last Post Lug Nut
                                    by Lug Nut
                                     
                                    Started by Tykes_Place, 3 weeks ago
                                    27 responses
                                    307 views
                                    0 likes
                                    Last Post Lug Nut
                                    by Lug Nut
                                     
                                    Started by p birk, 3 days ago
                                    16 responses
                                    152 views
                                    0 likes
                                    Last Post Tcontrol  
                                    Started by V-Max, 03-05-2018, 09:08 AM
                                    57 responses
                                    4,854 views
                                    0 likes
                                    Last Post Shotround  
                                    Started by Bnag0, 04-13-2022, 11:05 PM
                                    102 responses
                                    1,283 views
                                    1 like
                                    Last Post Bnag0
                                    by Bnag0
                                     
                                    Started by luff_tackle, 1 day ago
                                    9 responses
                                    119 views
                                    0 likes
                                    Last Post brianmac  
                                    Started by roadiemort, 17 hours ago
                                    3 responses
                                    16 views
                                    0 likes
                                    Last Post roadiemort  
                                    Started by jb3472, 2 days ago
                                    13 responses
                                    86 views
                                    0 likes
                                    Last Post Chooch
                                    by Chooch
                                     
                                    Started by ABCarr, 4 days ago
                                    14 responses
                                    166 views
                                    0 likes
                                    Last Post ABCarr
                                    by ABCarr
                                     
                                    Started by BloodMoney, 04-15-2022, 02:28 PM
                                    17 responses
                                    173 views
                                    0 likes
                                    Last Post BloodMoney  
                                    Started by Lug Nut, 3 days ago
                                    11 responses
                                    100 views
                                    2 likes
                                    Last Post Lug Nut
                                    by Lug Nut
                                     
                                    Started by Tykes_Place, 3 days ago
                                    18 responses
                                    143 views
                                    0 likes
                                    Last Post DEEPHATE  
                                    Started by BloodMoney, 1 week ago
                                    5 responses
                                    57 views
                                    0 likes
                                    Last Post BloodMoney  
                                    Started by Sabotage, 6 days ago
                                    9 responses
                                    120 views
                                    0 likes
                                    Last Post Sabotage  
                                    Started by LordOfTheBuzzards, 3 weeks ago
                                    31 responses
                                    359 views
                                    0 likes
                                    Last Post LordOfTheBuzzards  
                                    Started by ItBeMe, 3 days ago
                                    3 responses
                                    47 views
                                    0 likes
                                    Last Post roadiemort  
                                    Started by Lifeguard, 4 days ago
                                    14 responses
                                    126 views
                                    0 likes
                                    Last Post Duke
                                    by Duke
                                     
                                    Started by Shores, 5 days ago
                                    13 responses
                                    119 views
                                    0 likes
                                    Last Post brianmac  
                                    Started by CoolCheech, 6 days ago
                                    23 responses
                                    154 views
                                    0 likes
                                    Last Post 6door7r
                                    by 6door7r
                                     
                                    Working...
                                    X