Announcement

Collapse
No announcement yet.

Adjustment Needed.....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Adjustment Needed.....

    But I'm not sure where to start.

    Bike starts and runs great, but until it's fully warmed up it acts like it's starving for fuel. But if I pull the choke/enricher out it acts like it's flooding, and I get a strong gas smell. So the only way I can keep it running without cutting out is to increase the idle speed. But then once it's warmed up, the idle speed is too fast.

    I'm running the stock carb with a Dynojet needle with the clip in the 4th groove, a 172.5 main jet, a pilot jet and the PMS is at 2.5 turns out.

    And yes, it does require the choke to be pulled out in order to start, then within 30 seconds or so I can go to about 1/2 way in. And within a minute or so I'll start riding and the position of the choke doesn't matter; all the way in or out and it acts like it's cutting out. So I increase the idle speed.

    Any ideas?

    Thanks!!

  • #2
    Need more information. What year is bike? How many miles on bikes? What air filter assembly and what exhaust? What other modifications? Is the intake manifold cracked or leaking? Do you have the AIS deleted?
    LET'S RIDE

    Comment


    • #3
      2005 Silverado AIS removed
      Ported manifold in good shape
      Mikuni K&N filter with Arlen Ness Big Sucker cover
      Cobra HP 2-into-1 exhaust


      Comment


      • #4
        40 pilot? from what your setup is you're jetting seems fine PMS seems fine clip position seems fine and your bike should run like a raped ape. Are you sure there's no exhaust leaks? No intake leak did you spray starting fluid around the intake manifold while running toVerify? Have you checked for sticky valve syndrome? When the bike is running take a dollar bill and put it at the exhaust pipe and see if it consistently pushes it out or if once in a while it tries to suck it in.
        LET'S RIDE

        Comment


        • #5
          And it does run fantastic after it's warmed up. It's just when it's cold that it cuts out unless I speed up the idle. And then it runs great. In both situations, cold with the idle sped up or once it's warmed up, it's got very good throttle response and no hiccups when I blip the throttle. Just kinda strange...

          ​​​​​​I'll check the things you mentioned and see if there are any issues.

          Thanks!

          Comment


          • #6
            Some are cold-blooded. If your plugs look good, then it maybe okay. Just don't ride it until it's warmed up. Only adjust the idle when it's warm to about 900 rpm.

            Comment


            • #7
              Yeah I would change plugs make sure you use NGK 5129 gapped at 034. Get it warmed up after a half hour ride and get an easy tach or play with the throttle but do not play with the idle once it's adjusted. set the idle at 900 and then do not mess with the idle to try to solve problems. Leave it alone completely. You may need the enricher longer or play with the throttle but do not play with the idle once it's adjusted.
              LET'S RIDE

              Comment


              • #8
                Yeah, I've had the bike since 2006 and it's definitely cold-blooded, but not like this. This just started since re-rejetting the carb and installing the Cobra pipes. I rejetted it in 2008 when I installed a set of Hard Krome pipes. I will say that the overall performance is better with this set-up, except for the annoying cold running issue.

                Comment


                • #9
                  I’m with Shores. How do the plugs look?

                  Check for leaks with some starter fluid on the intake system. If the idle changes, you’ll know. As for the exhaust, drift some smoke around all of the couplings and look for any movement..

                  ‘’Ratl.

                  Comment


                  • #10
                    I have a 1999 RS and i live in Canada near Niagara Falls. The bike definitely doesn't like the cold weather and takes a while to warm up. Once it's hot the bike runs great. I switched to 10W-40 oil from 20W-50 and it warms up faster...

                    Comment


                    • Shores
                      Shores commented
                      Editing a comment
                      I agree with oil viscosity. There's no reason to run 20-50 if you are in a cold climate. Look at the suggested oil viscosity versus temperature in the owner's manual.

                  • #11
                    Thanks for all the input and suggestions. I'll definitely check for intake and exhaust leaks first then go from there. In the mean time I'll have to order or somehow get my hands on an EZ Tach (or something similar) so I can set the rpm.

                    Appreciate the help!!

                    Comment


                    • #12
                      Amazon sells the EZ Tach
                      LET'S RIDE

                      Comment


                      • #13
                        I've had a lot of air cooled bikes, but none as cold natured as the Road Star.

                        Comment


                        • #14
                          Update.......
                          Well, part of the problem was me. Or maybe I was the entire problem!! As it turns out, my senses aren't as calibrated as I thought.

                          ​​​​​​I purchased a Hardline inductive Tach/Hour meter and put it on the bike when I got home from work today. After figuring out what setting it needs to be on I went for a ride and got the motor up to operating temp. What I thought was an appropriate idle rpm turned out to be way too slow. Bike was only turning about 700 rpm s at idle. So now I've got it set to where it's staying at 910-940 rpms.

                          It's supposed to be nice tomorrow so I'll be able to ride to work and see what it does on a cold start.

                          Thanks again for all the input!!

                          Comment


                          • #15
                            the correct idle will definitely help it warm up better faster drive better earlier etc.
                            LET'S RIDE

                            Comment


                            • #16
                              Forgot to mention that before installing the tach, I did check for intake and exhaust leaks and for any sign of sticky valves and everything checked out good.

                              Comment


                              • #17
                                But did you change spark plugs??

                                as advised by several members… you may still be chasing ghosts…. Plug inspection can tell you a lot about current carb setup…

                                Comment


                                • #18
                                  Yes, I pulled them after my last post. They were all in good shape with no signs of fouling. Regapped them then went for about a two hour ride, stopping occasionally to check the rpms at idle. And every time the tach was reading between 860 and 940 rpms. I'll admit, I don't know how accurate the tach is since I don't have anything to check it against, but it is consistent.

                                  Comment


                                  • davej
                                    davej commented
                                    Editing a comment
                                    the tach gets its signal from the coil so accuracy should be OK

                                • #19
                                  And it was super easy to install. Just coiled the lead wire around around the spark plug wire 5-6 times, zip tied it in place and just like that you've got a tach. Can't believe I didn't do this sooner!

                                  Right now I've just got the wire routed up along the main wiring harness and the tach is laying loose in my windshield bag. It's not real convenient to look at while riding, but it definitely serves the purpose. So I might rig up some sort of backing plate and mount it where it's visible all the time

                                  Comment


                                  • #20
                                    Originally posted by ABCarr View Post
                                    Yeah, I've had the bike since 2006 and it's definitely cold-blooded, but not like this. This just started since re-rejetting the carb and installing the Cobra pipes… I will say that the overall performance is better with this set-up, except for the annoying cold running issue.
                                    There’s your issue. You re-jetted, so it runs different. Not necessarily wrong, just different.

                                    You put on a different exhaust and changed the jetting, so it may be a touch leaner or richer. Either way, slightly different than you are used to.

                                    Try running with the enricher about halfway out for a mile or two before pushing it in all the way and see how that works out. I’m running New Freedom True Duals with a similar setup and that’s what I’ve done since re-jetting. It’s a cold blooded beast, but I love it.

                                    Ratl.

                                    Comment

                                    Latest Posts

                                    Collapse

                                    Topics Statistics Last Post
                                    Started by joej85a, 2 days ago
                                    15 responses
                                    159 views
                                    0 likes
                                    Last Post Shores
                                    by Shores
                                     
                                    Started by Father Pobasturd, 05-24-2019, 02:51 PM
                                    1,318 responses
                                    15,642 views
                                    2 likes
                                    Last Post Mr. Miyagi  
                                    Started by Lug Nut, 21 hours ago
                                    14 responses
                                    107 views
                                    1 like
                                    Last Post EasyTargetRN  
                                    Started by DWD6955, 5 days ago
                                    31 responses
                                    204 views
                                    0 likes
                                    Last Post EasyTargetRN  
                                    Started by bigjames, 3 days ago
                                    10 responses
                                    138 views
                                    0 likes
                                    Last Post Lug Nut
                                    by Lug Nut
                                     
                                    Started by joej85a, 2 days ago
                                    12 responses
                                    124 views
                                    0 likes
                                    Last Post Chromepony  
                                    Started by ItBeMe, 1 day ago
                                    0 responses
                                    47 views
                                    0 likes
                                    Last Post ItBeMe
                                    by ItBeMe
                                     
                                    Started by DWD6955, 5 days ago
                                    13 responses
                                    179 views
                                    0 likes
                                    Last Post davej
                                    by davej
                                     
                                    Started by Snotrub, 2 weeks ago
                                    23 responses
                                    208 views
                                    0 likes
                                    Last Post DWD6955
                                    by DWD6955
                                     
                                    Started by Mr. Miyagi, 2 days ago
                                    7 responses
                                    112 views
                                    0 likes
                                    Last Post MikeyC
                                    by MikeyC
                                     
                                    Started by [email protected], 2 days ago
                                    5 responses
                                    54 views
                                    0 likes
                                    Last Post Shores
                                    by Shores
                                     
                                    Started by Jwojtt, 1 day ago
                                    5 responses
                                    80 views
                                    0 likes
                                    Last Post Shores
                                    by Shores
                                     
                                    Started by MikeyC, 07-11-2022, 11:19 PM
                                    25 responses
                                    246 views
                                    0 likes
                                    Last Post MikeyC
                                    by MikeyC
                                     
                                    Started by Lug Nut, 4 days ago
                                    1 response
                                    60 views
                                    0 likes
                                    Last Post D-Fresh
                                    by D-Fresh
                                     
                                    Started by Hairless Hippy, 1 week ago
                                    26 responses
                                    295 views
                                    1 like
                                    Last Post D-Fresh
                                    by D-Fresh
                                     
                                    Started by brianmac, 4 weeks ago
                                    16 responses
                                    330 views
                                    0 likes
                                    Last Post D-Fresh
                                    by D-Fresh
                                     
                                    Started by Roadstar_Rob, 6 days ago
                                    5 responses
                                    128 views
                                    0 likes
                                    Last Post 6door7r
                                    by 6door7r
                                     
                                    Started by Der Steppenwolf, 5 days ago
                                    8 responses
                                    119 views
                                    0 likes
                                    Last Post Mr. Miyagi  
                                    Started by ebaleytherogue, 04-22-2019, 11:08 AM
                                    4 responses
                                    433 views
                                    1 like
                                    Last Post JJansen
                                    by JJansen
                                     
                                    Started by CHEAPOMCGEE97, 3 days ago
                                    15 responses
                                    131 views
                                    0 likes
                                    Last Post Shotround  
                                    Working...
                                    X