Announcement

Collapse
No announcement yet.

Runs at idle bogs out with any throttle

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Runs at idle bogs out with any throttle

    Good evening everyone I’ve had my bike for 6 years it’s 2005. My bike has always been reliable the first week of December was toys for tots. I started my bike in the morning to it’s carbureted. Started and idled just fine. Got my gear on and with the slightest amount of throttle the bike would shut off. I replaced the fuel pump two years ago. I replaced the plugs and no difference. If anyone has anyone suggestions feel free I would greatly appreciate it.

  • #2
    Kickstand down? If not might be you kickstand switch

    Comment


    • #3
      What brand fuel pump did you install? Anything but OEM is crap! How long was it sitting and not being ridden since it ran well? You may have ethanol fuel all gummed up in the fuel system in carburetor. Keep it simple! What has changed since it last ran well?

      Comment


      • #4
        Sounds like Accelerator pump needs Cleaned , New O-ring , or simply Replaced !

        Comment


        • #5
          It wasn’t oem fuel pump. It’s maybe a 3 weeks when I rode if prior to when it stopped running. I took the carb out and cleaned it really well didn’t notice any debris and I had maybe just fill up the tank a week or two before it’s stopped running. I seems if though it maybe be a fuel delivery problem so I might just need to replace the pump

          Comment


          • #6
            Originally posted by SanctionFew View Post
            It wasn’t oem fuel pump. It’s maybe a 3 weeks when I rode if prior to when it stopped running. I took the carb out and cleaned it really well didn’t notice any debris and I had maybe just fill up the tank a week or two before it’s stopped running. I seems if though it maybe be a fuel delivery problem so I might just need to replace the pump
            OEM for EVERY electrical component on these bikes....just too many problems with aftermarket junk Chinese crap....pump, relays, starters, rectifiers, stators ets

            I have a good used pump (and maybe a brand new never used pump) available if interested
            LET'S RIDE

            Comment


            • brianmac
              brianmac commented
              Editing a comment
              lug im not using any OEM starter bruch plates, strictlky Rick's Motorsports 70-507, the quality is great, and its steel instead of brass, which tends to crack, for me, and even new OEM cracked after 1 yr.

          • #7
            If I were you, I would bypass the fuel pump and see if it'll start on gravity feed. Might save yourself money. If it does run, then you can decide if you want to ditch the pump permanently.

            Comment


            • #8
              If your getting fuel to the bowl, then try this trick. Squirt a little carb cleaner in the main and pilot air feed holes then blow compressed air thru them. This usually cleans out the ports enough to run the bike.
              If it's idle fine but bogs when twisting the throttle, then it's more than likely in the main jet port or the exceleratior pump.
              Click image for larger version  Name:	IMG_1394.jpg Views:	0 Size:	126.3 KB ID:	135011

              Comment


              • DEEPHATE
                DEEPHATE commented
                Editing a comment
                I agree with this one...

            • #9
              Ok I’ll try to get some carb cleaner and see if it helps at all thank you guys for the suggestions I appreciate it.

              Comment


              • #10
                check the diaphragm as well maybe a pinhole/tear ? its easy to check the throttle pump, pull of the filter just work the throttle you should see the fuel squirt out of the brass tube straight into the chamber,

                Comment


                • #11
                  I 2nd the accelerator pump/cam. I had the same issue on my '05. I noticed that the accelerator pump cam wasn't moving when I hit the throttle. Any advance on the throttle and it would starve for fuel. I cleaned it well and problem solved.
                  Manuals, Roadwing, other stuff
                  PGR
                  PGT MT

                  Comment


                  • #12
                    I have also had an issue with a tank of fuel once upon a time. I live .2 mile from the station, I filled up on the way home. When I next ran it, the bike didn't die but it ran like crap until I added some stabilizer to the fuel. Might not be the problem, but doesn't hurt to check.

                    Comment


                    • #13
                      Thanks Duke it was just was a clog I appreciate it

                      Comment


                      • #14
                        bet some of you have shit in your tanks, and or bowls. sloshing around., and or rust

                        Comment

                        Latest Posts

                        Collapse

                        Topics Statistics Last Post
                        Started by Aussiestar, 1 day ago
                        12 responses
                        100 views
                        1 like
                        Last Post SbTx_Rider  
                        Started by ElVispo, 1 hour ago
                        0 responses
                        12 views
                        0 likes
                        Last Post ElVispo
                        by ElVispo
                         
                        Started by Aussiestar, 23 hours ago
                        4 responses
                        53 views
                        0 likes
                        Last Post Aussiestar  
                        Started by WobblyBoot, 8 hours ago
                        10 responses
                        41 views
                        0 likes
                        Last Post MidnightRide  
                        Started by Kmartcivic, 2 weeks ago
                        13 responses
                        139 views
                        1 like
                        Last Post WobblyBoot  
                        Started by JHouse, 3 weeks ago
                        6 responses
                        141 views
                        3 likes
                        Last Post WobblyBoot  
                        Started by MidnightRide, 1 day ago
                        27 responses
                        138 views
                        0 likes
                        Last Post Shores
                        by Shores
                         
                        Started by tekdiver609, 02-03-2019, 07:49 PM
                        26 responses
                        3,146 views
                        0 likes
                        Last Post Azuqui
                        by Azuqui
                         
                        Started by WobblyBoot, 16 hours ago
                        2 responses
                        49 views
                        0 likes
                        Last Post roadiemort  
                        Started by Renegade, 2 weeks ago
                        33 responses
                        356 views
                        0 likes
                        Last Post davej
                        by davej
                         
                        Started by Mr. Miyagi, 1 day ago
                        6 responses
                        52 views
                        2 likes
                        Last Post KFallsRider  
                        Started by WobblyBoot, 3 days ago
                        15 responses
                        128 views
                        0 likes
                        Last Post Sharpman66  
                        Started by rsnyder1976, 2 days ago
                        6 responses
                        84 views
                        0 likes
                        Last Post rsnyder1976  
                        Started by Do Something, 4 days ago
                        13 responses
                        122 views
                        0 likes
                        Last Post Lug Nut
                        by Lug Nut
                         
                        Started by Father Pobasturd, 05-24-2019, 02:51 PM
                        1,264 responses
                        15,396 views
                        2 likes
                        Last Post MidnightRide  
                        Started by Leadkrm, 01-10-2019, 06:28 AM
                        13 responses
                        294 views
                        0 likes
                        Last Post Shores
                        by Shores
                         
                        Started by Apsn, 1 week ago
                        41 responses
                        364 views
                        0 likes
                        Last Post Tcontrol  
                        Started by marcus, 2 days ago
                        8 responses
                        99 views
                        0 likes
                        Last Post davej
                        by davej
                         
                        Started by roadiemort, 04-17-2022, 01:19 PM
                        37 responses
                        513 views
                        1 like
                        Last Post roadiemort  
                        Started by scotcher65, 2 days ago
                        6 responses
                        59 views
                        0 likes
                        Last Post Father Pobasturd  
                        Working...
                        X