Announcement

Collapse
No announcement yet.

pumpless float level setting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pumpless float level setting

    Has anyone come up with a proven float level setting for after going pumpless? I just checked mine to see if my low throttle stumble might be caused by a low fuel level in the float bowl.. So far, in pursuit of a cure, I have replaced the entire coasting enrichener assembly,enrichener cable assembly, and thoroughly chemically cleaned the throttle body. the c/e piston was stuck in the throttle body and the e/c cable had some of the rubber cladding pulled back (it seems like the replacement cable is a bit longer than the one i took off, because it is easier to move around to attach to the stock mounting bracket). All parts were replaced upon suggestions found in the forum archives. The accelerator pump assembly looked OK when I removed it, but , for the life of me, I can't figure out how one would 'adjust ' it.. My profile shows the jetting and other mods, but I'm wondering if that Speedstar needle could be causing a problem-most of the long-time members of this forum are using Baron's needles, so, it' just a thought.

  • #2
    what main jet,pilot jet and clip groove are you using with the Speedstar needle? The jetting is different with a Speedstar needle due to the diameter of the needle.

    To adjust the acc pumpther is a tiny screw with a jam nut on it located at the top backside of the black plastic cam that pushed the acc pump plunger. The cam should be touching the plunger rod. with no gap. then there is another screw on the front of that bracket to adjust the duration of the fuel squirt.

    read this link

    https://wayback.archive-it.org/10073...nt/view/63/96/

    Comment


    • #3
      This is my adventure going pumpless recently. JC

      https://www.roadstarclinic.com/forum...-vent-pumpless

      Comment


      • #4
        I didn't change my float setting when I went pumpless. Everything seems to be fine, it's been that way for 6 years now. To be honest , I have not held it wide open at top speed for extended periods to see if it would sustain itself, as I have no need for it to do that. I have run it at 80 mph for 15-20 miles and it never starved for fuel.

        Comment


        • #5
          I eyeballed my float level and went Pumpless with it as it was. No issues running at all (did have to turn in PMS about 1/8 to 1/4 to make it perfect from where it was at (2 3/4 out). Buried speedo several times and ran 90 mph for 30-40 miles at a time no issues.
          LET'S RIDE

          Comment


          • #6
            Originally posted by davej View Post
            what main jet,pilot jet and clip groove are you using with the Speedstar needle? The jetting is different with a Speedstar needle due to the diameter of the needle.

            To adjust the acc pumpther is a tiny screw with a jam nut on it located at the top backside of the black plastic cam that pushed the acc pump plunger. The cam should be touching the plunger rod. with no gap. then there is another screw on the front of that bracket to adjust the duration of the fuel squirt.

            read this link

            https://wayback.archive-it.org/10073...nt/view/63/96/
            I'm running a 175 Main jet and the needle is in the 4th groove from the blunt end. Pilot jet is a 40, PMS @2 1/2 turns.. I have always wondered if the needle would affect settings.

            Comment


            • davej
              davej commented
              Editing a comment
              put the clip in the 5th groove

          • #7
            If you've check and adjusted the carb to the right specifications along with the exceleratior pump, and still getting a slight stumble, then raise the needle up 1 notch.

            Comment


            • davej
              davej commented
              Editing a comment
              He has it in the 4th groove. A Speedstar needle needs to be in the 5th groove

            • Duke
              Duke commented
              Editing a comment
              Sounds good to me also Dave.

          • #8
            I just looked at the Speedstar jetting instructions and it calls for the 5th groove but also calls for a #50 pilot jet with the pms at 3 - 3 1/2 turns out. So I went to some old dyno charts from when I had a stock carb and a Speedstar needle and I used a182.5 main #45 pilot at 3 turns out on the pms on my best dyno. The 182.5 was with V&H 2-1 propipe that requires a little bigger main jet than your exhaust. It dynoed at 75hp and 100 Tq with that jetting and 2-1 exhaust. When I got rid of that exhaust I changed the main to a 180 and left the rest the way it was and the bike ran good.

            Comment


            • #9
              Well, after replacing all the parts, and moving the clip to the 5th notch on the needle, I took the bike out on a commute to work. I don't ever recall it running so well! I really think that the advice on the position of the clip on the needle did the trick! THANKS guys!!!

              Comment


              • #10
                Glad to see it was that easy.

                Comment


                • #11
                  Although I credit the change in the clip on the needle as the solution to my long term problem, the stuck coasting enrichener diaphragm gives me uneasiness. I'm wondering if that is the culprit causing the engine idle to be so high after coming off high speed cruising on the highway. This consensus occurs due to the fact that after these changes, I no longer am experiencing a high idle after such aforementioned excursions.

                  Comment


                  • #12
                    Was it stuck in or out of the enrichener? If it was stuck in, then I'd think it wouldn't have anything to do with your old problem. If it was stuck out, it should have been rich.

                    Comment


                    • Duke
                      Duke commented
                      Editing a comment
                      I was talking about the diaphragm plunger enrichener valve. Is that what you were talking about boomerA?

                  • #13
                    Yeah, the diaphragm and piston and spring under the ceramic cover. It must have been causing the bike to run rich, because, as long as I had the gas tank off, I pulled the plugs and examined them...they looked like I was running rich. Considering the fact that, since the replacement of parts and adjustment of needle, no other changes were made, and the bike runs smoother, I don't have the high rpms after coming off the highway, and I can definitely feel the little click when I push the enrichener cable all the way in after the engine has warmed up.. I ended up using a scattergun approach, because of all the suggestions, and finally got an answer about how having a needle other than a Baron's or Mikuni affected the way it ran. I rode my bike for seven years with the wrong needle setting, including two trips up to OKC and following Route 66 to the Arizona/California border ( I didn't want to enter California,because of their anti-2nd Amendment laws, and the fact that, since I travel alone, I'm packing).

                    Comment

                    Latest Posts

                    Collapse

                    Topics Statistics Last Post
                    Started by Doc_V, 2 weeks ago
                    12 responses
                    175 views
                    4 likes
                    Last Post DEEPHATE  
                    Started by Doc_V, 1 week ago
                    11 responses
                    237 views
                    1 like
                    Last Post Doc_V
                    by Doc_V
                     
                    Started by Father Pobasturd, 05-24-2019, 02:51 PM
                    1,014 responses
                    11,986 views
                    2 likes
                    Last Post Ironman
                    by Ironman
                     
                    Started by joe29, 1 day ago
                    2 responses
                    38 views
                    0 likes
                    Last Post joe29
                    by joe29
                     
                    Started by area1509, 20 hours ago
                    2 responses
                    45 views
                    0 likes
                    Last Post RRS_07RdStar  
                    Started by Road Star Charlie, 1 day ago
                    6 responses
                    72 views
                    0 likes
                    Last Post scotcher65  
                    Started by Mr300game, 20 hours ago
                    10 responses
                    104 views
                    0 likes
                    Last Post scotcher65  
                    Started by McVinny614, 1 week ago
                    12 responses
                    221 views
                    0 likes
                    Last Post Duke
                    by Duke
                     
                    Started by AR. Hillbilly, 02-01-2020, 10:31 AM
                    89 responses
                    1,283 views
                    2 likes
                    Last Post rsokie
                    by rsokie
                     
                    Started by roadiemort, 08-22-2020, 03:09 AM
                    172 responses
                    909 views
                    1 like
                    Last Post roadiemort  
                    Started by Mr300game, 1 week ago
                    12 responses
                    127 views
                    0 likes
                    Last Post MikeyC
                    by MikeyC
                     
                    Started by Cmw2212, 04-26-2018, 07:38 PM
                    27 responses
                    917 views
                    0 likes
                    Last Post Shores
                    by Shores
                     
                    Started by Lifeguard, 2 days ago
                    4 responses
                    145 views
                    1 like
                    Last Post Jclevesque  
                    Started by Blackbeard, 2 days ago
                    6 responses
                    133 views
                    0 likes
                    Last Post Lug Nut
                    by Lug Nut
                     
                    Started by Blackbeard, 1 day ago
                    2 responses
                    53 views
                    0 likes
                    Last Post Blackbeard  
                    Started by estrom, 6 days ago
                    4 responses
                    93 views
                    0 likes
                    Last Post Baxter85  
                    Started by JohnnyBGreen, 3 weeks ago
                    29 responses
                    286 views
                    0 likes
                    Last Post brianmac  
                    Started by LUV4RS, 2 days ago
                    8 responses
                    117 views
                    0 likes
                    Last Post davej
                    by davej
                     
                    Started by Sluggerknuckles, 2 days ago
                    2 responses
                    72 views
                    0 likes
                    Last Post MikeyC
                    by MikeyC
                     
                    Started by jinxpress, 2 days ago
                    4 responses
                    82 views
                    0 likes
                    Last Post Jclevesque  
                    Working...
                    X