Announcement

Collapse
No announcement yet.

pumpless float level setting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pumpless float level setting

    Has anyone come up with a proven float level setting for after going pumpless? I just checked mine to see if my low throttle stumble might be caused by a low fuel level in the float bowl.. So far, in pursuit of a cure, I have replaced the entire coasting enrichener assembly,enrichener cable assembly, and thoroughly chemically cleaned the throttle body. the c/e piston was stuck in the throttle body and the e/c cable had some of the rubber cladding pulled back (it seems like the replacement cable is a bit longer than the one i took off, because it is easier to move around to attach to the stock mounting bracket). All parts were replaced upon suggestions found in the forum archives. The accelerator pump assembly looked OK when I removed it, but , for the life of me, I can't figure out how one would 'adjust ' it.. My profile shows the jetting and other mods, but I'm wondering if that Speedstar needle could be causing a problem-most of the long-time members of this forum are using Baron's needles, so, it' just a thought.

  • #2
    what main jet,pilot jet and clip groove are you using with the Speedstar needle? The jetting is different with a Speedstar needle due to the diameter of the needle.

    To adjust the acc pumpther is a tiny screw with a jam nut on it located at the top backside of the black plastic cam that pushed the acc pump plunger. The cam should be touching the plunger rod. with no gap. then there is another screw on the front of that bracket to adjust the duration of the fuel squirt.

    read this link

    https://wayback.archive-it.org/10073...nt/view/63/96/

    Comment


    • #3
      This is my adventure going pumpless recently. JC

      https://www.roadstarclinic.com/forum...-vent-pumpless

      Comment


      • #4
        I didn't change my float setting when I went pumpless. Everything seems to be fine, it's been that way for 6 years now. To be honest , I have not held it wide open at top speed for extended periods to see if it would sustain itself, as I have no need for it to do that. I have run it at 80 mph for 15-20 miles and it never starved for fuel.

        Comment


        • #5
          I eyeballed my float level and went Pumpless with it as it was. No issues running at all (did have to turn in PMS about 1/8 to 1/4 to make it perfect from where it was at (2 3/4 out). Buried speedo several times and ran 90 mph for 30-40 miles at a time no issues.
          LET'S RIDE

          Comment


          • #6
            Originally posted by davej View Post
            what main jet,pilot jet and clip groove are you using with the Speedstar needle? The jetting is different with a Speedstar needle due to the diameter of the needle.

            To adjust the acc pumpther is a tiny screw with a jam nut on it located at the top backside of the black plastic cam that pushed the acc pump plunger. The cam should be touching the plunger rod. with no gap. then there is another screw on the front of that bracket to adjust the duration of the fuel squirt.

            read this link

            https://wayback.archive-it.org/10073...nt/view/63/96/
            I'm running a 175 Main jet and the needle is in the 4th groove from the blunt end. Pilot jet is a 40, PMS @2 1/2 turns.. I have always wondered if the needle would affect settings.

            Comment


            • davej
              davej commented
              Editing a comment
              put the clip in the 5th groove

          • #7
            If you've check and adjusted the carb to the right specifications along with the exceleratior pump, and still getting a slight stumble, then raise the needle up 1 notch.

            Comment


            • davej
              davej commented
              Editing a comment
              He has it in the 4th groove. A Speedstar needle needs to be in the 5th groove

            • Duke
              Duke commented
              Editing a comment
              Sounds good to me also Dave.

          • #8
            I just looked at the Speedstar jetting instructions and it calls for the 5th groove but also calls for a #50 pilot jet with the pms at 3 - 3 1/2 turns out. So I went to some old dyno charts from when I had a stock carb and a Speedstar needle and I used a182.5 main #45 pilot at 3 turns out on the pms on my best dyno. The 182.5 was with V&H 2-1 propipe that requires a little bigger main jet than your exhaust. It dynoed at 75hp and 100 Tq with that jetting and 2-1 exhaust. When I got rid of that exhaust I changed the main to a 180 and left the rest the way it was and the bike ran good.

            Comment


            • #9
              Well, after replacing all the parts, and moving the clip to the 5th notch on the needle, I took the bike out on a commute to work. I don't ever recall it running so well! I really think that the advice on the position of the clip on the needle did the trick! THANKS guys!!!

              Comment


              • #10
                Glad to see it was that easy.

                Comment


                • #11
                  Although I credit the change in the clip on the needle as the solution to my long term problem, the stuck coasting enrichener diaphragm gives me uneasiness. I'm wondering if that is the culprit causing the engine idle to be so high after coming off high speed cruising on the highway. This consensus occurs due to the fact that after these changes, I no longer am experiencing a high idle after such aforementioned excursions.

                  Comment


                  • #12
                    Was it stuck in or out of the enrichener? If it was stuck in, then I'd think it wouldn't have anything to do with your old problem. If it was stuck out, it should have been rich.

                    Comment


                    • Duke
                      Duke commented
                      Editing a comment
                      I was talking about the diaphragm plunger enrichener valve. Is that what you were talking about boomerA?

                  • #13
                    Yeah, the diaphragm and piston and spring under the ceramic cover. It must have been causing the bike to run rich, because, as long as I had the gas tank off, I pulled the plugs and examined them...they looked like I was running rich. Considering the fact that, since the replacement of parts and adjustment of needle, no other changes were made, and the bike runs smoother, I don't have the high rpms after coming off the highway, and I can definitely feel the little click when I push the enrichener cable all the way in after the engine has warmed up.. I ended up using a scattergun approach, because of all the suggestions, and finally got an answer about how having a needle other than a Baron's or Mikuni affected the way it ran. I rode my bike for seven years with the wrong needle setting, including two trips up to OKC and following Route 66 to the Arizona/California border ( I didn't want to enter California,because of their anti-2nd Amendment laws, and the fact that, since I travel alone, I'm packing).

                    Comment

                    Latest Posts

                    Collapse

                    Topics Statistics Last Post
                    Started by Lifeguard, 17 hours ago
                    7 responses
                    72 views
                    0 likes
                    Last Post DEEPHATE  
                    Started by Jaybo, 02-08-2020, 05:54 PM
                    324 responses
                    3,865 views
                    3 likes
                    Last Post Duke
                    by Duke
                     
                    Started by scotcher65, 4 hours ago
                    2 responses
                    30 views
                    0 likes
                    Last Post scotcher65  
                    Started by Tykes_Place, 3 days ago
                    51 responses
                    521 views
                    2 likes
                    Last Post Flashback  
                    Started by Father Pobasturd, 05-24-2019, 02:51 PM
                    998 responses
                    11,637 views
                    2 likes
                    Last Post Jaybo
                    by Jaybo
                     
                    Started by IBDirty, 1 day ago
                    7 responses
                    94 views
                    0 likes
                    Last Post Duke
                    by Duke
                     
                    Started by Shores, 1 week ago
                    6 responses
                    165 views
                    0 likes
                    Last Post Duke
                    by Duke
                     
                    Started by Jon D, 2 days ago
                    9 responses
                    102 views
                    0 likes
                    Last Post Lifeguard  
                    Started by Aussie John, 1 day ago
                    3 responses
                    105 views
                    1 like
                    Last Post Chromepony  
                    Started by Jon D, 21 hours ago
                    5 responses
                    77 views
                    0 likes
                    Last Post Chooch
                    by Chooch
                     
                    Started by dna9656, 1 week ago
                    17 responses
                    135 views
                    0 likes
                    Last Post LUV4RS
                    by LUV4RS
                     
                    Started by DEEPHATE, 2 weeks ago
                    19 responses
                    211 views
                    0 likes
                    Last Post Jaybo
                    by Jaybo
                     
                    Started by hardone2get, 2 days ago
                    4 responses
                    113 views
                    0 likes
                    Last Post Smokescreens  
                    Started by viper, 3 days ago
                    7 responses
                    128 views
                    0 likes
                    Last Post viper
                    by viper
                     
                    Started by scotcher65, 2 days ago
                    5 responses
                    128 views
                    0 likes
                    Last Post Shores
                    by Shores
                     
                    Started by Jon D, 2 days ago
                    6 responses
                    84 views
                    0 likes
                    Last Post DEEPHATE  
                    Started by Squirts, 3 days ago
                    13 responses
                    119 views
                    0 likes
                    Last Post Chromepony  
                    Started by Blackcloud12, 2 weeks ago
                    10 responses
                    155 views
                    2 likes
                    Last Post Lug Nut
                    by Lug Nut
                     
                    Started by Andrew, 02-25-2018, 09:53 AM
                    22 responses
                    4,058 views
                    0 likes
                    Last Post Lug Nut
                    by Lug Nut
                     
                    Started by a_gunslinger, 2 weeks ago
                    34 responses
                    554 views
                    0 likes
                    Last Post texasscott1  
                    Working...
                    X