Announcement

Collapse
No announcement yet.

Headlight fuse blew. Twice.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Headlight fuse blew. Twice.

    Riding up to my folks today- nice cruise. About 40 minutes. I discovered in the last 5 miles or so that my signal indicator was inop. So was the high beam indicator. This is 2012 a Silverado.
    So I get to my folks and look around- no lights are working.
    I replaced the light fuse and started it back up. No issues. Toggled high beam and driving lights. No issues.
    When we left- the first time I hit the turn signal switch- lost lights again.
    Bike is up at my folks. Couldn’t ride it home in the dark.
    I’m thinking a turn signal bulb may have failed in such a way as to blow the fuse.
    I’ll pick up a few fuses and new bulbs and try it out this week.


  • #2
    Have you had this bike awhile? If you just got it, this might be why it was sold.

    Comment


    • #3
      Got a hot wire rubbed bare, somewhere.

      Comment


      • #4
        How long have you had the bike. Have you been dicking with anything or had anything apart or added anything. If so back track your steps. You most likely have a bear wire touching ground. Good luck with it.

        Comment


        • #5
          Check your neck especially at the steering bump stops to make sure there are no wires that got pinched and broke thru wiring sheathing. I recently discovered this on my bike and did the repair. Noticed fast flashing on one side but not a fuse blowing.

          Comment


          • #6
            I'll try to cover everything in one post.....I have not had this RS long- about a month. It has not given me a single issue up to this point. The only thing I have done is take the windshield off for the time being; and added the lead for a battery tender.
            I will double check the wires after eliminating the simple- the lamps. Since at least one of them is a dual filament I'm still hopeful that a filament broke and is laying across both "terminals" of the lamp and shorts when the signal switch is activated.
            After than I will start looking at wiring- starting at the headlight bucket and where ever else the harness for the left side switch cluster feeds through.
            Thanks guys!!

            Comment


            • #7
              Did you install your battery tender lead with the correct polarity?

              Comment


              • Blackcloud12
                Blackcloud12 commented
                Editing a comment
                Pretty sure it's correct. The battery tender hasn't thrown an alarm.
                Though I'm not seeing how that would cause an issue when the battery tender isn't connected? Correct or reversed polarity should only be an issue once the voltage (from the tender connection) is applied?

            • #8
              Originally posted by Blackcloud12 View Post
              Pretty sure it's correct. The battery tender hasn't thrown an alarm.
              Though I'm not seeing how that would cause an issue when the battery tender isn't connected? Correct or reversed polarity should only be an issue once the voltage (from the tender connection) is applied?
              One of the terminals on the end of the tender pig tail is bare metal. If it is connected to the battery wrong, the bare terminal could touch the frame, etc. and cause a short.

              Comment


              • #9
                Originally posted by Shores View Post

                One of the terminals on the end of the tender pig tail is bare metal. If it is connected to the battery wrong, the bare terminal could touch the frame, etc. and cause a short.

                Oh- yeah- that makes sense.

                Comment


                • #10
                  If you have an oem light bar check to see if the wires on the switch on the side of the light bar bucket have broken and shorting out inside the bucket.

                  Comment


                  • #11
                    I have no update yet. Been too busy after work to trek up to my folks and monkey with it. I'm still hopeful that it's something dumb. Everything seems to function as normal when I replace the fuse. But once the turn signal switch is hit- that's when the fuse blows.
                    May not get to play with it til this weekend. I'll keep ya posted.

                    Definitely a bit frustrating/embarrassing. The first time I ride it up to my folks it stays there. The reason (well, one of them) I didn't buy a Harley was reliability!!! And here we are.......

                    Comment


                    • fastjohnny
                      fastjohnny commented
                      Editing a comment
                      OMG! If it WAS a HD there's no doubt in my mind that you wouldn't be able to find the issue without taking it to the stealer which would end up costing you $736.92 (pulled that number out of my ass but you get the point).
                      Hang in there. I'm sure it's gonna be a simple fix, and won't cost much - if anything. These bikes are pretty bullet proof. Mine is a 2005 I bought in 2006 with 1100 miles on the clock.....PO didn't have time for her. I now have > 82,000 miles with very few issues.

                  • #12
                    Don't get discouraged, they are awesome bikes, sounds like a bare wire touching ground. Does it happen on Left turn or right turn or both? One spot to look is at the outboard end of the light bar, where the wires turn down into the signal housing, especially if the bike has ever tipped over, but it could be in the back end of the bike. Have there been any modifications to the bike? After market taillight?

                    Edit: I see reading back you said left turn, left side passing light bucket has several connections that like to do that, get your soldering gun out and it takes about 2 minutes to fix it all up.
                    Life is tough, it's even tougher if your stupid----John Wayne

                    Comment


                    • #13
                      I’ve got a solution........just use hand signals!

                      Comment


                      • #14
                        check for a pinched or bare wire where the turn signal wires come out of the passing light bar and into the turn signal housing. It is a pinch/rub area for the wires.

                        Comment


                        • #15
                          Ready for this one?? Spent some time yesterday looking at the RS- I had new lamps and a package of 15A fuses to play with. Took the lenses off the right side signals. Lamps were good. Tested the switch again just for kicks. No issues. Put everything back together slowly and was able to isolate it to the right front. Blew another fuse. Took the RF signal apart again and tested. No issues. Put the lamp holding bracket back on loosely and tested- no issues. Tightened it back down and tested- odd slow bling across both fronts then blew fuse. Took the signal off to make sure the signal wires and driving light wires were all ok. No issues there.

                          Long story short- the little screw on the right (outside) of the little band/bracket that holds the lamp was the culprit. Not exactly sure what it was grounding on- perhaps it was too long. I did not compare it to the screws on the rear signal. I wrapped the lamp holder bracket in electrical tape and reinstalled. No issues. Rode around a bit to test. No issues.

                          Very weird. And I had one fuse to spare! After restoring my spare 15A in the fuse block. LOL

                          Glad it is functional- when it's back home I'll probably play with it a little more to try to find to root of the problem but for now all is happy. Thank you all for the suggestions; I'm glad it wasn't anything more serious.

                          Comment


                          • #16
                            That little screw has caused it's share of problems. But that's how a lot of the problems go, some little errant screw.
                            Life is tough, it's even tougher if your stupid----John Wayne

                            Comment

                            Latest Posts

                            Collapse

                            Topics Statistics Last Post
                            Started by Lifeguard, 1 day ago
                            10 responses
                            175 views
                            0 likes
                            Last Post Shores
                            by Shores
                             
                            Started by JonBru, 15 hours ago
                            8 responses
                            78 views
                            0 likes
                            Last Post davej
                            by davej
                             
                            Started by Tykes_Place, 06-06-2018, 12:40 AM
                            26 responses
                            395 views
                            4 likes
                            Last Post Starboi7  
                            Started by Brad_G, 12 hours ago
                            0 responses
                            25 views
                            0 likes
                            Last Post Brad_G
                            by Brad_G
                             
                            Started by Ed_XV1600, 1 week ago
                            19 responses
                            198 views
                            0 likes
                            Last Post Starboi7  
                            Started by Starboi7, 5 days ago
                            35 responses
                            404 views
                            0 likes
                            Last Post Starboi7  
                            Started by roadiemort, 4 days ago
                            6 responses
                            120 views
                            0 likes
                            Last Post Brad_G
                            by Brad_G
                             
                            Started by Engineman, 1 day ago
                            2 responses
                            93 views
                            1 like
                            Last Post BigPainRing  
                            Started by Smalls, 1 day ago
                            16 responses
                            140 views
                            0 likes
                            Last Post davej
                            by davej
                             
                            Started by Leiurus, 08-22-2019, 11:21 AM
                            17 responses
                            341 views
                            1 like
                            Last Post GreasySam  
                            Started by Father Pobasturd, 05-24-2019, 02:51 PM
                            791 responses
                            9,216 views
                            1 like
                            Last Post Herrindude  
                            Started by J89k, 1 day ago
                            15 responses
                            211 views
                            0 likes
                            Last Post RonK
                            by RonK
                             
                            Started by midnitmike, 3 days ago
                            10 responses
                            152 views
                            0 likes
                            Last Post Shores
                            by Shores
                             
                            Started by Kenkaman, 07-21-2019, 05:11 PM
                            20 responses
                            252 views
                            0 likes
                            Last Post Flashback  
                            Started by 6feet, 4 days ago
                            6 responses
                            192 views
                            0 likes
                            Last Post 6feet
                            by 6feet
                             
                            Started by Mikegoat2497, 2 weeks ago
                            12 responses
                            311 views
                            0 likes
                            Last Post Mikegoat2497  
                            Started by Father Pobasturd, 4 days ago
                            8 responses
                            193 views
                            2 likes
                            Last Post Lug Nut
                            by Lug Nut
                             
                            Started by RickC, 09-09-2019, 10:38 AM
                            14 responses
                            226 views
                            0 likes
                            Last Post Lug Nut
                            by Lug Nut
                             
                            Started by brianmac, 3 days ago
                            10 responses
                            121 views
                            0 likes
                            Last Post brianmac  
                            Working...
                            X