Announcement

Collapse
No announcement yet.

Headlight fuse blew. Twice.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Headlight fuse blew. Twice.

    Riding up to my folks today- nice cruise. About 40 minutes. I discovered in the last 5 miles or so that my signal indicator was inop. So was the high beam indicator. This is 2012 a Silverado.
    So I get to my folks and look around- no lights are working.
    I replaced the light fuse and started it back up. No issues. Toggled high beam and driving lights. No issues.
    When we left- the first time I hit the turn signal switch- lost lights again.
    Bike is up at my folks. Couldn’t ride it home in the dark.
    I’m thinking a turn signal bulb may have failed in such a way as to blow the fuse.
    I’ll pick up a few fuses and new bulbs and try it out this week.


  • #2
    Have you had this bike awhile? If you just got it, this might be why it was sold.

    Comment


    • #3
      Got a hot wire rubbed bare, somewhere.

      Comment


      • #4
        How long have you had the bike. Have you been dicking with anything or had anything apart or added anything. If so back track your steps. You most likely have a bear wire touching ground. Good luck with it.

        Comment


        • #5
          Check your neck especially at the steering bump stops to make sure there are no wires that got pinched and broke thru wiring sheathing. I recently discovered this on my bike and did the repair. Noticed fast flashing on one side but not a fuse blowing.

          Comment


          • #6
            I'll try to cover everything in one post.....I have not had this RS long- about a month. It has not given me a single issue up to this point. The only thing I have done is take the windshield off for the time being; and added the lead for a battery tender.
            I will double check the wires after eliminating the simple- the lamps. Since at least one of them is a dual filament I'm still hopeful that a filament broke and is laying across both "terminals" of the lamp and shorts when the signal switch is activated.
            After than I will start looking at wiring- starting at the headlight bucket and where ever else the harness for the left side switch cluster feeds through.
            Thanks guys!!

            Comment


            • #7
              Did you install your battery tender lead with the correct polarity?

              Comment


              • Blackcloud12
                Blackcloud12 commented
                Editing a comment
                Pretty sure it's correct. The battery tender hasn't thrown an alarm.
                Though I'm not seeing how that would cause an issue when the battery tender isn't connected? Correct or reversed polarity should only be an issue once the voltage (from the tender connection) is applied?

            • #8
              Originally posted by Blackcloud12 View Post
              Pretty sure it's correct. The battery tender hasn't thrown an alarm.
              Though I'm not seeing how that would cause an issue when the battery tender isn't connected? Correct or reversed polarity should only be an issue once the voltage (from the tender connection) is applied?
              One of the terminals on the end of the tender pig tail is bare metal. If it is connected to the battery wrong, the bare terminal could touch the frame, etc. and cause a short.

              Comment


              • #9
                Originally posted by Shores View Post

                One of the terminals on the end of the tender pig tail is bare metal. If it is connected to the battery wrong, the bare terminal could touch the frame, etc. and cause a short.

                Oh- yeah- that makes sense.

                Comment


                • #10
                  If you have an oem light bar check to see if the wires on the switch on the side of the light bar bucket have broken and shorting out inside the bucket.

                  Comment


                  • #11
                    I have no update yet. Been too busy after work to trek up to my folks and monkey with it. I'm still hopeful that it's something dumb. Everything seems to function as normal when I replace the fuse. But once the turn signal switch is hit- that's when the fuse blows.
                    May not get to play with it til this weekend. I'll keep ya posted.

                    Definitely a bit frustrating/embarrassing. The first time I ride it up to my folks it stays there. The reason (well, one of them) I didn't buy a Harley was reliability!!! And here we are.......

                    Comment


                    • fastjohnny
                      fastjohnny commented
                      Editing a comment
                      OMG! If it WAS a HD there's no doubt in my mind that you wouldn't be able to find the issue without taking it to the stealer which would end up costing you $736.92 (pulled that number out of my ass but you get the point).
                      Hang in there. I'm sure it's gonna be a simple fix, and won't cost much - if anything. These bikes are pretty bullet proof. Mine is a 2005 I bought in 2006 with 1100 miles on the clock.....PO didn't have time for her. I now have > 82,000 miles with very few issues.

                  • #12
                    Don't get discouraged, they are awesome bikes, sounds like a bare wire touching ground. Does it happen on Left turn or right turn or both? One spot to look is at the outboard end of the light bar, where the wires turn down into the signal housing, especially if the bike has ever tipped over, but it could be in the back end of the bike. Have there been any modifications to the bike? After market taillight?

                    Edit: I see reading back you said left turn, left side passing light bucket has several connections that like to do that, get your soldering gun out and it takes about 2 minutes to fix it all up.
                    Life is short, eat dessert first----Unknown

                    Comment


                    • #13
                      I’ve got a solution........just use hand signals!

                      Comment


                      • #14
                        check for a pinched or bare wire where the turn signal wires come out of the passing light bar and into the turn signal housing. It is a pinch/rub area for the wires.

                        Comment


                        • #15
                          Ready for this one?? Spent some time yesterday looking at the RS- I had new lamps and a package of 15A fuses to play with. Took the lenses off the right side signals. Lamps were good. Tested the switch again just for kicks. No issues. Put everything back together slowly and was able to isolate it to the right front. Blew another fuse. Took the RF signal apart again and tested. No issues. Put the lamp holding bracket back on loosely and tested- no issues. Tightened it back down and tested- odd slow bling across both fronts then blew fuse. Took the signal off to make sure the signal wires and driving light wires were all ok. No issues there.

                          Long story short- the little screw on the right (outside) of the little band/bracket that holds the lamp was the culprit. Not exactly sure what it was grounding on- perhaps it was too long. I did not compare it to the screws on the rear signal. I wrapped the lamp holder bracket in electrical tape and reinstalled. No issues. Rode around a bit to test. No issues.

                          Very weird. And I had one fuse to spare! After restoring my spare 15A in the fuse block. LOL

                          Glad it is functional- when it's back home I'll probably play with it a little more to try to find to root of the problem but for now all is happy. Thank you all for the suggestions; I'm glad it wasn't anything more serious.

                          Comment


                          • #16
                            That little screw has caused it's share of problems. But that's how a lot of the problems go, some little errant screw.
                            Life is short, eat dessert first----Unknown

                            Comment

                            Latest Posts

                            Collapse

                            Topics Statistics Last Post
                            Started by Agpilot, 3 hours ago
                            3 responses
                            28 views
                            0 likes
                            Last Post Father Pobasturd  
                            Started by petr.hw, 7 hours ago
                            5 responses
                            22 views
                            0 likes
                            Last Post Father Pobasturd  
                            Started by TEXenvy, 5 hours ago
                            6 responses
                            57 views
                            0 likes
                            Last Post Father Pobasturd  
                            Started by Pauli466, 1 day ago
                            13 responses
                            152 views
                            0 likes
                            Last Post Pauli466  
                            Started by Father Pobasturd, 01-12-2020, 11:43 PM
                            1,408 responses
                            2,330 views
                            0 likes
                            Last Post Father Pobasturd  
                            Started by Koal0313, 08-27-2018, 12:54 AM
                            17 responses
                            270 views
                            0 likes
                            Last Post MikeyC
                            by MikeyC
                             
                            Started by Jaybo, 02-08-2020, 05:54 PM
                            57 responses
                            714 views
                            2 likes
                            Last Post MikeyC
                            by MikeyC
                             
                            Started by Duke, 1 week ago
                            7 responses
                            167 views
                            2 likes
                            Last Post TEXenvy
                            by TEXenvy
                             
                            Started by coreys1982, 4 days ago
                            7 responses
                            119 views
                            0 likes
                            Last Post brianmac  
                            Started by toms03se, 18 hours ago
                            3 responses
                            42 views
                            0 likes
                            Last Post Lug Nut
                            by Lug Nut
                             
                            Started by JD64k, 03-27-2018, 06:39 PM
                            166 responses
                            6,199 views
                            3 likes
                            Last Post Father Pobasturd  
                            Started by Ret HPD, 11-23-2019, 02:49 PM
                            24 responses
                            435 views
                            0 likes
                            Last Post erizo
                            by erizo
                             
                            Started by Knutselsmurf, 2 days ago
                            19 responses
                            164 views
                            0 likes
                            Last Post Knutselsmurf  
                            Started by RoadieRob, 1 day ago
                            5 responses
                            80 views
                            0 likes
                            Last Post RoadieRob  
                            Started by ctkog, 1 day ago
                            2 responses
                            49 views
                            0 likes
                            Last Post Questcap  
                            Started by Sguitard, 5 days ago
                            4 responses
                            118 views
                            0 likes
                            Last Post Smokescreens  
                            Started by Aussie John, 1 week ago
                            7 responses
                            198 views
                            0 likes
                            Last Post Shores
                            by Shores
                             
                            Started by Pauli466, 3 days ago
                            27 responses
                            276 views
                            0 likes
                            Last Post Duke
                            by Duke
                             
                            Started by 2time, 2 days ago
                            7 responses
                            115 views
                            0 likes
                            Last Post 2time
                            by 2time
                             
                            Started by Lifeguard, 3 days ago
                            7 responses
                            205 views
                            0 likes
                            Last Post Lifeguard  
                            Working...
                            X