Announcement

Collapse
No announcement yet.

No turn signals, no power to gauge cluster in neutral.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No turn signals, no power to gauge cluster in neutral.

    Hey everyone, you guys seem like studs and I’m sure this has been covered but I’m kind of stranded right now so I just decided to go ahead and post for the sake of urgency. I’ve got a 2000 Road Star 1600 and I’m having some serious electrical drama. Basically, none of the gauges or odometer function when the bike is in neutral. Additionally, when I activate the turn signals while riding it kills all power to the gauge cluster and the turn signals do not function at all. And finally, the neutral light does not illuminate at all. This is my only means of tranpo so I really appreciate your input. I just bought this bike and it’s been giving me ample trouble since the moment I started it.

  • #2
    sounds to me like someone has hacked up the wiring..look for loose or taped up wires.
    not all those who wander are lost......

    Comment

    Latest Posts

    Collapse

    Topics Statistics Last Post
    Started by Smokescreens, 03-05-2018, 10:34 AM
    273 responses
    5,813 views
    14 likes
    Last Post Shores
    by Shores
     
    Started by Lug Nut, 1 hour ago
    4 responses
    33 views
    0 likes
    Last Post Lug Nut
    by Lug Nut
     
    Started by mariner3302, 16 hours ago
    4 responses
    54 views
    0 likes
    Last Post Lug Nut
    by Lug Nut
     
    Started by Doc_V, 20 hours ago
    12 responses
    156 views
    0 likes
    Last Post Bikerron  
    Started by McVinny614, 1 week ago
    7 responses
    148 views
    0 likes
    Last Post mlharper  
    Started by Smokescreens, 06-17-2020, 09:49 AM
    13 responses
    215 views
    2 likes
    Last Post MrG
    by MrG
     
    Started by MrG, 13 hours ago
    1 response
    33 views
    0 likes
    Last Post Shores
    by Shores
     
    Started by Flyinfish, 6 days ago
    23 responses
    134 views
    0 likes
    Last Post 2time
    by 2time
     
    Started by gonzarelloz, 1 day ago
    11 responses
    51 views
    1 like
    Last Post 2time
    by 2time
     
    Started by Shores, 1 week ago
    33 responses
    319 views
    1 like
    Last Post JimH
    by JimH
     
    Started by JoeX, 5 days ago
    18 responses
    149 views
    2 likes
    Last Post JimH
    by JimH
     
    Started by Galcanised, 1 week ago
    17 responses
    168 views
    5 likes
    Last Post EP Roadie  
    Started by MrG, 3 weeks ago
    12 responses
    176 views
    0 likes
    Last Post LUV4RS
    by LUV4RS
     
    Started by Lug Nut, 2 days ago
    17 responses
    250 views
    1 like
    Last Post Littlebull  
    Started by chromax, 5 days ago
    11 responses
    231 views
    2 likes
    Last Post Sharpman66  
    Started by MikeyC, 2 days ago
    8 responses
    101 views
    0 likes
    Last Post Sharpman66  
    Started by Lug Nut, 3 days ago
    2 responses
    135 views
    3 likes
    Last Post Sharpman66  
    Started by MikeyC, 2 days ago
    12 responses
    121 views
    0 likes
    Last Post Sharpman66  
    Started by Lug Nut, 2 days ago
    4 responses
    88 views
    2 likes
    Last Post Sharpman66  
    Started by GreenMachine, 08-13-2020, 12:19 PM
    242 responses
    2,489 views
    3 likes
    Last Post GreenMachine  
    Working...
    X