Announcement

Collapse
No announcement yet.

Speedometer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Speedometer

    so now that the roadstar is running I went for the first test ride, the speedometer makes a full sweep when you turn the key on, but doesn't move while riding, gas gauge works fine, checked and cleaned the connections tried again still won't move. My service manual states there is no test for the speed sensor. I did a search and read a lot of replies about cleaning and lubing inside the speedometer before I do that, does it make any difference that it makes a full sweep when I turn the key on?
    thanks,
    Rob

  • #2
    Currently dealing with the same issues on my 2000 r*. The Tech at the dealer says the initial sweep is the speedo getting power but if it doesnt move while riding it could by a bad connection or failing Speed Sensor. Ordered one, Let you know if it works when it gets in and I get it on the bike

    Cheers

    Comment


    • #3
      Thank you

      Comment


      • #4
        I had to do both a speed sensor and speedometer on my "new" 2000. I didn't get a sweep....so I swapped my good speedo from my white bike and it swept. BUT when riding speedo still didn't work. So, got a good used speedo. I then installed new speedo sensor (haven't ridden since so honestly don't know if it's fixed but really nothing else it could be).

        speedo is a bitch to get back in (not too bad to remove) I can help walk you through it if you get hung up.
        LET'S RIDE

        Comment


        • Rob in FL
          Rob in FL commented
          Editing a comment
          Thank you ! Is the sensor on the right side behind the two chrome oil lines?

        • manser64
          manser64 commented
          Editing a comment
          Any tricks to get the sensor out and the new one in? The location of this must have been thought out by an engineer who already got fired??

      • #5
        Rob, are you running the factory turn signal box? I believe that you have to run that box for making the speedometer work, not 100% sure. The box works with the speed sensor and the cdi box for the self canceling turn signals. There should be a way to by pass that unit, but it's beyond me.

        Comment


        • Rob in FL
          Rob in FL commented
          Editing a comment
          Thanks Duke, I have led rear turn signals, the front turn signals are small lights, all the other fuses and wiring are factory parts

      • #6
        I had a similar problem. I simply washed my needle and bars with rubbing alcohol. They were kind of gummy. It did the trick. Be careful though. Rubbing alcohol will mess with the paint on the speedo.

        Comment


        • Rob in FL
          Rob in FL commented
          Editing a comment
          Thank you, I will try that today

        • Brian Schenk
          Brian Schenk commented
          Editing a comment
          My speedo will work and then not work sometimes. Could you explain needle and bars. Clock and trip seem to stay working but won't rack up miles. I wasn't going to worry about it on this old bike I don't really need it. But if it is a fairly easy fix will do it. just noticed if I give it a Fonzie it will work.

        • Spydr
          Spydr commented
          Editing a comment
          Brian Schenk; "if I give it a Fonzei it will work."
          I have to do that to mine from time to time also.
          NOBODY has really figured out why, nor how to Really fix it.
          As far as your Trip/Odometer... I haven't heard of that problem yet.

      • #7
        Try lubing the speedo and gas gauge needle pivots with sewing machine or fishing reel oil. It may take several treatments.

        Comment


        • #8
          How did it work Rob?

          @Brian_Schenk by needle i mean the actual Speedo needle. By bars I'm referring to the posts the speedo rests on when the bike is off. Mine were gunky.

          I have no tips on the odemeter, haven't had that issue.

          Comment


          • Rob in FL
            Rob in FL commented
            Editing a comment
            Unfortunately no luck on cleaning them. I'm going to order the speed sensor and hopefully it works the sensor is 90 dollars

          • Rob in FL
            Rob in FL commented
            Editing a comment
            I'm going to try the lube again. I asked my wife do you have oil for your sewing machine? Why? I need some. Why? So I had to explain the whole process to her

        • #9
          Mine does the same thing, no sweep, but when I Fonzie it.....it seem to help, until I see top and turn the bike off.

          Comment


          • #10
            My speedometer and fuel gauge both quit working years ago. For awhile, the speedo would respond to a sharp rap with the knuckles on the glass, but now that quit working. The odometer still works as do the idiot lights and the gauge lights. Fortunately for me, I don't really give a shit if the speedo works, I rode choppers for years with no guages. As for the fuel guage, I could care even less if it works. The little low fuel idiot light still works. It came on this morning when I was riding. I realize a lot of guys are anal retentive and have to have every little do-dad working, but that ain't me.

            Comment


            • #11
              Just replace speedo sensor.... $90....hard to do the first time I can walk you through it or Doc V.. He helped me on mine
              LET'S RIDE

              Comment


              • #12
                So can I remove it without removing my exhaust??? Because my bolts are froze in there pretty tight and trying to strip.

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by Fishbone333, 08-11-2021, 06:29 PM
                14 responses
                132 views
                0 likes
                Last Post YZ18
                by YZ18
                 
                Started by TheDaveySprocket, 08-11-2021, 07:22 AM
                13 responses
                286 views
                2 likes
                Last Post TheDaveySprocket  
                Started by Boots, 1 day ago
                12 responses
                86 views
                0 likes
                Last Post davej
                by davej
                 
                Started by Ron0303, 20 hours ago
                2 responses
                61 views
                0 likes
                Last Post mlrz24
                by mlrz24
                 
                Started by MikeyC, 2 weeks ago
                18 responses
                188 views
                0 likes
                Last Post Shores
                by Shores
                 
                Started by Ron0303, 20 hours ago
                5 responses
                54 views
                0 likes
                Last Post Shores
                by Shores
                 
                Started by Andynz, 8 hours ago
                6 responses
                53 views
                0 likes
                Last Post Shores
                by Shores
                 
                Started by Yamatech, 2 weeks ago
                19 responses
                128 views
                0 likes
                Last Post TheDaveySprocket  
                Started by CanadaboyA, 2 weeks ago
                36 responses
                288 views
                0 likes
                Last Post CanadaboyA  
                Started by AR. Hillbilly, 03-13-2021, 07:23 AM
                82 responses
                1,343 views
                1 like
                Last Post AR. Hillbilly  
                Started by ZenSPIKE, 10-18-2018, 03:11 PM
                25 responses
                635 views
                0 likes
                Last Post Boots
                by Boots
                 
                RAP by zopy
                Started by zopy, 19 hours ago
                3 responses
                48 views
                0 likes
                Last Post Brad_G
                by Brad_G
                 
                Started by rsokie, 1 day ago
                5 responses
                56 views
                0 likes
                Last Post rsokie
                by rsokie
                 
                Started by scotcher65, 2 weeks ago
                54 responses
                603 views
                1 like
                Last Post egelasi
                by egelasi
                 
                Started by roadiemort, 1 day ago
                3 responses
                46 views
                0 likes
                Last Post Father Pobasturd  
                Started by schzx14, 1 day ago
                5 responses
                43 views
                0 likes
                Last Post davej
                by davej
                 
                Started by Father Pobasturd, 1 day ago
                15 responses
                119 views
                0 likes
                Last Post Tykes_Place  
                Started by BloodMoney, 07-27-2021, 09:18 PM
                12 responses
                237 views
                0 likes
                Last Post BloodMoney  
                Started by Kmartcivic, 07-24-2021, 10:25 AM
                6 responses
                107 views
                0 likes
                Last Post Kmartcivic  
                Started by CanadaboyA, 1 week ago
                10 responses
                141 views
                0 likes
                Last Post CanadaboyA  
                Working...
                X