Announcement

Collapse
No announcement yet.

Not charging

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Not charging

    My battery seems to go dead periodically so I posted on here asking for advice. Everyone suggested I take the battery in and get it tested. It was dead this morning so I took it in and they said it was good. They said it had 675 cca (the battery tag says it's 310 cca). My next question is what to check next. I have a trip to the U.P. planned in couple weeks and this has me nervous. I put a tester on with it idling and it was at 12.8 volts and not much difference if any when it was revved up. I don't know if this matters but this is the same bike I wrecked last summer. It went down on It's right side but the engine guard stopped any damage to the engine

  • #2
    The ‘04, and earlier, Road Stars had a weak charging system. I see you’re sporting 1700+ posts on RSC, but at a loss as what to do.

    I’m surprised.

    Time to put that volt meter through its paces.

    Here’s a couple links to get get you started.

    https://wayback.archive-it.org/10073...t/view/18/103/

    https://wayback.archive-it.org/10073.../view/189/103/



    Comment


    • #3
      Thanks. I looked at those earlier but I was hoping someone came up with a different way by now. Those voltmeters are like a foreign language to me but I guess now is as good of time as any to learn. Thanks again.

      Comment


      • #4
        Volt meters are about the only way that I know of to ‘see’ electricity.





        Comment


        • #5
          Clean the stator wire connector (3 white wires)

          Comment


          • #6
            Guessing is expensive. I’d suggest a friend or a YouTube video.


            Wherever you go in life, ride there if at all possible.

            Comment


            • #7
              I'm at the part where it says to check ohms at the plug with 3 white wires. They all get 1.1 on the multimeter. I looked up how to use one and set it and it said when I touch the leads together it should read 0 but it reads .9. I used another one and the same thing so I was wondering if these multimeters are not accurate or there is a bad wire or stator like the article says.

              Comment


              • #8
                Yea, don’t expect ohm reading accuracy with one of those Harbor Freight specials. You can, however set it to AC voltage and read each two of the three wires for AC (the stator produces alternating current) output from the stator if you can start the bike. Careful, you will see voltage in the 50v+ range so kill the engine before swapping the probes and it won’t hurt the electrical system during the test.

                As long as each pair of any three terminals are all close to their output the stator should be good.

                careful about jamming those probes into the plug terminals so as not to spread them or the spades on the other side of the plug will have bad connections when plugged back together.



                Comment


                • #9
                  It was mid 30's at idle and with a little throttle mid to upper 50's. Both meters are from Napa so no idea how accurate.

                  Comment


                  • #10
                    If you were getting those kind of AC V from A-B, A-C, and B-C wires then stator sounds good.



                    Comment


                    • #11
                      I checked for continuity through the regulator plug in front to the Male (spade) part of the stator plug and all seemed good. Then I checked the volts going to the regulator plug and they were 30ish at idle then with some throttle over 80 v. Am I safe to assume the stator is good and the regulator is bad? If it is the regulator, do I get one for 05 to 07 or an 04?

                      Comment


                      • #12
                        I’d go for the ‘05-‘07, then if you ever do the upgrade for a higher output stator, you’re half way there.



                        Comment


                        • #13
                          Thank you guys for your help!!

                          Comment


                          • #14
                            Just to let you know the meter might be fine and the probe leads do have some resistance. You should read the probes touching together then subtract that from the stator readings.
                            When checking your charging system you should have the battery charged, first put the meter to read the battery with the engine off, note this reading. Start the bike, watching your meter, if the volts drops below 10.3 volts your battery is weak. After it's started the voltage should be around 13 + or - .3 volts. When revving the engine the voltage should go up to around 14 volts, but if the battery is weak, it could keep the voltage from changing very much. It depends on the battery condition.
                            You mentioned your battery was dead and had someone checked the battery and they said it was good and had 675 cca. I find it hard to beleave your battery has that many amps. We are lucky to have 250 cca in our RS batterys.
                            I'm just saying to make sure the your battery is good, before you spend money on the charging system.
                            Trying to help, Duke.

                            Comment


                            • #15
                              When the battery died I put it on the charger and fully charged it before I had it tested at Advanced Auto. I asked the guy how it was possible to have that many CCA from a battery that was rated at 310 and he didnt have an answer and just said it was good. I have a tester that has a load switch on it and it tested fine on that one also. With the multimeter the battery was at 12.8v before starting it and when I hit the starter it was in the 11's if I remember correctly. After it started it was 12.6 to 12.7 and no change when revved at the battery it would go up and down when I was testing the connections before the regulator but not after.

                              Comment


                              • #16
                                Do you have another rectifier you could try? Make sure you have a good ground on the rectifier mounting screws.

                                Comment


                                • #17
                                  I dont have another one but I will check the ground in the morning before ordering one. Thanks.

                                  Comment


                                  • #18
                                    I got my regulator/rectifier ordered today. I knew they weren't cheap but I didn't realize they were $200. The guy said it listed at $275. I thought that's how much the stator was. Anyone else bought one lately?

                                    Comment


                                  • #19
                                    That is what I was finding also. I double checked with the guy that it wasnt the stator and he said it wasn't. I will see on Tuesday when it's delivered. Thank you.

                                    Comment


                                    • #20
                                      Hey Bud, Just wanting to see if the new regulator fixed your problem? I am having similar issues. Everything on mine has ohm'd out within tolerance. My voltage at start up is right at 13.9/14.2 for about 2 minutes and then drops to 12.6. I'm thinking mine is also a regulator issue. Just curious if the regulator fixed yours.

                                      Comment


                                      • jd750ace
                                        jd750ace commented
                                        Editing a comment
                                        Sounds like your regulator is heating up and failing if it collapses to battery voltage and stays there, regardless of RPM. It is possible to have a winding that will check good on resistance “cold” but expands and goes open when hot, but typically that does not result in a drop all the way down to battery voltage.

                                    Latest Posts

                                    Collapse

                                    Topics Statistics Last Post
                                    Started by roadiemort, 03-05-2018, 08:01 PM
                                    2,852 responses
                                    24,071 views
                                    3 likes
                                    Last Post roadiemort  
                                    Started by zingpow, 5 days ago
                                    35 responses
                                    340 views
                                    0 likes
                                    Last Post Father Pobasturd  
                                    Started by Shores, 11 hours ago
                                    6 responses
                                    48 views
                                    1 like
                                    Last Post Father Pobasturd  
                                    Started by Father Pobasturd, 5 hours ago
                                    9 responses
                                    7 views
                                    0 likes
                                    Last Post Father Pobasturd  
                                    Started by Smokescreens, 4 weeks ago
                                    21 responses
                                    288 views
                                    0 likes
                                    Last Post Shores
                                    by Shores
                                     
                                    Started by jd750ace, 5 days ago
                                    47 responses
                                    610 views
                                    0 likes
                                    Last Post RonK
                                    by RonK
                                     
                                    Started by grubsie, 2 days ago
                                    6 responses
                                    145 views
                                    2 likes
                                    Last Post grubsie
                                    by grubsie
                                     
                                    Started by Shores, 1 day ago
                                    4 responses
                                    87 views
                                    0 likes
                                    Last Post grubsie
                                    by grubsie
                                     
                                    Started by Johnrocks, 2 days ago
                                    4 responses
                                    141 views
                                    0 likes
                                    Last Post Derailed75  
                                    Started by Jeaston, 1 day ago
                                    0 responses
                                    71 views
                                    0 likes
                                    Last Post Jeaston
                                    by Jeaston
                                     
                                    Started by viking, 2 days ago
                                    2 responses
                                    101 views
                                    1 like
                                    Last Post viking
                                    by viking
                                     
                                    Started by Lifeguard, 2 days ago
                                    7 responses
                                    131 views
                                    0 likes
                                    Last Post Tykes_Place  
                                    Started by Txulrich, 04-24-2018, 01:12 PM
                                    642 responses
                                    3,589 views
                                    0 likes
                                    Last Post LDofDC
                                    by LDofDC
                                     
                                    Started by RonK, 3 days ago
                                    12 responses
                                    144 views
                                    0 likes
                                    Last Post scottw
                                    by scottw
                                     
                                    Started by Chksbak, 5 days ago
                                    28 responses
                                    231 views
                                    0 likes
                                    Last Post highvoltage  
                                    Started by cike, 4 days ago
                                    6 responses
                                    181 views
                                    0 likes
                                    Last Post cike
                                    by cike
                                     
                                    Started by davej, 4 days ago
                                    6 responses
                                    180 views
                                    0 likes
                                    Last Post Littlebull  
                                    Started by Jeaston, 1 week ago
                                    27 responses
                                    241 views
                                    0 likes
                                    Last Post Jeaston
                                    by Jeaston
                                     
                                    Started by scottw, 1 week ago
                                    16 responses
                                    200 views
                                    0 likes
                                    Last Post MidwestMike  
                                    Started by Jed Milhorne, 3 weeks ago
                                    49 responses
                                    840 views
                                    0 likes
                                    Last Post BSeward
                                    by BSeward
                                     
                                    Working...
                                    X