Announcement

Collapse
No announcement yet.

Wanting some input from people who have 2008 plus fuel injected Road Stars

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wanting some input from people who have 2008 plus fuel injected Road Stars

    Need input specifically from owners of 2008 through 2014 fuel injected Road Star XV 1700. Me as well as others have experienced a flutter or stumble between 65 and 85 mph when cruising. This goes away with throttle input or getting off the throttle. Otherwise bike runs perfectly. Not related to TPS. I'm thinking possibly related to the power commander 5 I have but more likely related to oxygen sensor simulators. I would like to hear from members who have a fuel injected roadstar that have completely stock exhaust with oxygen sensors hooked up as well as members that have aftermarket exhaust with oxygen sensors hooked up and those that have aftermarket exhaust with either plugs or oxygen sensors left in but unhooked and/or using O2 simulator/delete plugs. Do any of you have that stumble and that certain mile per hour rangeIn fifth gear? I know it's on my bike it seems to be more RPM related because at 60 mph and 5th gear bike runs perfect but if I drop to fourth gear at 60 mph it stumbles and flutters.

    I currently have the Power Commander 5 with a zero tune which means using the factory tune only. I do have the rev limiter bumped up to 4850. fresh fluids filters spark plugs brand new TPS sensor set properly startron through the gas severalVery clean gas tank blew out rollover valve everything checks out 100%. Bike runs amazingly nice except for that stumble when trying to sustain speed between 65 and 85 mph and fifth gear.I have long shot exhaust without O2 bungs and I have the O2 simulators in the wiring harness side of the bike.

    ,on the Facebook site I've heard of other people having very similar issues with and without the tuner. I'm trying to gather more information from people that haveThe same issue I have and to find out what kind of exhaust they're running if they're running any sort of fuel processor or just stock computer and what they're doing about the O2 sensors either keeping them plugged in and working correctly or using simulators.

    So for all you feel injected bike guys if you're not having any issues and your bike is not completely stock what exactly do you have done and if you do have the issue like I'm describing can you tell me what your modifications are right now? Thanks.
    LET'S RIDE

  • #2
    Lug Nut, I have a 09 fuel injected bike that is completely stock with exception of the stock exhaust being altered. I have not experienced a stutter 65-85 MPH range. Most of my riding has been in this window, we often ride the interstate to get to the places we go. The speed limit is usually 75 on the interstate and we are usually 5-10 over.

    Comment


    • Mr. Miyagi
      Mr. Miyagi commented
      Editing a comment
      I also still have the AIS intact. I have the Barron's kit to remove it, but I am just now getting around to putting weight on my knee and have not been in a hurry to get down there to play with removing it.

  • #3
    My '08 still has the stock exhaust (although I'd like to remedy that one day) with the O2 sensors intact. I also have the AIS as I haven't gotten around to removing it yet. I don't have any fuel processor either. I've never noticed any kind of stutter or stumble cruising like you're describing.

    Comment


    • #4
      Seems to be related to aftermarket exhaust and then oxygen sensor delete or simulators more than anything else. The power commander and ignition boxes like that seem to cause other problems. I'm trying to nail things down and hopefully it'll be a simple as welding and new buns and throwing some oxygen sensors back in.
      LET'S RIDE

      Comment


      • Brad_G
        Brad_G commented
        Editing a comment
        I'll be interested to hear how this all plays out. I have some V&H longshots (but missing a chrome cover) and some Hard Chromes that I wanted to put on just for grins to see what they sound like. I was looking into bungs to weld on as I didn't want to dump the O2 sensors. Your issue may reinforce that idea.

    • #5
      Scott, is it possible that the ECU can sense the RPM change from pulley changes and is trying to compensate? Ignore if this bike has stock final drive ratios.

      Comment


      • #6
        Lucy??? What I tol you? Get rid of that paper weight! My 2008 with Freedom true duals and universal K&N filter runs smooth as butter through all speeds and gears.

        Comment


        • #7
          Originally posted by roadiemort View Post
          Scott, is it possible that the ECU can sense the RPM change from pulley changes and is trying to compensate? Ignore if this bike has stock final drive ratios.
          Still stock pulley for now. Didn't want to start changing things so I got this figured out
          LET'S RIDE

          Comment


          • #8
            Originally posted by Shores View Post
            Lucy??? What I tol you? Get rid of that paper weight! My 2008 with Freedom true duals and universal K&N filter runs smooth as butter through all speeds and gears.
            Do you have the stock oxygen sensors in your exhaust? Or are you using the simulators?
            LET'S RIDE

            Comment


            • #9
              I'm getting some input from guys on the Facebook site. It is pointing to the issue being oxygen sensor versus simulator more than anything else.
              LET'S RIDE

              Comment


              • #10
                Originally posted by Lug Nut View Post

                Do you have the stock oxygen sensors in your exhaust? Or are you using the simulators?
                I have the stock O2 sensors. Everything is stock except the exhaust and the intake.

                Comment


                • #11
                  Originally posted by Shores View Post

                  I have the stock O2 sensors. Everything is stock except the exhaust and the intake.
                  I think for the issue that I'm facing it's related to the O2 simulators not doing a good enough job to give the computer proper information. I've eliminated pretty much everything else. And it's a consistent problem after it gets warmed up for a couple miles as if the computer has learned something... And it's that 65 to 85mile per hour range and fifth gear where it does the fluttering.I think I'll buy some buns cut holes and weld into my current exhaust and see how that works. I thought the TPS might be an issue but I tested the old one and it was fine The new one I put on adjusted it very precisely reset it with the computer and for that first night it ran great and then the next day boom same problem creeps back up
                  LET'S RIDE

                  Comment


                  • Shores
                    Shores commented
                    Editing a comment
                    Why worry about it? You don't ride that fast anyway! Plus you never make any radical turns!

                • #12
                  I ride faster than anybody I ride with. We don't make radical turns in Indiana We just keep pace with the corn. This bike is so nice other than that fluctuation from 65 to 85.
                  LET'S RIDE

                  Comment


                  • Shores
                    Shores commented
                    Editing a comment
                    Better fluctuations than flatulence!

                • #13
                  I may find a takeoff set of stock exhaust with 02 bungs and throw it on there and just ride it Or maybe get lucky and find an aftermarket set made for an '08 with bungs already in it. This exhaust I have is wonderful but very loud and would be better off on a little solo bike..
                  LET'S RIDE

                  Comment


                  • #14
                    I'm running Bassani true duals with added O2 bungs for the stock sensors. They were like 15 bucks each because theyre stainless and the less common of the major O2 sizes. 20 bucks to have my pipes drilled and the bungs welded in. I have no issues.

                    Comment


                    • #15
                      Originally posted by EnergyGuy View Post
                      I'm running Bassani true duals with added O2 bungs for the stock sensors. They were like 15 bucks each because theyre stainless and the less common of the major O2 sizes. 20 bucks to have my pipes drilled and the bungs welded in. I have no issues.
                      Do you happen to have the part numbers the size where you got them from etc. I'm trying to get back my original oxygen sensors that came with the bike that I gave with the aftermarket exhaust I sold to a different member.
                      LET'S RIDE

                      Comment


                      • #16
                        https://www.dpfpartsdirect.com/colle...condition=true

                        took me a minute to find the 10x1.25's again, but there ya go!!

                        Comment


                        • EnergyGuy
                          EnergyGuy commented
                          Editing a comment
                          oh.. and the AIS was deleted when I gutted my stock exhaust and added a BigAir Kit a couple of years ago

                          so - BAK, sans AIS, dual exhaust, stock O2's, runs like a scalded dog, no issues with 5th gear / cruise speed throttle fluttering

                        • Brad_G
                          Brad_G commented
                          Editing a comment
                          Thanks for that link! Might have to pick up a couple for some old Hard Chromes I got with a pile of parts.

                        • EnergyGuy
                          EnergyGuy commented
                          Editing a comment
                          I was bumming until I came across these. I didn't want to eliminate my sensors, but I couldn't find any 10mm's anywhere, to start, then finding the bastards in SS. I was threatening to just fab some with a couple of nuts, but I didn't really want to do that, either.

                      • #17
                        I'm either going to change exhaust to one that already has buns welded in or have bungs welded in my current exhaust. I love these pipes but they're very very loud. And this is going to be my long-distance touring bike so I may want to go something a little more reasonable.
                        LET'S RIDE

                        Comment


                        • #18
                          I'm a little late to the party here but here is my setup. '12 RS, Cobra long shot exhaust (hate them but came on the bike), I'm assuming stock O2 sensors, AIS delete, stock intake, no aftermarket ignition computer. No surging/stutter at any speed range/gear, including the one you are asking about.
                          2012 Road Star Silverado S

                          Comment


                          • #19
                            From here and from Facebook input It sure seems like when you use the O2 simulators you get the problems I have. With or without the PC5. So my first step will be to either weldon buns or just get a new exhaust.
                            LET'S RIDE

                            Comment

                            Latest Posts

                            Collapse

                            Topics Statistics Last Post
                            Started by WobblyBoot, 2 hours ago
                            2 responses
                            28 views
                            0 likes
                            Last Post roadiemort  
                            Started by Renegade, 2 weeks ago
                            33 responses
                            339 views
                            0 likes
                            Last Post davej
                            by davej
                             
                            Started by Aussiestar, 11 hours ago
                            7 responses
                            52 views
                            1 like
                            Last Post Ahodge75  
                            Started by MidnightRide, 17 hours ago
                            20 responses
                            94 views
                            0 likes
                            Last Post KFallsRider  
                            Started by Mr. Miyagi, 17 hours ago
                            6 responses
                            41 views
                            2 likes
                            Last Post KFallsRider  
                            Started by Aussiestar, 9 hours ago
                            3 responses
                            34 views
                            0 likes
                            Last Post MikeyC
                            by MikeyC
                             
                            Started by WobblyBoot, 2 days ago
                            15 responses
                            118 views
                            0 likes
                            Last Post Sharpman66  
                            Started by rsnyder1976, 2 days ago
                            6 responses
                            81 views
                            0 likes
                            Last Post rsnyder1976  
                            Started by tekdiver609, 02-03-2019, 07:49 PM
                            25 responses
                            3,129 views
                            0 likes
                            Last Post tekdiver609  
                            Started by Do Something, 3 days ago
                            13 responses
                            120 views
                            0 likes
                            Last Post Lug Nut
                            by Lug Nut
                             
                            Started by Father Pobasturd, 05-24-2019, 02:51 PM
                            1,264 responses
                            15,393 views
                            2 likes
                            Last Post MidnightRide  
                            Started by Leadkrm, 01-10-2019, 06:28 AM
                            13 responses
                            288 views
                            0 likes
                            Last Post Shores
                            by Shores
                             
                            Started by Apsn, 1 week ago
                            41 responses
                            360 views
                            0 likes
                            Last Post Tcontrol  
                            Started by marcus, 1 day ago
                            8 responses
                            97 views
                            0 likes
                            Last Post davej
                            by davej
                             
                            Started by roadiemort, 04-17-2022, 01:19 PM
                            37 responses
                            513 views
                            1 like
                            Last Post roadiemort  
                            Started by scotcher65, 1 day ago
                            6 responses
                            55 views
                            0 likes
                            Last Post Father Pobasturd  
                            Started by Frazdogg, 07-08-2018, 09:14 AM
                            25 responses
                            637 views
                            0 likes
                            Last Post scotcher65  
                            Started by dna9656, 2 days ago
                            2 responses
                            56 views
                            0 likes
                            Last Post Mr. Miyagi  
                            Started by alo1600, 07-13-2021, 07:08 PM
                            29 responses
                            431 views
                            0 likes
                            Last Post davej
                            by davej
                             
                            Started by Overkill777, 2 days ago
                            2 responses
                            66 views
                            1 like
                            Last Post SbTx_Rider  
                            Working...
                            X