Announcement

Collapse
No announcement yet.

2008 FI Won’t start- I believe fuel issue- Help.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2008 FI Won’t start- I believe fuel issue- Help.

    I had posted a question yesterday regarding fuel filter location or if there even was one.. but wanted to start a new thread on broader subject. I have a 2008 that has been sitting for some time.. ~ 2 years with little use.. Electrical system seems find and the bike turns over just fine.. just not firing up.. I’m getting spark at the plugs.. The tank has some rust in it.. I’ve taken the tank off, emptied the old fuel and put some clean fuel in, drained it again and not have it fueled up again and back on the bike.. I have the fuel tank fittting off at the moment (blue tab) and cranking the bike looking for fuel to come out.. I don’t see any fuel coming out of the tank/fuel pump when cranking.. I’m assuming fuel should pulse out of the tank when cranking? Thoughts on the above? Any help would be appreciated. Thanks.

  • #2
    I have a 2008 also and have never had any trouble. I would not assume that by removing the fuel line you would be able to have fuel spewing out the line when cranking over. I just don't know. Since you have had rust in the tank, I would assume that somewhere down the line you have rust plugging the system, possibly the injectors themselves. Since it was sitting, you may also have ethanol fuel that has turned to gel in the fuel system. Ethanol attracts moisture and over time will turn to gel. The only thing I can suggest is that you take the fuel system apart as much as possible and clean everything out. I would also test the voltage of your battery as you are cranking the starter and let us know the reading. A battery that tests 12 volts just sitting does not necessarily have the power to fire up the system when cranking.

    Comment


    • #3
      Also you have this thread posted in the classifieds which does not show up unless readers totally refresh the screen by pushing the road star icon at the top left of the page. I suggest you move it to the technical section.

      Comment


      • #4
        Not sure if a mod can move this thread for you as Shores indicated it's in the classifieds. That or edit the above post by deleting the text and posting again in the bike talk area.

        When you do a little back story might help as well. I presume it ran fine up until it was parked? When you turn on the key, do you hear the pump run for a few seconds and build up pressure? There's a member in Florida who's been working on an issue of the pump not coming on. He sent his ECU and relay to me to put on my bike to test and make sure they were good.

        Lots of possibilities here so just need to methodically go through them and test/verify.

        Comment


        • #5
          Thanks much.. not sure how i put this in classifieds.. ughgh. I’ll delete and repost properly..

          Comment

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by brianmac, 2 days ago
          2 responses
          62 views
          0 likes
          Last Post J89k
          by J89k
           
          Started by Bnag0, 04-13-2022, 11:05 PM
          106 responses
          1,334 views
          1 like
          Last Post Bnag0
          by Bnag0
           
          Started by Mad Maj, 2 days ago
          25 responses
          214 views
          0 likes
          Last Post Father Pobasturd  
          Started by dna9656, 5 hours ago
          2 responses
          18 views
          0 likes
          Last Post dna9656
          by dna9656
           
          Started by KFallsRider, 16 hours ago
          11 responses
          107 views
          0 likes
          Last Post KFallsRider  
          Started by dna9656, 1 day ago
          8 responses
          72 views
          0 likes
          Last Post Ahodge75  
          Started by Kmartcivic, 2 days ago
          7 responses
          107 views
          0 likes
          Last Post Chromepony  
          Started by Sykobox, 2 days ago
          16 responses
          135 views
          0 likes
          Last Post Chromepony  
          Started by KFallsRider, 2 days ago
          16 responses
          137 views
          0 likes
          Last Post Chromepony  
          Started by ElVispo, 01-25-2022, 07:34 AM
          100 responses
          1,756 views
          4 likes
          Last Post ElVispo
          by ElVispo
           
          Started by dna9656, 1 day ago
          3 responses
          70 views
          0 likes
          Last Post dna9656
          by dna9656
           
          Started by roadiemort, 3 days ago
          7 responses
          49 views
          0 likes
          Last Post LDofDC
          by LDofDC
           
          Started by Tykes_Place, 11-17-2021, 12:09 AM
          122 responses
          1,535 views
          2 likes
          Last Post Shores
          by Shores
           
          Started by 6door7r, 2 days ago
          14 responses
          90 views
          0 likes
          Last Post 6door7r
          by 6door7r
           
          Started by roadiemort, 2 days ago
          0 responses
          38 views
          0 likes
          Last Post roadiemort  
          Started by Mad Maj, 2 weeks ago
          14 responses
          194 views
          0 likes
          Last Post Mad Maj
          by Mad Maj
           
          Started by 6door7r, 6 days ago
          5 responses
          130 views
          3 likes
          Last Post Chromepony  
          Started by Lug Nut, 3 days ago
          4 responses
          84 views
          0 likes
          Last Post Lug Nut
          by Lug Nut
           
          Started by Tykes_Place, 4 weeks ago
          27 responses
          335 views
          0 likes
          Last Post Lug Nut
          by Lug Nut
           
          Started by p birk, 1 week ago
          16 responses
          179 views
          0 likes
          Last Post Tcontrol  
          Working...
          X