Announcement

Collapse
No announcement yet.

Gas tank sending unit

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Gas tank sending unit

    Where can I buy a new gas tank sending unit
    I'm in Oakville ontario

  • #2
    Somebody help me out here

    Comment


    • #4

      Originally my gauge did not register when filled and the "low" gauge light flashed 8 times.
      I installed a new OEM gas tank sending unit and when the tank is filled
      the gauge only goes too half full.
      I think I read something on the forum a long time ago that there are some issues
      with the OEM sending units, somthing obout aftermarket units are better.
      Is there such an AM unit??
      Also how do you check the gauge unit.
      Please advise.
      Thank you.

      Comment


      • roadiemort
        roadiemort commented
        Editing a comment
        How far did you ride it after the fix?

    • #5
      I road 20 klm and the gauge won't go past 1/2 full.

      Comment


      • #6
        I would check the sending unit with an ohmmeter, per the service manual. Make sure it reads correctly. Also, you might want to try some electrical contact cleaner on the wiring connector - just make sure the cleaner you use is safe for plastics.

        Comment


        • #7
          Rock River Powersports at the bottom of this page. They sponsor this forum.

          “The West is the Best" - Jim Morrison

          Comment


          • #8
            I want to know how you check the "gauge" not the sending unit

            Comment


            • #9
              Your gauge needle might be sticking. Look up posts for sticking speedometer issues.

              Comment


              • #10
                Thank's boomerA but I found out the problem and I'm the problem.
                I put the sending unit in backwards
                I turned it 180 and everything is good.

                Comment


                • #11
                  Yeah, that DOES make a difference!

                  Comment


                  • #12
                    I have another problem. I took off the intake manifold and all the rubber near the intakes
                    that goes too the heads is crispy crunch. Bits and pieces have flaked off. I wondered why the engine didn't run wright sometimes.
                    I'v been removing all the loose hard rubber off the metal that will come off, so what now??
                    Do I dremel down the rubber that's still tight too the metal so it 's nice flush with metal,
                    go ahead and port the manifold and reinstall it or what??
                    I need some input hear guys.
                    Thank you.

                    Comment


                    • #13
                      Crispy cracked manifolds are a part of R* ownership... it's from all the heat in between the cylinders. However, that manifold is *very* thick. often crack that appear really bad don't go all the way through... More common is a leak at the mating surface once you remove the manifold... Best solution is to replace the o-rings with new OEM o-rings... As for porting inside, you can certainly do that to clean it up.. many of us have... In fact, Curt, a long time member, used to sell ported manifolds... But unfortunately he no longer does that. You can buy an aftermarket one, but they're not as good as just doing it yourself.

                      Some have gone with Permatex Blue... but it's messy as hell and not a guarantee.. Definitely don't use it with paper fiber home made gaskets instead of the rubber o-ring... Ask me how I know.

                      Comment


                      • techguy
                        techguy commented
                        Editing a comment
                        I cleaned up the manifold and ported it. I use a slight surface skim of hi temp red Permatex.
                        The engine works like it should.
                        Thanks Doc.

                    • #14
                      Originally posted by techguy View Post
                      Thank's boomerA but I found out the problem and I'm the problem.
                      I put the sending unit in backwards
                      I turned it 180 and everything is good.
                      The other day when you posted that it was only showing 1/2 full, I responded, but forgot to hit the Post Reply button. Glad you figured it out for yourself.



                      Comment


                      • #15
                        Thank you Bikerron.
                        Good looking ride.

                        Comment

                        Latest Posts

                        Collapse

                        Topics Statistics Last Post
                        Started by Milkman, 5 hours ago
                        7 responses
                        56 views
                        0 likes
                        Last Post Doc_V
                        by Doc_V
                         
                        Started by Milkman, 5 hours ago
                        2 responses
                        46 views
                        0 likes
                        Last Post scottw
                        by scottw
                         
                        Started by orthogonal, 8 hours ago
                        7 responses
                        57 views
                        0 likes
                        Last Post scottw
                        by scottw
                         
                        Started by simko9468, 2 days ago
                        19 responses
                        111 views
                        0 likes
                        Last Post rsokie
                        by rsokie
                         
                        Started by roadiemort, 03-05-2018, 07:01 PM
                        2,295 responses
                        19,890 views
                        3 likes
                        Last Post LDofDC
                        by LDofDC
                         
                        Started by drumsonly2002, 22 hours ago
                        5 responses
                        77 views
                        0 likes
                        Last Post drumsonly2002  
                        Started by Cmw2212, 12 hours ago
                        10 responses
                        102 views
                        1 like
                        Last Post scottw
                        by scottw
                         
                        Started by dadiezel07, 1 day ago
                        23 responses
                        165 views
                        1 like
                        Last Post jd750ace  
                        Started by Fat pete, 17 hours ago
                        4 responses
                        47 views
                        0 likes
                        Last Post Fat pete  
                        Started by Jon1985, 8 hours ago
                        2 responses
                        51 views
                        0 likes
                        Last Post Jon1985
                        by Jon1985
                         
                        Started by clover51, 9 hours ago
                        2 responses
                        31 views
                        0 likes
                        Last Post Doc_V
                        by Doc_V
                         
                        Started by Leadkrm, 4 days ago
                        33 responses
                        194 views
                        0 likes
                        Last Post MikeyC
                        by MikeyC
                         
                        Started by Doc_V, 2 days ago
                        8 responses
                        170 views
                        0 likes
                        Last Post Doc_V
                        by Doc_V
                         
                        Started by Brad_G, 1 day ago
                        11 responses
                        125 views
                        0 likes
                        Last Post scottw
                        by scottw
                         
                        Started by grubsie, 14 hours ago
                        2 responses
                        61 views
                        0 likes
                        Last Post scottw
                        by scottw
                         
                        Started by Txulrich, 04-24-2018, 12:12 PM
                        628 responses
                        3,445 views
                        0 likes
                        Last Post roadiemort  
                        Started by Coach, 1 day ago
                        15 responses
                        142 views
                        0 likes
                        Last Post Coach
                        by Coach
                         
                        Started by Ypsilonn, 02-24-2018, 01:22 AM
                        34 responses
                        1,307 views
                        1 like
                        Last Post Ypsilonn  
                        Started by viking, 5 days ago
                        38 responses
                        294 views
                        0 likes
                        Last Post Leadkrm
                        by Leadkrm
                         
                        Started by Messer2.0, 1 day ago
                        9 responses
                        116 views
                        0 likes
                        Last Post blueverclear  
                        Working...
                        X