Announcement

Collapse
No announcement yet.

Hello from Michigan

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Jclevesque
    replied

    Leave a comment:


  • sprt220
    replied
    From Madera,Ca.

    Leave a comment:


  • Brad_G
    replied
    from Solon, IA

    Leave a comment:


  • Ace
    replied
    from beautiful Burketon, Ontario...Ace

    Leave a comment:


  • highvoltage
    replied
    fromConway, SC

    Leave a comment:


  • Duke
    replied
    . From the Four Corners area, northwest New Mexico.

    Leave a comment:


  • LUV4RS
    replied
    Welcome! The guys here always have great information and tips. Been learning a lot about my bike here.

    Leave a comment:


  • Smokescreens
    replied
    and the manual is still wrong on the amount of oil just put 4 qts in and forget about the other .3qts.


    im in michigan as well. harrison township right by metro beach

    Leave a comment:


  • Wonky1
    replied

    Leave a comment:


  • Chromepony
    replied
    from Athens, Georgia.
    8 qts ? !
    Holy crap !
    Don't do that again.

    Leave a comment:


  • roadiemort
    replied
    Attached Files

    Leave a comment:


  • davej
    commented on 's reply
    My MIL used to live in the 2nd house on Hix South of Cherry Hill. Across from the 711. I retired from Metro Airport Authority. I worked in the Equipment Repair Div.

  • mlharper
    replied
    What Dave said, from Plano Texas.

    Leave a comment:


  • DDsRS
    replied
    By the way Davej I'm near Cherry Hill and John Hix.

    Leave a comment:


  • DDsRS
    replied
    Thanks Davej. I myself have been a mechanic for 34 years, although in the diesel truck field. Have been riding for longer. I do understand the procedure for checking the oil level. I just never had this situation for the 4 prior years of owning this bike. I've spent a lot of time researching the oil flow of the RS and have had concerns about the double sided oil pump. Specifically the scavenger side that returns the oil to the reservoir.

    Leave a comment:


  • davej
    replied
    I see you are from Westland Mi. I just moved to Toledo from Westland where I lived for over 40 years. I was at Joy/Merriman I've been here about 4 years now. I am also a retired Mechanic.
    These guys gave you good info on the leak. That hose is usually rerouted to up under the tank with a breather element on the end or down and to the ground . There is a special procedure to check the oil so no one checks it. We all put 4 qts in at the oil change and forget about it. These things don't leak or use oil in between changes. except out of that tube if they are overfilled. It has a semi dry sump and the oil in the tank will never be the same when you check it unless you follow the procedure.
    Here is the procedure, Watch the video and you will understand why we don't bother checking it.

    https://www.youtube.com/watch?v=QjG18WGbHMg

    Leave a comment:


  • Father Pobasturd
    replied
    You have no leak, it's just got too much oil in it. It's gotta go somewhere!

    Leave a comment:


  • DDsRS
    replied
    I've always had oil on the dipstick prior to this. The oil that was dripping came from the air filter housing and crossed over to the left side as the bike leaned that way on the side stand.

    Leave a comment:


  • Shores
    replied
    Never check the oil with the dipstick and never add oil. just add four quarts and ride it until it's time to change it again. You were obviously blowing oil out the rear valve cover your other leak is likely from behind the primary drive pulley.

    Leave a comment:


  • DDsRS
    started a topic Hello from Michigan

    Hello from Michigan

    I'm new here to Road Star Clinic and hoping someone may be able to help me figure out my problem. I could write a long explanation but I start with a shorter version. I've owned my 2005 RS Silverado 1700 for 5 years with no problems at all. This problem started last year after changing the oil and not immediately. I started noticing a small spot of oil under the left side after bike sat following any ride. So checking the oil level as you are supposed to I added oil. This persisted throughout a month or so.I removed the air cleaner housing and started the engine. Oil was coming out of the breather tube from the rear cylinder to the air cleaner housing. I started researching and was unable to come up with any pertinent info. I decided to drain the oil and replaced the filter and to my dismay 8 qts of oil drained out. And yes I drained both the crankcase and the reservoir. So I refilled according to directions and still had the same situation. I have more info if anyone has any ideas. Just thought I would start with this.
    Hope to get to enjoy this forum and lend advice for anyone in need.

Latest Posts

Collapse

Topics Statistics Last Post
Started by mariner3302, 18 hours ago
5 responses
66 views
0 likes
Last Post MikeyC
by MikeyC
 
Started by Smokescreens, 03-05-2018, 10:34 AM
273 responses
5,819 views
14 likes
Last Post Shores
by Shores
 
Started by Lug Nut, 2 hours ago
4 responses
44 views
0 likes
Last Post Lug Nut
by Lug Nut
 
Started by Doc_V, 21 hours ago
12 responses
159 views
0 likes
Last Post Bikerron  
Started by McVinny614, 1 week ago
7 responses
150 views
0 likes
Last Post mlharper  
Started by Smokescreens, 06-17-2020, 09:49 AM
13 responses
217 views
2 likes
Last Post MrG
by MrG
 
Started by MrG, 15 hours ago
1 response
33 views
0 likes
Last Post Shores
by Shores
 
Started by Flyinfish, 6 days ago
23 responses
134 views
0 likes
Last Post 2time
by 2time
 
Started by gonzarelloz, 1 day ago
11 responses
51 views
1 like
Last Post 2time
by 2time
 
Started by Shores, 1 week ago
33 responses
320 views
1 like
Last Post JimH
by JimH
 
Started by JoeX, 5 days ago
18 responses
149 views
2 likes
Last Post JimH
by JimH
 
Started by Galcanised, 1 week ago
17 responses
168 views
5 likes
Last Post EP Roadie  
Started by MrG, 3 weeks ago
12 responses
177 views
0 likes
Last Post LUV4RS
by LUV4RS
 
Started by Lug Nut, 2 days ago
17 responses
250 views
1 like
Last Post Littlebull  
Started by chromax, 5 days ago
11 responses
232 views
2 likes
Last Post Sharpman66  
Started by MikeyC, 2 days ago
8 responses
102 views
0 likes
Last Post Sharpman66  
Started by Lug Nut, 3 days ago
2 responses
135 views
3 likes
Last Post Sharpman66  
Started by MikeyC, 2 days ago
12 responses
124 views
0 likes
Last Post Sharpman66  
Started by Lug Nut, 2 days ago
4 responses
88 views
2 likes
Last Post Sharpman66  
Started by GreenMachine, 08-13-2020, 12:19 PM
242 responses
2,489 views
3 likes
Last Post GreenMachine  
Working...
X