Announcement

Collapse
No announcement yet.

Speedo finally quit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Speedo finally quit

    Seems I fix one thing and something else happens. Have had intermittent speedometer issues where it would show 10mp when I was around 40. Occasionally the test sweep of the speedo guage wouldn't work but the fuel guage would. Now it seems like its completely out. No reading, no test sweep etc. I'm lucky though the odometer is still running as thats my only fuel guage (fuel guage never worked).

    The a common problem with a sensor or the gauges its self? Is it fixable or have to buy another cluster for the bike? Where is the speed sensor located too?

    Thanks for the help.
    Remember. No matter where you go, there you are.

  • #2
    The speed sensor is pointed at the transmission countershaft its just to the right of frame down post under the seat, if you look down in front of the oil fill you can see 3 wires going into it, looks like it would be a bitch to replace

    Comment


    • #3
      Speed sensor is about $100 and a pain to change. Email me and I can give you some pointers....did mine last summer.
      "I'm Ricky Bobby. If you don't chew Big Red.....then Fuck You"

      Comment


      • #4
        This is a common problem. Mine did the same thing. Every once in a while it'll start working again. Fortunately for me, I don't care if any of the gauges work.

        Comment


        • #5
          The speed sensor is okay or the odometer wouldn't be working.. Same thing happened to my '99. Replaced the speedo with one from a 2006 and it has worked every since.
          Scott B.

          Comment


          • twowheeltherapy
            twowheeltherapy commented
            Editing a comment
            I have the same issue with my speedometer AND MY ODOMETER. So does that mean I have two separate issues? To fix the speed sensor will only fix the odometer? All three gauges (speed, odometer, fuel) failed over 6 month period. I've only replaced fuel sending unit but it failed after a week. I've been living with it now for years. Sorry if this is stealing the thread but your comment was the first I've heard about speed sensor possibly being the issue for odometer.

        • #6
          Could be as simple as a stuck needle. A little tedious , but you can take the Speedo face off and apply a tiny drop of , I used Pnuematic Tool oil , on the needle shaft . It worked for mine 4 years ago . and WAY less then a new Speedo , even a used one .

          Comment


          • #7
            Another type of oil you can use on the speedo and the fuel gauge is fishing reel oil or (a bit harder to find, sewing machine oil) Once you have to instrument cluster taken apart enough to access the speedo, put a drop or two on the shaft the indicating needle is mounted on, cycle it manually the full range of its motion a few times, and again apply a drop or two of the oil. Use a cotton swab or a tissue to wipe up excess oil and reassemble. I have done this multiple times on my '07 RoadStar. DO NOT use electrical contact cleaner on this instrument....it REMOVES the paint on the face of the instrument (a very difficult to find piece (Don't even consider Custom Gauge- he never delivers what he advertises.

            Comment


            • #8
              Since you have it apart you might consider refreshing the light bulbs.

              Comment


              • #9
                +1 for oiling the needle. I also clean the needle with rubbing alcohol to remove any stickiness. Careful not to get it on the actual speedometer though - it'll remove paint.

                Comment


                • #10
                  Alright all, thank you. Will give a few of those items a try and see what works.
                  Remember. No matter where you go, there you are.

                  Comment


                  • #11
                    bump

                    Comment


                    • #12
                      So this weekend I finally took the instruments out and apart. Sure enough the dials were sticking to the stop posts. When moving them with my fingers you could actually feel them stick to the posts. I put a little bit of air tool oil on the stems and worked it around. Put everything together and it worked fine. I wasn't able to find any of those plastic earring backs that should help the needle from sticking but when I do I'll put those on too.
                      Remember. No matter where you go, there you are.

                      Comment

                      Latest Posts

                      Collapse

                      Topics Statistics Last Post
                      Started by SPislanderATX, 5 hours ago
                      3 responses
                      36 views
                      0 likes
                      Last Post Bikerron  
                      Started by badger2078, 2 hours ago
                      2 responses
                      11 views
                      0 likes
                      Last Post badger2078  
                      Started by TataMichas, 5 hours ago
                      3 responses
                      29 views
                      0 likes
                      Last Post Lug Nut
                      by Lug Nut
                       
                      Started by Bricejevinn, 7 hours ago
                      3 responses
                      40 views
                      0 likes
                      Last Post Bricejevinn  
                      Started by petr.hw, 14 hours ago
                      3 responses
                      59 views
                      0 likes
                      Last Post mlharper  
                      Started by Pauli466, 7 hours ago
                      1 response
                      32 views
                      0 likes
                      Last Post Shores
                      by Shores
                       
                      Started by Shores, 9 hours ago
                      0 responses
                      58 views
                      0 likes
                      Last Post Shores
                      by Shores
                       
                      Started by petr.hw, 14 hours ago
                      2 responses
                      52 views
                      2 likes
                      Last Post Chromepony  
                      Started by TEXenvy, 3 days ago
                      11 responses
                      190 views
                      0 likes
                      Last Post Chromepony  
                      Started by Father Pobasturd, 3 days ago
                      31 responses
                      332 views
                      0 likes
                      Last Post Zman
                      by Zman
                       
                      Started by Herrindude, 3 weeks ago
                      10 responses
                      194 views
                      0 likes
                      Last Post Lug Nut
                      by Lug Nut
                       
                      Started by JD64k, 03-27-2018, 06:39 PM
                      170 responses
                      6,308 views
                      3 likes
                      Last Post JD64k
                      by JD64k
                       
                      Started by roadiemort, 3 days ago
                      33 responses
                      57 views
                      0 likes
                      Last Post roadiemort  
                      Started by Primetime64, 2 days ago
                      3 responses
                      106 views
                      0 likes
                      Last Post Chromepony  
                      Started by Jaybo, 02-08-2020, 05:54 PM
                      58 responses
                      762 views
                      3 likes
                      Last Post Chromepony  
                      Started by Father Pobasturd, 01-12-2020, 11:43 PM
                      1,476 responses
                      2,477 views
                      0 likes
                      Last Post TheBru
                      by TheBru
                       
                      Started by toms03se, 4 days ago
                      6 responses
                      108 views
                      0 likes
                      Last Post mlharper  
                      Started by coreys1982, 1 week ago
                      14 responses
                      162 views
                      0 likes
                      Last Post coreys1982  
                      Started by Agpilot, 3 days ago
                      7 responses
                      180 views
                      0 likes
                      Last Post Brad_G
                      by Brad_G
                       
                      Started by Primetime64, 2 days ago
                      10 responses
                      128 views
                      0 likes
                      Last Post Shores
                      by Shores
                       
                      Working...
                      X