Announcement

Collapse
No announcement yet.

Rear speaker/amp question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Smokescreens
    replied
    if both speakers dont work its likely the amp lost power/broke or disconnected wires

    Leave a comment:


  • Makriluc
    replied
    Just try to connect a 1.5 volts battery (AA or AAA type) to the speaker wires (polarity is not important) and if you hear a thump or see the speaker move, then you'll know it is not the speaker. Don't worry you can't damage them.

    Leave a comment:


  • YZ18
    commented on 's reply
    No old ones around that I know of. I will look for a fuse. Thanks.

  • daveto
    replied
    You got any old speakers laying around you could try? Is there a fuse on or before the amp and is it good?

    Leave a comment:


  • YZ18
    replied
    While I understand that, I would think that someone with more knowledge about speakers/amp would be able to help.

    Leave a comment:


  • Spydr
    replied
    You'll probably have to try one of the HD forums for info about an Ultra.

    Leave a comment:


  • YZ18
    started a topic Rear speaker/amp question

    Rear speaker/amp question

    So my parents recently bought a new to them a 2003 Ultra classic. A few days ago the rear speakers are not working. How can we tell if they are bad, if the amp is still good or could it be the rocker switch in the fairing? I appreciate any assistance with this issue.

Latest Posts

Collapse

Topics Statistics Last Post
Started by cromwell, 1 week ago
15 responses
110 views
0 likes
Last Post cromwell  
Started by roadiemort, 1 week ago
33 responses
70 views
0 likes
Last Post roadiemort  
Started by Shores, 2 days ago
9 responses
189 views
0 likes
Last Post Jaybo
by Jaybo
 
Started by cike, 8 hours ago
2 responses
24 views
0 likes
Last Post Lug Nut
by Lug Nut
 
Started by jdhard0341, 2 days ago
4 responses
73 views
0 likes
Last Post brianmac  
Started by rondo_calrissian, 2 days ago
4 responses
97 views
0 likes
Last Post Shores
by Shores
 
Started by Jed Milhorne, 04-20-2019, 03:48 AM
17 responses
239 views
0 likes
Last Post D-Fresh
by D-Fresh
 
Started by Jeaston, 5 days ago
8 responses
239 views
0 likes
Last Post Flashback  
Started by Father Pobasturd, 1 week ago
64 responses
523 views
0 likes
Last Post TheBru
by TheBru
 
Started by Pauli466, 1 day ago
3 responses
92 views
0 likes
Last Post Jclevesque  
Started by GreasySam, 10-03-2019, 06:13 AM
14 responses
236 views
0 likes
Last Post GreasySam  
Started by Grease, 03-04-2019, 09:08 PM
41 responses
857 views
0 likes
Last Post GreasySam  
Started by Bricejevinn, 4 days ago
6 responses
142 views
0 likes
Last Post GreasySam  
Started by Thee_masonator, 07-31-2019, 12:29 AM
11 responses
246 views
0 likes
Last Post Spydr
by Spydr
 
Started by daveto, 02-17-2018, 10:47 AM
13 responses
438 views
0 likes
Last Post Thee_masonator  
Started by JoeBloShmo, 5 days ago
6 responses
135 views
1 like
Last Post KCpartsguy  
Started by torquemada163, 4 days ago
7 responses
92 views
0 likes
Last Post torquemada163  
Started by torquemada163, 11-21-2019, 07:41 AM
25 responses
437 views
0 likes
Last Post torquemada163  
Started by area1509, 11-12-2019, 05:31 PM
20 responses
409 views
0 likes
Last Post Duke
by Duke
 
Started by Dick M, 5 days ago
6 responses
126 views
0 likes
Last Post Tropicalrs  
Working...
X